Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compose key does not produce characters above UFFFF
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Phobos4711
n00b
n00b


Joined: 04 Oct 2018
Posts: 5

PostPosted: Sun Feb 10, 2019 6:54 pm    Post subject: Compose key does not produce characters above UFFFF Reply with quote

I am running GNOME and I have mapped my ALT GR key as the compose key via the tweak tool.

My locale is de_DE.UTF-8 and I'm using ('xkb' 'us') as the GNOME input source.

I have set GTK_IM_MODULE=xim in my ~/.xprofile

The compose key works great for all compose sequences in the UCS-2 range (so below U10000), but it fails for higher Unicode code points.

For example there is a definition for the poo symbol in /usr/share/X11/locale/en_US.UTF-8/Compose :

Code:

<Multi_key> <p> <o> <o>                 : "????"  U1F4A9 # PILE OF POO


On the other hand there is a definition for CCCP:

Code:

<Multi_key> <C> <C> <C> <P>             : "☭"   U262D # HAMMER AND SICKLE


That one works just fine! Is my computer a communist? :wink:

It seems that any code point above UFFFF can not be typed using the compose key. Why? Is there a workaround?

Also it seems that I can't use a double compose key sequence, I'm trying to use the emojis from https://github.com/kragen/xcompose.

For example:

Code:

<Multi_key> <Multi_key>  <v> <i> <c> <t> <o> <r> <y> :  "✌"   U270C     # VICTORY HAND


This should work, since it is below U10000, but it doesn't. The input method doesn't let me enter a double compose key sequence, it seems to abort when seeing the second key press …
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Sun Feb 10, 2019 8:13 pm    Post subject: Reply with quote

I've noticed the same. I don't think settings make any difference, using en_GB.utf8 and no xim here. It just doesn't work whatsoever.

Maybe it's an inherent limitation of X11? I've had problems with keyboards emitting keycodes > 255 too.

Does make me wonder why they'd bother putting those characters in the system xcompose files though.
Back to top
View user's profile Send private message
Phobos4711
n00b
n00b


Joined: 04 Oct 2018
Posts: 5

PostPosted: Mon Feb 11, 2019 7:13 am    Post subject: Reply with quote

It seems like GNOME is using ibus and ibus and / or GNOME have several issues with the compose key:

https://github.com/ibus/ibus/issues/1990

https://github.com/ibus/ibus/issues/1819

https://github.com/ibus/ibus/issues/2074

So, at least the issues are known upstream.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum