Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X - no mouse or keyboard [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tenspd1370
Tux's lil' helper
Tux's lil' helper


Joined: 14 Dec 2017
Posts: 78

PostPosted: Wed Feb 06, 2019 5:07 am    Post subject: X - no mouse or keyboard [solved] Reply with quote

Hi all - I just did an update world, and now X is not picking up my keyboard or mouse. In the Xorg log - I keep seeing the message:

[ 1433.097] (WW) Warning, couldn't open module libinput
[ 1433.097] (EE) Failed to load module "libinput" (module does not exist, 0)
[ 1433.097] (EE) No input driver matching `libinput'

libinput-1.12.6 and xf86-input-libinput-0.28.1 are installed, libinput list-devices shows everything.

emerge --info
https://pastebin.com/AUpeqAeT

Xorg.0.log (generated from start x with just xterm in my .xinitrc)
https://pastebin.com/E3DvT4ns

I would appreciate any help. I had to dig all this up by ssh'ing into my machine, and when I manually kill X, everything is frozen - it does not go back to a terminal.

Thanks.

***********************************************
ok - that was wierd - I just rebuilt libinput and xf86-input-libinput and things started working again. Hmmmm - probably better do an x11-module-rebuild to be safe....
***********************************************
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum