Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] baloo_file_extr segfaulting
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 23 May 2006
Posts: 1122

PostPosted: Sun Feb 03, 2019 9:04 pm    Post subject: [solved] baloo_file_extr segfaulting Reply with quote

I recently observed tons of baloo_file_extr segfaulting in dmesg. Is this a known bug? Or should I file a bug Is there a known way to fix? Although, I am not unhappy, if this thing does not generate loads of I/O on my disk all the time :D

[ 8896.693093] Code: 05 a5 72 20 00 8b 4e 04 48 89 07 85 c9 7e 3b 48 89 d5 31 db 31 c9 4c 8d 6c 24 20 4c 8d 74 24 18 48 8b 7e 10 89 da 48 8d 04 3e <0f> b6 04 18 3c 01 74 48 44 8d 7b 01 84 c0 0f 84 5c 01 00 00 48 ff
[ 8897.404616] baloo_file_extr[2783]: segfault at 7fc40001bef1 ip 00007fc404081d40 sp 00007ffc4faad7d0 error 4 in[7fc404056000+32000]
[ 8897.404623] Code: 05 a5 72 20 00 8b 4e 04 48 89 07 85 c9 7e 3b 48 89 d5 31 db 31 c9 4c 8d 6c 24 20 4c 8d 74 24 18 48 8b 7e 10 89 da 48 8d 04 3e <0f> b6 04 18 3c 01 74 48 44 8d 7b 01 84 c0 0f 84 5c 01 00 00 48 ff
[ 8897.604969] baloo_file_extr[2824]: segfault at 1 ip 00007f234d6f1c6b sp 00007fffe98fb740 error 4 in[7f234d6da000+32000]
[ 8897.604975] Code: 48 31 c9 48 8d 4c 24 30 48 89 57 08 48 8b 38 48 8d 54 24 20 e8 c6 1c ff ff 3d b2 87 ff ff 74 4f 48 8b 74 24 38 48 8d 7c 24 18 <48> 8b 06 48 83 c6 08 48 89 03 8b 44 24 30 8d 50 f8 e8 ff 1d ff ff
[ 8898.013835] traps: baloo_file_extr[2885] general protection fault ip:7fd0e0542d40 sp:7ffc2601ab80 error:0 in[7fd0e0517000+32000]
[ 8898.233991] baloo_file_extr[2933]: segfault at 1 ip 00007f9acd24a505 sp 00007fff10a1d0e8 error 4 in[7f9acd0fe000+1c3000]
[ 8898.234001] Code: f0 04 00 77 20 4d 63 0c 93 48 01 d6 48 01 d7 4d 01 d9 41 ff e1 0f 0b 0f 1f 40 00 66 2e 0f 1f 84 00 00 00 00 00 40 38 fe 7e 5b <f3> 0f 6f 06 48 89 f9 48 83 e7 f0 48 83 c7 10 49 89 c8 48 29 f9 48

emerge --info
Portage 2.3.51 (python 3.6.5-final-0, default/linux/amd64/17.0/desktop/plasma, gcc-7.3.0, glibc-2.27-r6, 4.20.5-gentoo x86_64)
System uname: Linux-4.20.5-gentoo-x86_64-AMD_Ryzen_5_1600_Six-Core_Processor-with-gentoo-2.6
KiB Swap:   33554428 total,  33551100 free
Timestamp of repository gentoo: Sun, 03 Feb 2019 20:30:01 +0000
Head commit of repository gentoo: 24a1522c7c0d28bd2d093c19c79d2fc6fb82d4ce
sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.30 p5) 2.30.0
app-shells/bash:          4.4_p23-r1::gentoo
dev-lang/perl:            5.26.2::gentoo
dev-lang/python:          2.7.15::gentoo, 3.6.5::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.29::dantrell-gnome
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.30-r4::gentoo
sys-devel/gcc:            7.3.0-r3::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.14-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r6::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1

    location: /var/lib/layman/seden
    masters: gentoo
    priority: 50

    location: /var/lib/layman/dantrell-gnome-3-30
    masters: gentoo
    priority: 100

    location: /usr/local/portage
    masters: gentoo
    priority: 100

    location: /var/lib/layman/dantrell-gnome
    masters: gentoo
    priority: 150

CFLAGS="-O2 -march=znver1"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=znver1"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de de_DE el en fr fr_FR it tr"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac acl acpi activities aes alsa amd64 avx avx2 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord crypt cups cxx d3d9 dbus declarative dri dri3 dts dvd dvdr eds egl elogind emboss encode evo exif fam ffmpeg flac fma3 fortran frei0r gdbm gif glamor gnome gnome-keyring gnome-online-accounts gnutls gpm gtk gtk3 gtkstyle iconv icu introspection ios ipv6 jpeg kde kipi kwallet lcms ldap libinput libnotify libsecret libtirpc llvm lm_sensors mad mmx mmxext mng mp3 mp4 mpeg mtp multilib nautilus ncurses nls nptl ocr ogg openal opencl opengl openmax openmp osmesa pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qml qt5 rdp readline realtime s3tc scanner sdl seccomp semantic-desktop spell spice sse sse2 sse3 sse4_1 sse4_2 sse4a ssh ssl ssse3 staging startup-notification svg tcpd theora tiff tracker truetype udev udisks unicode upower usb vaapi vdpau vhost-net vkd3d vnc vorbis vpx vulkan wayland webrtc-aec widgets wxwidgets x264 xa xattr xcb xcomposite xml xv xvid xvmc zlib" ABI_X86="64 32" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext smp sse sse2 sse3 sse4_1 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" L10N="de el en fr it tr" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-1" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby24" SANE_BACKENDS="pixma" USERLAND="GNU" VIDEO_CARDS="amdgpu radeonsi virgl" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Last edited by Elleni on Tue Feb 05, 2019 1:45 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 30 Aug 2008
Posts: 1873
Location: United Kingdom

PostPosted: Mon Feb 04, 2019 11:22 am    Post subject: Reply with quote

A couple of things that have worked for me when I have had problems with Baloo (sefaulting or 100% CPU on one core) are given in the following post:
Clevo W230SS: amd64 nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 xf86-video-ati. Dual boot Win 7 Pro 64-bit.
OpenRC eudev elogind & KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message

Joined: 23 May 2006
Posts: 1122

PostPosted: Tue Feb 05, 2019 1:45 am    Post subject: Reply with quote

Fitzcarraldo thanks, as your tips removed the segfaulting. Strange enough, it also re-enabled my printer being visible within cups. I was already considering it dead, as it would not print within a KVM VM either. After disabling, and enabling balooctl followed by the deletion of mentioned files in linked bugreport, I rebooted and found no segfaults anymore. To my surprise printer was recognized again and started doing its job :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum