Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] Bumblebee non va
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Tue Jan 29, 2019 2:21 am    Post subject: [Risolto] Bumblebee non va Reply with quote

Ciao ragazzi, scusate il titolo ma il problema è esattamente quello.
Allora, ho installato driver intel, driver nvidia, bumblebee e bbswitch. Aggiunto l'user al gruppo bumblebee, aggiunto il service con rc-update default ma se provo ad avviare da /etc/init.d ottengo questo:

Code:
gentoobook:/home/saul # /etc/init.d/bumblebee start
 * ERROR: bumblebee needs service(s) vgl


Una volta funzionava, e non capisco cosa è cambiato.

Questo è l'output di lshw
Code:
gentoobook:/home/saul # lshw -c display
  *-display                 
       description: 3D controller
       product: GP107M [GeForce GTX 1050 Mobile]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:a3000000-a3ffffff memory:90000000-9fffffff memory:a0000000-a1ffffff ioport:5000(size=128)
  *-display
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:137 memory:a2000000-a2ffffff memory:b0000000-bfffffff ioport:6000(size=64) memory:c0000-dffff
quindi le due schede vengono viste.

Code:
gentoobook:/home/saul # lsmod | grep nvidia
nvidia_drm             45056  0
nvidia_modeset       1015808  1 nvidia_drm
nvidia              16818176  1 nvidia_modeset
drm_kms_helper        192512  2 nvidia_drm,i915
drm                   520192  14 drm_kms_helper,nvidia_drm,i915
i2c_core               81920  7 videodev,drm_kms_helper,i2c_algo_bit,igb,nvidia,i915,drm
driver nvidia correttamente caricati

ma non riesco a capire cosa sia questo vgl. Ho fatto una ricerca, ma non sono riuscito a trovare nulla di risolutivo


Last edited by zar Marco on Tue Jan 29, 2019 3:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21782
Location: here

PostPosted: Tue Jan 29, 2019 6:44 am    Post subject: Reply with quote

https://wiki.gentoo.org/wiki/NVIDIA/Bumblebee#Configuring_.2Fetc.2Finit.d.2Fbumblebee
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 416
Location: Colle Umberto ( TV )

PostPosted: Tue Jan 29, 2019 3:46 pm    Post subject: Reply with quote

Ero un pirla, ero convinto di aver installato tuto, ma mancava virtualgl. Ora funziona tutto
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum