Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
compton interfering ... with audio??
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Gen3Hunna
n00b
n00b


Joined: 31 Dec 2018
Posts: 27

PostPosted: Fri Jan 11, 2019 2:28 am    Post subject: compton interfering ... with audio?? Reply with quote

I just installed compton on my MATE desktop. Kind of annoyingly hard to get working satisfactory with nvidia drivers but whatever.

Here's the thing, I don't have [compton] set to auto-start when I log in. I'm making sure compositing is off in MATE. If I log in to my account (which I'm logging in from LightDM straight into the MATE session), start compton, and then start Firefox to a video stream/Youtube video/whatever, the audio in (whatever open application, in this case - Firefox) will not work. However, if I start Firefox with the Youtube stream and then start compton, it doesn't interfere.

Now, when I'm randomly killing and starting compton over and over again to check configuration updates, I hear the audio stream interrupted as I kill compton and then relieved or 'reinstated' as I restart compton. So there's definitely something between the two that's occurring. For now I don't care about this haphazard workaround. But I do want to have compton auto-start eventually and if compton starts before applications, audio stops working. So it's not really worth the trade-off, haha.

Man, I just find all the fun stuff :) but gentoo is so worth it
Back to top
View user's profile Send private message
Muso
l33t
l33t


Joined: 22 Oct 2002
Posts: 968
Location: The Holy city of Honolulu

PostPosted: Fri Jan 11, 2019 3:03 am    Post subject: Reply with quote

I use i3, not mate. Also, I don't use XDM or any XDM alternatives, I just startx, I have compton in my .config/i3/config file, it launches automatically, and I have no sound issues.

maybe mate is at fault? Or the combination of mate & compton.
_________________
Time is a great teacher, but unfortunately it kills all its pupils.
Back to top
View user's profile Send private message
Gen3Hunna
n00b
n00b


Joined: 31 Dec 2018
Posts: 27

PostPosted: Fri Jan 11, 2019 3:15 pm    Post subject: Reply with quote

I'm still struggling to figure this out. Although after further troubleshooting it appears that my issue is more between Firefox and compton than compton and all audio. VLC will play video just fine in either described circumstance. So it's not affecting VLC, only Firefox. It's as if Firefox stops being capable of output. The little speaker icon on tabs is also not active when this occurs.

Will keep this updated if I can narrow it down further or if I solve it..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum