Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gdm won't start, gnome-shell segfaults in libmutter-clutter
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
raddaqii
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2005
Posts: 100
Location: Berlin, Old Europe

PostPosted: Mon Jan 07, 2019 10:02 am    Post subject: gdm won't start, gnome-shell segfaults in libmutter-clutter Reply with quote

Happy new year! So, after updating a laptop with Sakaki's setup using
Code:
genup
gdm won't start. I have:

dmesg:

Code:
[  210.694567] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready
[  210.950226] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready
[  210.953698] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[  213.490514] gnome-shell[2379]: segfault at ffffffffffffffe0 ip 00007f8349f61db7 sp 00007fff67df8698 error 5 in libmutter-clutter-0.so[7f8349e9c000+153000]
[  214.496196] e1000e: enp0s25 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
[  214.496230] IPv6: ADDRCONF(NETDEV_CHANGE): enp0s25: link becomes ready
[  215.700503] gnome-shell[2482]: segfault at ffffffffffffffe0 ip 00007fe81dc4adb7 sp 00007fff579b6138 error 5 in libmutter-clutter-0.so[7fe81db85000+153000]
[  217.870495] gnome-shell[2549]: segfault at ffffffffffffffe0 ip 00007f674c6c8db7 sp 00007ffcc073a4e8 error 5 in libmutter-clutter-0.so[7f674c603000+153000]
...


The last line repeats a lot.

systemctl status:

Code:
$ sudo systemctl status -l gdm
Passwort:
● gdm.service - GNOME Display Manager
   Loaded: loaded (/lib/systemd/system/gdm.service; enabled; vendor preset: disabled)
   Active: inactive (dead) since Mon 2019-01-07 10:42:25 CET; 10min ago
  Process: 6311 ExecStart=/usr/sbin/gdm (code=exited, status=0/SUCCESS)
 Main PID: 6311 (code=exited, status=0/SUCCESS)

Jan 07 10:42:24 glossop gdm[6311]: Child process -7019 was already dead.
Jan 07 10:42:24 glossop gdm[6311]: Child process 7012 was already dead.
Jan 07 10:42:24 glossop gdm[6311]: Unable to kill session worker process
Jan 07 10:42:24 glossop gdm-launch-environment][7022]: pam_systemd(gdm-launch-environment:session): Unknown parameter 'kill-session-process>
Jan 07 10:42:24 glossop systemd[1]: Stopping GNOME Display Manager...
Jan 07 10:42:25 glossop gdm[6311]: Child process -7033 was already dead.
Jan 07 10:42:25 glossop gdm[6311]: GdmDisplay: display lasted 0,387016 seconds
Jan 07 10:42:25 glossop gdm[6311]: gdm_display_finish: assertion 'GDM_IS_DISPLAY (self)' failed
Jan 07 10:42:25 glossop gdm[6311]: GLib: g_hash_table_find: assertion 'version == hash_table->version' failed
Jan 07 10:42:25 glossop systemd[1]: Stopped GNOME Display Manager.


and some lines of (I think uncritical) lvmetad.service on the screen. All volumes are mounted.

Sakaki's setup uses wayland, so the use flag is set for Gnome related components.

Versions:

Code:
[I] media-libs/clutter
     Verfügbare Versionen:   (1.0) 1.26.2-r1{tbz2}
       {X aqua debug doc egl gtk +introspection test wayland}
     Installierte Versionen: 1.26.2-r1(1.0){tbz2}(16:29:58 05.11.2018)(X egl gtk introspection wayland -aqua -debug -doc -test)

[I] x11-wm/mutter
     Verfügbare Versionen:   3.24.4(0/0){tbz2} ~3.26.2-r1(0/1) {debug gles2 +introspection test udev wayland INPUT_DEVICES="wacom"}
     Installierte Versionen: 3.24.4(0/0){tbz2}(19:06:36 05.11.2018)(introspection udev wayland -debug -gles2 -test INPUT_DEVICES="-wacom")

[I] gnome-base/gdm
     Verfügbare Versionen:   3.24.3-r1{tbz2} ~3.26.2.1-r1 {accessibility audit branding fprint +introspection ipv6 plymouth selinux smartcard tcpd test wayland xinerama}
     Installierte Versionen: 3.24.3-r1{tbz2}(19:41:06 05.11.2018)(branding introspection ipv6 plymouth tcpd wayland -accessibility -audit -fprint -selinux -smartcard -test -xinerama)

[I] gnome-base/gnome-shell
     Verfügbare Versionen:   3.24.3{tbz2} ~3.26.2-r4 {+bluetooth +browser-extension elogind +ibus +networkmanager nsplugin -openrc-force systemd telepathy test PYTHON_SINGLE_TARGET="python3_4 python3_5 python3_6" PYTHON_TARGETS="python3_4 python3_5 python3_6"}
     Installierte Versionen: 3.24.3{tbz2}(19:40:06 05.11.2018)(bluetooth browser-extension ibus networkmanager -nsplugin -openrc-force PYTHON_TARGETS="python3_6 -python3_4 -python3_5")


Interesingly, on other machines I have those same versions after running genup, and everything works as should.

Hints, pointers?
_________________
--
Gentoo from 2004.3

Oh, took a new home in the fediverse: find me in the stream on pluspora.com: https://pluspora.com/tags/gentoo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum