Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problemi con upgrade world
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Sun Jan 06, 2019 3:25 am    Post subject: problemi con upgrade world Reply with quote

Salve a tutti , sto installando gentoo in un nuovo laptop dell, ho seguito gli step della wiky .. e fino al punto della compilazione del kernel tutto bene ..
dopo di che mi son ricordato che per avere i paccetti testing e` necessario aggiungere :
Code:

 ACCEPT_KEYWORDS="~amd64"


dopo ho provato a ri aggiornare world
Code:
emerge --ask --update --deep --newuse --backtrack=300 @world


ma ittengo questi errori : https://paste.pound-python.org/show/vzNisZ6nSBT2N8WdUBAO/

qualcuno sa` darmi una mano ?
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 671

PostPosted: Sun Jan 06, 2019 7:57 am    Post subject: Reply with quote

L'errore ti è stato indicato.
c'è da ricomilare il kernel
Quote:
Running pre-merge checks for net-misc/openssh-7.9_p1-r1
>>> Running pre-merge checks for x11-drivers/nvidia-drivers-415.25
* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Found sources for kernel version:
* 4.14.83-gentoo
* Checking for suitable kernel configuration options...
* CONFIG_DEBUG_MUTEXES: should not be set. But it is.

* Please check to make sure these options are set correctly.
* Failure to do so may cause unexpected problems.
* Once you have satisfied these options, please try merging
* this package again.
* ERROR: x11-drivers/nvidia-drivers-415.25::gentoo failed (pretend phase):
* Incorrect kernel configuration options
*
* Call stack:
* ebuild.sh, line 124: Called pkg_pretend
* nvidia-drivers-415.25.ebuild, line 117: Called nvidia_drivers_versions_check
* nvidia-drivers-415.25.ebuild, line 113: Called check_extra_config
* linux-info.eclass, line 857: Called die
* The specific snippet of code:
* die "Incorrect kernel configuration options"


con questa opzione d disabilitare
Code:
# CONFIG_DEBUG_MUTEXES is not set


se stai utilizzando la .config in /usr/src/linux , edita il file di config
altrimenti modifica il config che usi (ad esempio con genkernel lo trovi in /etc/kernels)

o dsabilita la voce direttamente nel menuconfig se utilizzi quello

ricompila il kernel dopo la modifica

PS : c'è pure l'aggiormamento di perl
in primis darei :
Code:
# perl cleaner reallyall

per andare sul sicuro (blocchi permettendo)
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Sun Jan 06, 2019 9:19 am    Post subject: Reply with quote

e come lo abilito invece usando menuconfig ? io ho seguito tutte le istruzioni riportate nella wiky dei driver nvidia,

altrimenti come lo aggiungo ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Sun Jan 06, 2019 9:23 am    Post subject: Reply with quote

Nel menuconfig lo trovi in
Code:
Kernel hacking  --->
    Lock Debugging (spinlocks, mutexes, etc...)  --->
        [*] Mutex debugging: basic checks

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Sun Jan 06, 2019 2:28 pm    Post subject: Reply with quote

era gia settato ... anche leggendo il .config e`
Code:

CONFIG_DEBUG_MUTEXES=y

riprovo a compilare ...
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Sun Jan 06, 2019 2:49 pm    Post subject: Reply with quote

lo devo settare su "n" ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21351
Location: here

PostPosted: Sun Jan 06, 2019 3:07 pm    Post subject: Reply with quote

drudox wrote:
lo devo settare su "n" ?

Esatto il messaggio dice che non deve essere impostato
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Sun Jan 06, 2019 3:31 pm    Post subject: Reply with quote

perfetto grazue mille
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum