Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
samba share on asus-wrt is not mounting [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
don quixada
l33t
l33t


Joined: 15 May 2003
Posts: 730

PostPosted: Wed Jan 02, 2019 3:28 am    Post subject: samba share on asus-wrt is not mounting [SOLVED] Reply with quote

I'm trying to connect to a guest share on my network and it's not working. I'm getting the error:

Code:
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


when I use the '-o guest' option.

I think it may have something to do with the SUID but I'm not sure how to check this. The logfile reveals nothing. Any suggestions? Thanks.

dq


Last edited by don quixada on Fri Jan 04, 2019 4:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
guitou
Guru
Guru


Joined: 02 Oct 2003
Posts: 389
Location: France

PostPosted: Wed Jan 02, 2019 12:33 pm    Post subject: Reply with quote

Hello.

I suppose the option you want to set is NOT just guest, but user=guest

++
Gi)
Back to top
View user's profile Send private message
don quixada
l33t
l33t


Joined: 15 May 2003
Posts: 730

PostPosted: Wed Jan 02, 2019 1:38 pm    Post subject: Reply with quote

But then it asks for a password and there isn't (and shouldn't be) a password for 'guest'.

dq
Back to top
View user's profile Send private message
guitou
Guru
Guru


Joined: 02 Oct 2003
Posts: 389
Location: France

PostPosted: Thu Jan 03, 2019 12:21 pm    Post subject: Reply with quote

And you have a password option as well for mount command ;)

++
Gi)
Back to top
View user's profile Send private message
don quixada
l33t
l33t


Joined: 15 May 2003
Posts: 730

PostPosted: Thu Jan 03, 2019 1:49 pm    Post subject: Reply with quote

I'm aware of that fact, but Samba's guest access has no password by design. The server is set up correctly and I can access it using other devices just not this Gentoo box after upgrading it.

Incidentally, if I set up the server to not allow guest access and try to connect to it using an actual username and password it still doesn't work (I get the same error). Something is wrong with my setup on the Gentoo box. Does it have to do with the SMB version levels that are enabled?

dq
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1785
Location: Oranienburg/Germany

PostPosted: Thu Jan 03, 2019 1:57 pm    Post subject: Reply with quote

Hi,

can you check, whether your samba password db is having an entry for user "guest"?

check with
Code:
pdbedit -L


greets, Stefan
_________________
1st: i5-4570, 16GB, 1.75TB
2nd: i5-4570, 16GB, 620GB
3rd: i5-4570, 16GB, 10,5TB
4th: Asus N61VN, 8GB, 240GB
5th: C2D T7200, 2GB, 16GB USB + NFS
Back to top
View user's profile Send private message
don quixada
l33t
l33t


Joined: 15 May 2003
Posts: 730

PostPosted: Fri Jan 04, 2019 1:10 am    Post subject: Reply with quote

On the server side (asus-wrt) or the client side (gentoo)? I tried that command on both sides but it didn't yield much. Asus-wrt doesn't have it installed and gentoo give a blank result..

dq
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2889
Location: Illinois, USA

PostPosted: Fri Jan 04, 2019 2:34 am    Post subject: Reply with quote

On my system, user=nobody, doesn't require a password.
Back to top
View user's profile Send private message
don quixada
l33t
l33t


Joined: 15 May 2003
Posts: 730

PostPosted: Fri Jan 04, 2019 4:51 am    Post subject: Reply with quote

Well for the asus-wrt the user nobody is asking for a password. But asus-wrt is working fine. Other devices are connecting using the guest network no problem. Even my gentoo machine did until I updated. Also, it is important to note that even an existing user/password combination doesn't work using gentoo to connect to the samba share so the problem lies with my config on samba on gentoo...

dq
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1785
Location: Oranienburg/Germany

PostPosted: Fri Jan 04, 2019 6:27 am    Post subject: Reply with quote

Hi,

you should try the mount option for the max smb version. maybe the asus-wrt allows smb2 only. check out the following example:

Code:
mount -t cifs -o vers=3.0,username=MyUsername,password=*,rw,soft //MyServerIP/MyShare /tmp/veeam/MyServerIPMyShare


here is the "mapping":

https://superuser.com/questions/1297724/linux-force-default-mount-cifs-version-to-3-0 wrote:

vers=3.0 is SMB3 i.e. Windows 8, Windows Server 2012
vers=2.1 is SMB2_10 i.e. Windows 7, Windows Server 2008 R2
vers=2.0 is SMB2_02 i.e. Vista SP1, Windows Server 2008
vers=1.0 is NT1 i.e. Windows 95, NT 4.0


greets, Stefan
_________________
1st: i5-4570, 16GB, 1.75TB
2nd: i5-4570, 16GB, 620GB
3rd: i5-4570, 16GB, 10,5TB
4th: Asus N61VN, 8GB, 240GB
5th: C2D T7200, 2GB, 16GB USB + NFS
Back to top
View user's profile Send private message
don quixada
l33t
l33t


Joined: 15 May 2003
Posts: 730

PostPosted: Fri Jan 04, 2019 4:00 pm    Post subject: Reply with quote

This was the answer! I put 'vers=2.0' is my fstab and then I could mount both guest and existing users. Thanks for your help!

dq

PS: I've changed the topic heading to reflect the wider issue.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum