Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] AMDGPU Kernel >4.19.x blackscreen at boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
gorg86
Tux's lil' helper
Tux's lil' helper


Joined: 20 May 2011
Posts: 135

PostPosted: Thu Dec 27, 2018 3:49 pm    Post subject: [SOLVED] AMDGPU Kernel >4.19.x blackscreen at boot Reply with quote

Hello,

I use an ASUS AMD Radeon R9 390, since Kernel 4.19.x something is messed up with AMDGPU, the problem persists in 4.20.0 too.
4.18.20 runs fine but I want to try out a newer Kernel. 4.18.20 is stable but there is some weird stuttering going on periodically when I use the TearFree option in xorg.conf.
On boot when the resolution is about to switch to native I just get a black screen and nothing happens. I don't know exactly what is happening, because I can't use dmesg obviously...
I have to hard reset the machine, when I do that my main monitor (on DVI) stays black for ~30 sec in the BIOS, the second one (HDMI) turns on immediately like it should.
That ~30sec thing only happens after a failed boot with Kernel >4.19.x.

Anybody experiencing the same thing?

EDIT:
amdgpu.dpm=1 was causing the issue...
The system boots fine now.

EDIT 2:
Setting amdgpu.dc=0 fixed the stuttering issue for me at least on 4.20.0, it might be related to this:
https://bugs.freedesktop.org/show_bug.cgi?id=106175

This might be useful for you folks experimenting with AMDGPU:
https://www.phoronix.com/scan.php?page=article&item=linux-413-gcn101&num=1
Quote:
Beginning with Linux 4.13, AMDGPU and Radeon GCN 1.0/1.1 support can co-exist nicer thanks to some new module options added. Even if blacklisting the Radeon DRM, AMDGPU doesn't have GCN 1.0/1.1 support by default but requires setting amdgpu.cik_support=1 for GCN 1.1 support and amdgpu.si_support=1 for GCN 1.0 support. To get Radeon DRM to not bind to these generations of GPUs, radeon.si_support=0 and radeon.cik_support=0 must be set. So basically if you want to get AMDGPU working for Sea Islands and Southern Islands GPUs on Linux 4.13+, you need to append "radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1" to your kernel command line when booting the system.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum