Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]systemd: Remove gdm and enable lightdm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
reikdas
Apprentice
Apprentice


Joined: 27 Nov 2018
Posts: 238

PostPosted: Sun Dec 23, 2018 1:53 pm    Post subject: [Solved]systemd: Remove gdm and enable lightdm Reply with quote

[Moderator edit: Changed title to try to attract relevant answers. Original title lacked the systemd: prefix. -Hu]

When I tried enabling lightdm-

Code:
localhost /home/reik # systemctl enable lightdm
Failed to enable unit: File /etc/systemd/system/display-manager.service already exists and is a symlink to /lib/systemd/system/gdm.service.


When I tried removing gdm so I can enable lightdm-

Code:
localhost /home/reik # emerge -c --verbose gdm

Calculating dependencies... done!
  gnome-base/gdm-3.24.3-r1 pulled in by:
    gnome-base/gnome-3.24.2 requires >=gnome-base/gdm-3.24.2
    gnome-base/gnome-shell-3.24.3 requires >=gnome-base/gdm-3.5[introspection]

>>> No packages selected for removal by depclean
Packages installed:   879
Packages in world:    15
Packages in system:   43
Required packages:    879
Number removed:       0


Last edited by reikdas on Sun Dec 23, 2018 6:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13498

PostPosted: Sun Dec 23, 2018 4:39 pm    Post subject: Reply with quote

According to that output, if you want to remove gnome-base/gdm, you need to remove some other core components of GNOME as well. Do you need to remove gnome-base/gdm? The systemctl output merely says that you cannot make lightdm the display manager while gdm is the display manager. It does not say that you must unmerge gdm in order to make it not be your display manager.
Back to top
View user's profile Send private message
reikdas
Apprentice
Apprentice


Joined: 27 Nov 2018
Posts: 238

PostPosted: Sun Dec 23, 2018 6:42 pm    Post subject: Reply with quote

Code:
systemctl disable gdm
systemctl enable lightdm

fixed the issue.

Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum