Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]Please help: MATE woudn't start on new installation.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
lesnik
n00b
n00b


Joined: 04 Oct 2016
Posts: 17

PostPosted: Sun Dec 23, 2018 11:19 am    Post subject: [Solved]Please help: MATE woudn't start on new installation. Reply with quote

I have decided to install the following configuration on a new computer: gentoo + systemd + mate desktop.

What profile should I have chosen during the installation? The following choices seemed appropriate:

Code:
default/linux/amd64/17.0/desktop
default/linux/amd64/17.0/desktop/gnome/systemd   <- I have chosen this one
default/linux/amd64/17.0/systemd


Was my choice correct?

Anyway, after initial installation I have emerged mate-base\mate and x11-misc/lightdm packages (I had to turn-off the notification use-flag for mate-base\mate because of conflict, as mentioned at https://wiki.gentoo.org/wiki/MATE).

I have configured the system following the https://wiki.gentoo.org/wiki/MATE.

Now I reboot the system, lightdm starts successfully, I enter the password, push loing button, but mate wouldn't start: screen gets black for a second and I get back to lightdm login.

No errors reported at /var/log/Xorg.0.log during this process (these are the lines which appear during login attempt):
Code:
[  1863.158] (II) event1  - Power Button: device removed
[  1863.166] (II) event0  - Power Button: device removed
[  1863.179] (II) event2  - AT Translated Set 2 keyboard: device removed
[  1863.187] (II) UnloadModule: "libinput"
[  1863.187] (II) UnloadModule: "libinput"
[  1863.187] (II) UnloadModule: "libinput"
[  1863.199] (II) Server terminated successfully (0). Closing log file.


However journalctl -f does report several problems:
Code:
Dec 23 14:06:23 nostromo gnome-session-c[3817]: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-obYRy6alTc: Connection refused
Dec 23 14:06:23 nostromo gnome-session[3798]: gnome-session-binary[3798]: WARNING: Unable to find required component 'org.gnome.Shell'
Dec 23 14:06:23 nostromo gnome-session-binary[3798]: WARNING: Unable to find required component 'org.gnome.Shell'
Dec 23 14:06:23 nostromo gnome-session-binary[3798]: Entering running state
Dec 23 14:06:23 nostromo gnome-session-f[3863]: Cannot open display:
Dec 23 14:06:24 nostromo lightdm[3788]: pam_unix(lightdm:session): session closed for user lesnik


I am not sure if any of the reported problems prevent mate session from start. I guess that the critical problem is that display id is empty - where should it come from?


Last edited by lesnik on Sun Dec 23, 2018 7:13 pm; edited 2 times in total
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5802

PostPosted: Sun Dec 23, 2018 11:33 am    Post subject: Reply with quote

while I don't use systemd or lightdm, default/linux/amd64/17.0/desktop/gnome/systemd would probably work just fine, at worst it pulls in more gnome than you need (which isn't much)...

if you log into a vt as your user and run startx, does mate start then? another thing i would check is the groups your user is in...

Code:
chris@gazelle ~ $ id
uid=1000(chris) gid=100(users) groups=100(users),10(wheel),14(uucp),18(audio),27(video),35(games),101(wireshark),104(plugdev)


you probably at least want audio/video, if it turns out to be groups.
_________________
overlay | patches
Neddyseagoon wrote:
The problem with leaving is that you can only do it once and it reduces your influence.
Back to top
View user's profile Send private message
lesnik
n00b
n00b


Joined: 04 Oct 2016
Posts: 17

PostPosted: Sun Dec 23, 2018 11:55 am    Post subject: Reply with quote

Thanks for clarifications, bunder!

I am in video and audio groups:

Code:
lesnik@nostromo ~ $ id
uid=1000(lesnik) gid=1000(lesnik) groups=1000(lesnik),10(wheel),18(audio),27(video),85(usb),100(users)


bunder wrote:
if you log into a vt as your user and run startx, does mate start then?


After I created ~/.xinitrc file:

Code:
$ cat .xinitrc
exec mate-session


I can startx manually! Mouse doesn't work though... but that's another problem.

And why can't lightdm start the mate? As I understand the only thing I have to do to configure lightdm to start mate is to create the following file (which I did as per the wiki instructions):
Code:
$ cat /etc/env.d/90xsession
XSESSION="Mate"
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21350
Location: here

PostPosted: Sun Dec 23, 2018 11:56 am    Post subject: Re: Please help: MATE woudn't start on new installation. Reply with quote

lesnik wrote:
Was my choice correct?

gnome/systemd can work but conbining desktop and systemd profile is a better choice
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
lesnik
n00b
n00b


Joined: 04 Oct 2016
Posts: 17

PostPosted: Sun Dec 23, 2018 5:52 pm    Post subject: Reply with quote

lesnik wrote:
And why can't lightdm start the mate? As I understand the only thing I have to do to configure lightdm to start mate is to create the following file (which I did as per the wiki instructions):
Code:
$ cat /etc/env.d/90xsession
XSESSION="Mate"


Problem solved, though I do not completely understand what I did wrong.

Well, first I fixed the problem with USB (I had to rebuild kernel with module xhci_hcd).

After that on lightdm login screen I was able to select x-session type (just for further reference: click on one of the icons on the top-right corner of the screen, menu with choices "Custom", "GNOME", "MATE", etc., select "MATE" item.) And that's it.

"journalctl -f" still reports some warnings (different than previously). Most sinister one:

Code:
Dec 23 20:40:11 nostromo org.gtk.vfs.Daemon[3118]: A connection to the bus can't be made


I guess I'll change profile as fedeliallalinea suggested.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum