Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Workaround]Trouble installing Gnome
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
reikdas
Apprentice
Apprentice


Joined: 27 Nov 2018
Posts: 238

PostPosted: Sun Dec 23, 2018 9:48 am    Post subject: [Workaround]Trouble installing Gnome Reply with quote

Profile - 17.0/desktop/gnome/systemd

My Xorg configuration issue(not really an issue?) - https://forums.gentoo.org/viewtopic-t-1090822-highlight-.html

I added X, gtk, gnome and systemd to the USE flag.

Ran
Code:
echo "gnome-base/gnome-session branding" >> /etc/portage/package.use
emerge --ask gnome-base/gnome
env-update && source /etc/profile
getent group plugdev
gpasswd -a reik plugdev
systemctl enable gdm.service


Running
Code:
systemctl start gdm.service

crashed my system.

Now whenever I reboot, I am always able to login on the 3rd try (This is weird) and after that tty hangs. Also gdm does not start. I login using tty.


Last edited by reikdas on Thu Dec 27, 2018 4:11 am; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sun Dec 23, 2018 9:51 am    Post subject: Re: Trouble installing Gnome Reply with quote

reikdas wrote:
I added X, gtk, gnome and systemd to the USE flag.

Since you use the gnome profile, all these flags will already have been set for you. You can always check your current global USE flag settings using emerge --info.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
reikdas
Apprentice
Apprentice


Joined: 27 Nov 2018
Posts: 238

PostPosted: Sun Dec 23, 2018 10:38 am    Post subject: Re: Trouble installing Gnome Reply with quote

asturm wrote:
reikdas wrote:
I added X, gtk, gnome and systemd to the USE flag.

Since you use the gnome profile, all these flags will already have been set for you. You can always check your current global USE flag settings using emerge --info.


Thanks! I removed those flags and saw that the flags are still present in emerge --info.

That does not solve the issue though :(
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21350
Location: here

PostPosted: Sun Dec 23, 2018 10:51 am    Post subject: Re: Trouble installing Gnome Reply with quote

reikdas wrote:
asturm wrote:
reikdas wrote:
I added X, gtk, gnome and systemd to the USE flag.

Since you use the gnome profile, all these flags will already have been set for you. You can always check your current global USE flag settings using emerge --info.


Thanks! I removed those flags and saw that the flags are still present in emerge --info.

That does not solve the issue though :(

When you changed profile you run
Code:
# emerge -uUD @world

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
reikdas
Apprentice
Apprentice


Joined: 27 Nov 2018
Posts: 238

PostPosted: Sun Dec 23, 2018 11:12 am    Post subject: Re: Trouble installing Gnome Reply with quote

fedeliallalinea wrote:
reikdas wrote:
asturm wrote:
reikdas wrote:
I added X, gtk, gnome and systemd to the USE flag.

Since you use the gnome profile, all these flags will already have been set for you. You can always check your current global USE flag settings using emerge --info.


Thanks! I removed those flags and saw that the flags are still present in emerge --info.

That does not solve the issue though :(

When you changed profile you run
Code:
# emerge -uUD @world


Did not fix the issue :(

reikdas wrote:
Now whenever I reboot, I am always able to login on the 3rd try (This is weird) and after that tty hangs. Also gdm does not start. I login using tty.


Some clarification-
gdm does not start so I boot into tty. The cursor while logging in blinks much faster than normal.
The 3 times is probably a coincidence. It seems like my keyboard presses are not recorded properly the first 2 times for some reason.
Sometimes tty hangs, sometimes not.
On one of the instances tty did not hang on startup, I tried running systemctl start gdm.service. I stayed on tty but it did not crash.
Back to top
View user's profile Send private message
reikdas
Apprentice
Apprentice


Joined: 27 Nov 2018
Posts: 238

PostPosted: Sun Dec 23, 2018 11:21 am    Post subject: Reply with quote

On one of the cases where I had to try 3 times to login and tty did not hang,
systemctl status gdm - https://paste.pound-python.org/show/2EzeQz01rQUsIG0Rt7CD/
Back to top
View user's profile Send private message
reikdas
Apprentice
Apprentice


Joined: 27 Nov 2018
Posts: 238

PostPosted: Sun Dec 23, 2018 11:35 am    Post subject: Reply with quote

Here are my GDM use flags.

USE="branding introspection ipv6 tcpd -accessibility -audit -fprint -plymouth (-selinux) -smartcard -test -wayland -xinerama"
Back to top
View user's profile Send private message
reikdas
Apprentice
Apprentice


Joined: 27 Nov 2018
Posts: 238

PostPosted: Sun Dec 23, 2018 11:55 am    Post subject: Reply with quote

xinit /usr/bin/gnome-session is able to successfully start GNOME.
The error is with gdm.
Back to top
View user's profile Send private message
reikdas
Apprentice
Apprentice


Joined: 27 Nov 2018
Posts: 238

PostPosted: Sun Dec 23, 2018 12:15 pm    Post subject: Reply with quote

Xorg.0.log -> https://paste.pound-python.org/show/fNeIHhzspYkcnbgpHkFj/
Back to top
View user's profile Send private message
reikdas
Apprentice
Apprentice


Joined: 27 Nov 2018
Posts: 238

PostPosted: Sun Dec 23, 2018 12:37 pm    Post subject: Reply with quote

systemctl cat gdm.service - https://paste.pound-python.org/show/wdTtRjigMJDU1Np7mVCK/
Back to top
View user's profile Send private message
reikdas
Apprentice
Apprentice


Joined: 27 Nov 2018
Posts: 238

PostPosted: Sun Dec 23, 2018 12:56 pm    Post subject: Reply with quote

systemctl show gdm.service -> https://paste.pound-python.org/show/YyGpf5sHCQfDPBadQqyU/

/etc/security/limits.conf -> https://paste.pound-python.org/show/H6DiPgZqQOCZGVO40Jww/
Back to top
View user's profile Send private message
reikdas
Apprentice
Apprentice


Joined: 27 Nov 2018
Posts: 238

PostPosted: Sun Dec 23, 2018 1:49 pm    Post subject: Reply with quote

Enabling lightdm solved the issue.

gdm is still broken on my system though. (Not marking it solved)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum