Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Network Manager - Not authorized to perform this operation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Belliash
Advocate
Advocate


Joined: 24 Nov 2004
Posts: 2428
Location: Wroclaw, Poland

PostPosted: Sat Dec 15, 2018 8:22 am    Post subject: Network Manager - Not authorized to perform this operation Reply with quote

Hello,

After an upgrade, I cannot add/remove/edit any network connection from NetworkManager.
In logs I found the following entries, but cannot really find a solution yet:

Code:
Dec 15 09:18:26 NoteBelliash NetworkManager[3041]: <info>  [1544861906.0379] audit: op="statistics" arg="refresh-rate-ms" pid=3699 uid=X result="fail" reason="Not authorized to perform this operation"
Dec 15 09:18:35 NoteBelliash NetworkManager[3041]: <info>  [1544861915.6041] audit: op="statistics" arg="refresh-rate-ms" pid=3699 uid=X result="fail" reason="Not authorized to perform this operation"
Dec 15 09:18:51 NoteBelliash NetworkManager[3041]: <info>  [1544861931.5751] audit: op="connection-add" pid=5221 uid=X result="fail" reason="Insufficient privileges."



Anyone came across such problem?
_________________
Asio Software Technologies
Belliash IT Weblog
Back to top
View user's profile Send private message
mirekm
Apprentice
Apprentice


Joined: 12 Feb 2004
Posts: 182
Location: Gliwice

PostPosted: Sat Dec 15, 2018 6:02 pm    Post subject: Reply with quote

The answer is, you have to downgrade policykit.
Back to top
View user's profile Send private message
Belliash
Advocate
Advocate


Joined: 24 Nov 2004
Posts: 2428
Location: Wroclaw, Poland

PostPosted: Sat Dec 15, 2018 6:04 pm    Post subject: Reply with quote

Is this some known bug?
BTW: I think you meant polkit?
_________________
Asio Software Technologies
Belliash IT Weblog
Back to top
View user's profile Send private message
Belliash
Advocate
Advocate


Joined: 24 Nov 2004
Posts: 2428
Location: Wroclaw, Poland

PostPosted: Sat Dec 15, 2018 10:32 pm    Post subject: Reply with quote

Belliash wrote:
Is this some known bug?
BTW: I think you meant polkit?


Hmmm,

Downgraded sys-auth/polkit and everything works fine now.
_________________
Asio Software Technologies
Belliash IT Weblog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum