Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Enlightenment 0.22.3 opengl init engine 'opengl_x11' failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
brigadire
n00b
n00b


Joined: 10 Dec 2018
Posts: 3

PostPosted: Mon Dec 10, 2018 10:44 am    Post subject: Enlightenment 0.22.3 opengl init engine 'opengl_x11' failed Reply with quote

Hello Сommunity!
I built the enlightenment desktop, but I get an error when I try to use OpenGL.
I ran the elementary_test and saw this error:

Code:

ELM_ACCEL=gl elementary_test
Xlib:  extension "DPMS" missing on display ":0.0".
ERR<10865>:ecore_evas modules/ecore_evas/engines/x/ecore_evas_x.c:4643 ecore_evas_gl_x11_options_new_internal() evas_engine_info_set() init engine 'opengl_x11' failed.
## Copy & Paste the below (until EOF) into a terminal, then hit Enter

eina_btlog << EOF
/usr/lib64/libeina.so.1  0x7fe9c6398a3c 0x7fe9c636d000
/usr/lib64/libeina.so.1  0x7fe9c6399a71 0x7fe9c636d000
/usr/lib64/libeina.so.1  0x7fe9c639b373 0x7fe9c636d000
/usr/lib64/ecore_evas/engines/x/v-1.20/module.so         0x7fe9b8ed1070 0x7fe9b8ec1000
/usr/lib64/ecore_evas/engines/x/v-1.20/module.so         0x7fe9b8ed10eb 0x7fe9b8ec1000
/usr/lib64/libecore_evas.so.1    0x7fe9c6f0e737 0x7fe9c6ef6000
/usr/lib64/libelementary.so.1    0x7fe9c606174d 0x7fe9c5d94000
/usr/lib64/libelementary.so.1    0x7fe9c6062514 0x7fe9c5d94000
/usr/lib64/libeo.so.1    0x7fe9c660c46e 0x7fe9c65fb000
/usr/lib64/libeo.so.1    0x7fe9c660408c 0x7fe9c65fb000
/usr/bin/elementary_test         0x55ec18577e3a 0x55ec18554000
/usr/lib64/libeo.so.1    0x7fe9c66100a7 0x7fe9c65fb000
/usr/lib64/libeo.so.1    0x7fe9c660b0fe 0x7fe9c65fb000
/usr/lib64/libecore.so.1         0x7fe9c6cb1fc5 0x7fe9c6c93000
/usr/lib64/libecore.so.1         0x7fe9c6cbe536 0x7fe9c6c93000
/usr/lib64/libecore.so.1         0x7fe9c6cbeb8f 0x7fe9c6c93000
/usr/lib64/libecore.so.1         0x7fe9c6cbec1f 0x7fe9c6c93000
/usr/lib64/libecore.so.1         0x7fe9c6cb0c8d 0x7fe9c6c93000
/usr/lib64/libecore.so.1         0x7fe9c6cb140f 0x7fe9c6c93000
/usr/lib64/libecore.so.1         0x7fe9c6cb1479 0x7fe9c6c93000
/usr/lib64/libecore.so.1         0x7fe9c6cae94a 0x7fe9c6c93000
/usr/bin/elementary_test         0x55ec185772b6 0x55ec18554000
/lib64/libc.so.6         0x7fe9c522dae7 0x7fe9c520c000
/usr/bin/elementary_test         0x55ec1857730a 0x55ec18554000
EOF


The glxinfo is successful:

Code:

glxinfo | grep rendering
direct rendering: Yes


Enlightenment and efl built with the following parameters:

Code:


eix dev-libs/efl

[I] dev-libs/efl
     Available versions:  1.20.7-r1 ~1.21.0 ~1.21.1 {X avahi +bmp connman dds debug doc drm +eet egl examples fbcon +fontconfig fribidi gif gles glib gnutls gstreamer harfbuzz hyphen ibus +ico ivi jpeg2k libressl libuv luajit neon nls opengl pdf physics pixman postscript +ppm +psd pulseaudio raw scim sdl sound ssl static-libs svg +system-lz4 systemd tga tiff tslib unwind v4l valgrind vlc vnc wayland webp xcf xim xine xpm xpresent}
     Installed versions:  1.20.7-r1(22:08:19 09.12.2018)(X bmp drm eet fbcon fontconfig gif glib gstreamer harfbuzz ico jpeg2k nls opengl physics ppm psd pulseaudio raw sound ssl v4l vnc xim -avahi -connman -dds -debug -doc -egl -examples -fribidi -gles -gnutls -hyphen -ibus -ivi -libressl -libuv -luajit -neon -pdf -pixman -postscript -scim -sdl -static-libs -svg -systemd -tga -tiff -tslib -unwind -valgrind -vlc -wayland -webp -xcf -xine -xpm -xpresent)
     
     
 
 [I] x11-wm/enlightenment
     Available versions:  (0.17) 0.22.3(0.17/0.22.3) (~)0.22.4(0.17/0.22.4)
       {acpi bluetooth connman doc geolocation nls packagekit pam systemd udisks wayland wifi ENLIGHTENMENT_MODULES="+appmenu +backlight +battery +bluez4 +clock +conf +conf-applications +conf-bindings +conf-dialogs +conf-display +conf-interaction +conf-intl +conf-menus +conf-paths +conf-performance +conf-randr +conf-shelves +conf-theme +conf-window-manipulation +conf-window-remembers +cpufreq +everything +fileman +fileman-opinfo +gadman +geolocation +ibar +ibox +lokker +luncher +mixer +msgbus +music-control +notification +packagekit +pager +pager-plain +quickaccess +shot +start +syscon +sysinfo +systray +tasks +teamwork +temperature +tiling +time +vkbd +winlist +wireless +wizard +wl-buffer +wl-desktop-shell +wl-drm +wl-text-input +wl-weekeyboard +wl-wl +wl-x11 +xkbswitch +xwayland"}
     Installed versions:  0.22.3(0.17/0.22.3)(10:35:36 10.12.2018)(acpi nls pam -connman -doc -systemd -udisks -wayland ENLIGHTENMENT_MODULES="appmenu backlight battery bluez4 clock conf conf-applications conf-bindings conf-dialogs conf-display conf-interaction conf-intl conf-menus conf-paths conf-performance conf-randr conf-shelves conf-theme conf-window-manipulation conf-window-remembers cpufreq everything fileman fileman-opinfo gadman geolocation ibar ibox lokker luncher mixer msgbus music-control notification packagekit pager pager-plain quickaccess shot start syscon sysinfo systray tasks teamwork temperature tiling time vkbd winlist wireless wizard wl-buffer wl-desktop-shell wl-drm wl-text-input wl-weekeyboard wl-wl wl-x11 xkbswitch xwayland")


Thanks.
Back to top
View user's profile Send private message
Juippisi
Guru
Guru


Joined: 30 Sep 2005
Posts: 324
Location: /home

PostPosted: Mon Dec 10, 2018 2:18 pm    Post subject: Reply with quote

Are you using proprietary nvidia-drivers?

https://wiki.gentoo.org/wiki/Enlightenment#.22No_opengl_engines_found.22_with_nvidia-drivers
Back to top
View user's profile Send private message
brigadire
n00b
n00b


Joined: 10 Dec 2018
Posts: 3

PostPosted: Mon Dec 10, 2018 3:07 pm    Post subject: Reply with quote

No. I use Intel i915 (mesa) driver for real hardware and qxl in vm - error is the same.
Back to top
View user's profile Send private message
Juippisi
Guru
Guru


Joined: 30 Sep 2005
Posts: 324
Location: /home

PostPosted: Mon Dec 10, 2018 5:41 pm    Post subject: Reply with quote

Maybe with mesa 18.2 it doesnt support newer opengl. Try with efl[gles] instead?
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Mon Dec 10, 2018 9:10 pm    Post subject: Reply with quote

Try without USE=egl
Back to top
View user's profile Send private message
brigadire
n00b
n00b


Joined: 10 Dec 2018
Posts: 3

PostPosted: Tue Dec 11, 2018 2:33 pm    Post subject: Reply with quote

Quote:
Maybe with mesa 18.2 it doesnt support newer opengl. Try with efl[gles] instead?



Yeah i tried this too:

Code:

[I] dev-libs/efl
     Available versions:  1.20.7-r1 ~1.21.0 ~1.21.1 {X avahi +bmp connman dds debug doc drm +eet egl examples fbcon +fontconfig fribidi gif gles glib gnutls gstreamer harfbuzz hyphen ibus +ico ivi jpeg2k libressl libuv luajit neon nls opengl pdf physics pixman postscript +ppm +psd pulseaudio raw scim sdl sound ssl static-libs svg +system-lz4 systemd tga tiff tslib unwind v4l valgrind vlc vnc wayland webp xcf xim xine xpm xpresent}
     Installed versions:  1.20.7-r1(14:11:34 11.12.2018)(X bmp eet egl fontconfig gles ico nls ppm psd ssl svg -avahi -connman -dds -debug -doc -drm -examples -fbcon -fribidi -gif -glib -gnutls -gstreamer -harfbuzz -hyphen -ibus -ivi -jpeg2k -libressl -libuv -luajit -neon -opengl -pdf -physics -pixman -postscript -pulseaudio -raw -scim -sdl -sound -static-libs -systemd -tga -tiff -tslib -unwind -v4l -valgrind -vlc -vnc -wayland -webp -xcf -xim -xine -xpm -xpresent)
     Homepage:            https://www.enlightenment.org
     Description:         Enlightenment Foundation Libraries all-in-one package



...but it did not help.

When I run elementary_test, I get the same error that I described at the beginning of this topic.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum