Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Display manager not starting at boot. [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
todd93
Guru
Guru


Joined: 30 Oct 2006
Posts: 524
Location: Missouri

PostPosted: Sun Dec 02, 2018 6:47 pm    Post subject: Display manager not starting at boot. [SOLVED] Reply with quote

Hi, all. I'm having trouble getting xdm to start at boot. I followed the installation instructions perfectly, I'm running Mate. I set lightdm as my display manager, added the necessary things to the default run level (consolekit, xdm, and dbus). Whenever I boot, I get a standard terminal login prompt (no display manager), there I login as root, run "xdm start", then I get the lightdm login screen where I can login as my normal user account. When I reboot my system, I have to do it from a terminal as well. When I try to do it from the applications menu, it just logs me out back to the lightdm login screen.

I'm not sure what I've done wrong, or even if those two issues are related. Any input I can get on this is deeply appreciated!

Thanks!

Todd.


Last edited by todd93 on Sun Dec 02, 2018 8:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42581
Location: 56N 3W

PostPosted: Sun Dec 02, 2018 7:10 pm    Post subject: Reply with quote

todd93,

Is xdm in the default runlevel?

Experience is what you get just after you needed it :)

More seriously, work on one issue at a time or you will get confused and your helpers will get confused as one set of advice impacts on another set of advice for solving a different problem.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
todd93
Guru
Guru


Joined: 30 Oct 2006
Posts: 524
Location: Missouri

PostPosted: Sun Dec 02, 2018 8:05 pm    Post subject: Reply with quote

NeddySeagoon,

I don't know how this happened, but xdm was somehow not added to the default run level. I swear I remember doing it, but somehow it wasn't. I feel like such a fool, but that solved both of these problems completely!

I really appreciate all of your help with this install, even though you have helped me with most of it, believe it or not, I've solved several of the problems I was having on my own.

Thanks again!

Todd
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42581
Location: 56N 3W

PostPosted: Sun Dec 02, 2018 8:59 pm    Post subject: Reply with quote

todd93,

Every one of us has been where you are now. We all remember it too.
I've been there and done that.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum