Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome - Gnome takes forever to load and skips login
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Zecuel
n00b
n00b


Joined: 02 Oct 2018
Posts: 18

PostPosted: Mon Nov 26, 2018 5:43 pm    Post subject: Gnome - Gnome takes forever to load and skips login Reply with quote

Hi there!

I have a problem with my Gnome where on startup, it takes forEVER to load into Gnome. The command line appears and some information about connections (wifi, ethernet) pops up, then nothing happens for a solid 2 minutes. Sometimes logging in at the command line helps and ti boots right away to Gnome but sometimes even that doesn't help.

When it finally loads into Gnome, it skips the login screen entirely and just brings me right to my desktop (which is for one, not very secure). If I try to access files or executables it asks me for a password though, so I guess I'm not completely without security..

It worked at one point but suddenly stopped working, and I don't know what I did to mess it up.
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7196
Location: almost Mile High in the USA

PostPosted: Mon Nov 26, 2018 8:15 pm    Post subject: Reply with quote

Probably have two issues here.

Systems have been having problems with the random number generator not initializing due to lack of entropy. A recent kernel update due to a false sense of security bug changed the requirements and many systems no longer can satisfy. Does shaking the mouse or doing random strokes on the touchpad speed up the boot in time? If so, this is the problem and you can continue to use this workaround else it's a userspace bug that needs to be fixed with an update.

The autologin problem you should check with the users manager once you get into gnome (upper right, click on the tools button, click on users). See if that account is set to auto login, though I'd imagine you should have manually enabled autologin for this to be the case...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Zecuel
n00b
n00b


Joined: 02 Oct 2018
Posts: 18

PostPosted: Tue Nov 27, 2018 12:57 pm    Post subject: Reply with quote

eccerr0r wrote:
Probably have two issues here.

Systems have been having problems with the random number generator not initializing due to lack of entropy. A recent kernel update due to a false sense of security bug changed the requirements and many systems no longer can satisfy. Does shaking the mouse or doing random strokes on the touchpad speed up the boot in time? If so, this is the problem and you can continue to use this workaround else it's a userspace bug that needs to be fixed with an update.

The autologin problem you should check with the users manager once you get into gnome (upper right, click on the tools button, click on users). See if that account is set to auto login, though I'd imagine you should have manually enabled autologin for this to be the case...


Turns out, I did indeed have autologin on. Not sure if I set it myself and just forgot about it..

About the startup though, doing random keystrokes seems to help it start up quicker. Do I need to upgrade my kernel to the newest (dev?) version or what is the fix for that?
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5866

PostPosted: Tue Nov 27, 2018 12:59 pm    Post subject: Reply with quote

Should be fixed in 4.18

https://www.phoronix.com/scan.php?page=news_item&px=Linux-4.18-Random-Boot-Fix
_________________
Neddyseagoon wrote:
The problem with leaving is that you can only do it once and it reduces your influence.

banned from #gentoo since sept 2017
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7196
Location: almost Mile High in the USA

PostPosted: Tue Nov 27, 2018 4:45 pm    Post subject: Reply with quote

Oh that is interesting, thought the kernel devs left userspace dead in the water to fix their bugs abusing the random number generator on boot. Then again Linus wanting not to break userspace...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum