Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
OpenSSH 7.7_p1-r9 does not recognize rsa or dsa as valid
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
lordjim
n00b
n00b


Joined: 25 Nov 2018
Posts: 3

PostPosted: Sun Nov 25, 2018 3:58 am    Post subject: OpenSSH 7.7_p1-r9 does not recognize rsa or dsa as valid Reply with quote

Hi,

I've updated OpenSSH to 7.7_p1-r9 and get the following error when trying to generate a key:

"unknown key type rsa".

Same is for dsa.

Does anyone have and idea what can be the cause of this?
Maybe I've missed some of the USE flags but I've checked on the site and everything seems to be in order.
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1001
Location: Frankfurt, Germany

PostPosted: Sun Nov 25, 2018 11:27 am    Post subject: Reply with quote

Please emerge OpenSSH with USE flag 'ssl', if you want to generate RSA or DSA keys.
Back to top
View user's profile Send private message
lordjim
n00b
n00b


Joined: 25 Nov 2018
Posts: 3

PostPosted: Sun Nov 25, 2018 3:14 pm    Post subject: Reply with quote

mike155 wrote:
Please emerge OpenSSH with USE flag 'ssl', if you want to generate RSA or DSA keys.


Thank You. Using USE="ssl" emerge --ask net-misc/openssh worked great.
I have a question, maybe a newb one but what is the difference between using "-ssl" and using "ssl" in USE flags?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21362
Location: here

PostPosted: Sun Nov 25, 2018 3:58 pm    Post subject: Reply with quote

lordjim wrote:
I have a question, maybe a newb one but what is the difference between using "-ssl" and using "ssl" in USE flags?

with character '-' before a use fag you disable this specific feature on package.

Code:
USE="ssl" emerge --ask net-misc/openssh

With this command next time you rebuild openssh the ssl use flag will be disabled because is only applied at this command.
If you want permanently enable the use flag you should use /etc/portage/package.use
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
lordjim
n00b
n00b


Joined: 25 Nov 2018
Posts: 3

PostPosted: Sun Nov 25, 2018 4:37 pm    Post subject: Reply with quote

Thanks for Your help it will help me in the future to avoid mistakes :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum