Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Libreoffice apps do not show menu bar
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ciechomke
n00b
n00b


Joined: 20 Nov 2018
Posts: 6

PostPosted: Tue Nov 20, 2018 6:46 pm    Post subject: Libreoffice apps do not show menu bar Reply with quote

I've installed app-office/libreoffice-6.0.6.2 but every app from the suite I start has no menu bar.
Code:
╰─➤  equery uses libreoffice
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for app-office/libreoffice-6.0.6.2:
 U I
 + + bluetooth                                   : Enable Bluetooth Support
 + + branding                                    : Enable Gentoo specific branding
 + + cups                                        : Add support for CUPS (Common Unix Printing System)
 + + dbus                                        : Enable dbus support for anything that needs it (gpsd, gnomemeeting, etc)
 - - debug                                       : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see
                                                   https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
 - - eds                                         : Enable support for Evolution-Data-Server (EDS)
 - - googledrive                                 : Enable support for remote files on Google Drive
 + + gstreamer                                   : Add support for media-libs/gstreamer (Streaming media)
 + + gtk                                         : Add support for x11-libs/gtk+ (The GIMP Toolkit)
 - - gtk2                                        : Enable legacy gtk2 frontend
 + + java                                        : Add support for Java
 + + jemalloc                                    : Use dev-libs/jemalloc for memory management
 + + libreoffice_extensions_nlpsolver            : LIBREOFFICE_EXTENSIONS option to build non-linear solver for calc
 + + libreoffice_extensions_scripting-beanshell  : LIBREOFFICE_EXTENSIONS option to build beanshell scripts parser
 + + libreoffice_extensions_scripting-javascript : LIBREOFFICE_EXTENSIONS option to build javascript scripts parser
 + + libreoffice_extensions_wiki-publisher       : LIBREOFFICE_EXTENSIONS option to build mediawiki integration
 - - mysql                                       : Add mySQL Database support
 + + odk                                         : Build the Office Development Kit
 + + pdfimport                                   : Enable PDF import via the Poppler library
 - - postgres                                    : Add support for the postgresql database
 - - python_single_target_python2_7              : Build for Python 2.7 only
 - - python_single_target_python3_4              : Build for Python 3.4 only
 - - python_single_target_python3_5              : Build for Python 3.5 only
 + + python_single_target_python3_6              : Build for Python 3.6 only
 + + python_targets_python2_7                    : Build with Python 2.7
 - - python_targets_python3_4                    : Build with Python 3.4
 - - python_targets_python3_5                    : Build with Python 3.5
 + + python_targets_python3_6                    : Build with Python 3.6
 - - test                                        : Enable dependencies and/or preparations necessary to run tests (usually controlled by FEATURES=test but can
                                                   be toggled independently)
 - - vlc                                         : Use media-video/vlc for video embedding



Example output when I start lowriter:
Code:
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx

** (soffice:20000): CRITICAL **: void g_lo_menu_insert_section(GLOMenu*, gint, const gchar*, GMenuModel*): assertion 'G_IS_LO_MENU (menu)' failed

(soffice:20000): Gtk-CRITICAL **: gtk_menu_bar_new_from_model: assertion 'G_IS_MENU_MODEL (model)' failed

(soffice:20000): Gtk-CRITICAL **: gtk_widget_insert_action_group: assertion 'GTK_IS_WIDGET (widget)' failed

(soffice:20000): Gtk-CRITICAL **: gtk_widget_set_hexpand: assertion 'GTK_IS_WIDGET (widget)' failed

(soffice:20000): Gtk-CRITICAL **: gtk_grid_attach: assertion 'GTK_IS_WIDGET (child)' failed

(soffice:20000): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(soffice:20000): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(soffice:20000): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(soffice:20000): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

** (soffice:20000): CRITICAL **: void g_lo_menu_insert_section(GLOMenu*, gint, const gchar*, GMenuModel*): assertion 'G_IS_LO_MENU (menu)' failed

(soffice:20000): Gtk-CRITICAL **: gtk_menu_bar_new_from_model: assertion 'G_IS_MENU_MODEL (model)' failed

(soffice:20000): Gtk-CRITICAL **: gtk_widget_insert_action_group: assertion 'GTK_IS_WIDGET (widget)' failed

(soffice:20000): Gtk-CRITICAL **: gtk_widget_set_hexpand: assertion 'GTK_IS_WIDGET (widget)' failed

(soffice:20000): Gtk-CRITICAL **: gtk_grid_attach: assertion 'GTK_IS_WIDGET (child)' failed

(soffice:20000): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(soffice:20000): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(soffice:20000): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(soffice:20000): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed


Last edited by ciechomke on Tue Nov 20, 2018 10:20 pm; edited 2 times in total
Back to top
View user's profile Send private message
AJM
Tux's lil' helper
Tux's lil' helper


Joined: 25 Sep 2002
Posts: 98
Location: Aberdeen, Scotland

PostPosted: Tue Nov 20, 2018 6:53 pm    Post subject: Reply with quote

Is dbus running?
Back to top
View user's profile Send private message
mike155
l33t
l33t


Joined: 17 Sep 2010
Posts: 989
Location: Frankfurt, Germany

PostPosted: Tue Nov 20, 2018 7:10 pm    Post subject: Reply with quote

1) Disable OpenCL and OpenGL in Tools / Options

2) If that doesn't help, build Libreoffice with USE flag 'gtk2'. Last time I checked (a year ago), the GTK3 interface of LibreOffice was alpha quality at most.
Back to top
View user's profile Send private message
ciechomke
n00b
n00b


Joined: 20 Nov 2018
Posts: 6

PostPosted: Tue Nov 20, 2018 7:31 pm    Post subject: Reply with quote

AJM wrote:
Is dbus running?

Yes

mike155 wrote:

1) Disable OpenCL and OpenGL in Tools / Options

2) If that doesn't help, build Libreoffice with USE flag 'gtk2'. Last time I checked (a year ago), the GTK3 interface of LibreOffice was alpha quality at most.

1. Tried this, does not help
2. Gonna give it a try

This is how it looks like:
https://imgur.com/a/x7MymIE
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Tue Nov 20, 2018 7:44 pm    Post subject: Reply with quote

Try to backup e remove .config/libreoffice/ directory
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ciechomke
n00b
n00b


Joined: 20 Nov 2018
Posts: 6

PostPosted: Tue Nov 20, 2018 8:34 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Try to backup e remove .config/libreoffice/ directory

Didn't help
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Tue Nov 20, 2018 8:46 pm    Post subject: Reply with quote

Try bin version to see if is a system problem or something else.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ciechomke
n00b
n00b


Joined: 20 Nov 2018
Posts: 6

PostPosted: Tue Nov 20, 2018 9:53 pm    Post subject: Reply with quote

Building with gtk2 didn't solve problem, but binary package works fine.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Wed Nov 21, 2018 6:46 am    Post subject: Reply with quote

ciechomke wrote:
Building with gtk2 didn't solve problem, but binary package works fine.

There is also a java problem try to disable this use flag
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ciechomke
n00b
n00b


Joined: 20 Nov 2018
Posts: 6

PostPosted: Wed Nov 21, 2018 12:36 pm    Post subject: Reply with quote

fedeliallalinea wrote:
ciechomke wrote:
Building with gtk2 didn't solve problem, but binary package works fine.

There is also a java problem try to disable this use flag


OK, uinstalled libreoffice-bin (but not deps to check if maybe something from libreoffice deps is missing), installed libreoffice without java and plugins flags and still the same.
I think I should file a bug.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Wed Nov 21, 2018 2:50 pm    Post subject: Reply with quote

I tried to compile libreoffice with your use flag but I can't reproduce the problem
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ralphe
n00b
n00b


Joined: 21 Nov 2018
Posts: 1

PostPosted: Wed Nov 21, 2018 5:56 pm    Post subject: Have the same issue Reply with quote

have exactly the same issue and have tried changing the use flags with no luck what so ever

ix.io/1u6t

(running a window manager / LibreOffice 6.1.3.2 10(Build:2))
Back to top
View user's profile Send private message
ciechomke
n00b
n00b


Joined: 20 Nov 2018
Posts: 6

PostPosted: Fri Nov 23, 2018 1:12 pm    Post subject: Reply with quote

Bug report:
https://bugs.gentoo.org/671634
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Sat Nov 24, 2018 8:45 pm    Post subject: Re: Have the same issue Reply with quote

ralphe wrote:
LibreOffice 6.1.3.2 10(Build:2))

hmm okay, so much for that question.
ralphe wrote:
(running a window manager)

And which one would that be?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum