Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Lumina shuts down shortly after it starts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dbx
n00b
n00b


Joined: 15 Nov 2018
Posts: 1

PostPosted: Thu Nov 15, 2018 6:07 pm    Post subject: Lumina shuts down shortly after it starts Reply with quote

Hello guys,

First of all I am very new to Linux, gentoo and this forum of course. I've already solved some issues I had during the installation etc, however I came across one, which I can't move.

I decided I am going to use Lumina desktop. I read some about a few desktop environments and I've made up my mind this one suits me the best, so please do not respond "why not gnome" :p The point is, I'll probably switch between a few, before I set with one for good. Now in fact I rather want to solve the problem than to use this specific desktop.

Anyway, X11 is up to date, I was making sure everything is up to date. It's Lumina 1.3.0

The desktop is appearing for a few seconds, it's loading (Preparing Workspace) and shortly after some windows are showing up the desktop is shutting down. See the screen after it's crushed:

https://image.ibb.co/fbkZqL/lumina.jpg

Do you reckon it may be my drivers confiiguration? Pointing in any direction would help me a lot.

Thanks in advance.
Back to top
View user's profile Send private message
AJM
Tux's lil' helper
Tux's lil' helper


Joined: 25 Sep 2002
Posts: 98
Location: Aberdeen, Scotland

PostPosted: Sat Nov 17, 2018 12:33 am    Post subject: Reply with quote

Are there any useful logs? ( I don't use Lumina myself but a quick web search suggests you could try looking in ~/.config/lumina-desktop/logs )
Back to top
View user's profile Send private message
dacoo
n00b
n00b


Joined: 08 Jun 2013
Posts: 2

PostPosted: Thu Nov 29, 2018 1:16 pm    Post subject: same error Reply with quote

I have exactly the same error
windowmaker/awesome wm are working fine
there's nothing important in lumina's logs
only informing? message is from kernel:
Code:
[15000.954649] lumina-desktop[19514]: segfault at 100000020 ip 00007fa7640258ce sp 00007ffc1ea31260 error 4 in libQt5Widgets.so.5.11.1[7fa763e28000+624000]
[15054.424471] lumina-desktop[20657]: segfault at 100000020 ip 00007fac664d18ce sp 00007ffd0882f550 error 4 in libQt5Widgets.so.5.11.1[7fac662d4000+624000]


Hence Qt5widgets is the culprit

[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
gene128
n00b
n00b


Joined: 30 Jul 2009
Posts: 12

PostPosted: Thu Nov 29, 2018 11:27 pm    Post subject: Reply with quote

I was using Lumina with qt-5.9. After the qt-5.11 upgrade Lumina crashed on launch as you are seeing.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum