Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
flip_done timed out X and console hangs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
olli.bo
Apprentice
Apprentice


Joined: 16 Jul 2003
Posts: 202
Location: Germany

PostPosted: Wed Nov 14, 2018 10:46 am    Post subject: flip_done timed out X and console hangs Reply with quote

Hi,

half ot fimes I'm switching from X to the console or restarting X I'm getting the following messages and the System hangs for about one minute:

Code:
[ 6853.579277] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:39:pipe A] flip_done timed out
[ 6863.819285] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:39:pipe A] flip_done timed out
[ 6874.059301] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CONNECTOR:52:LVDS-1] flip_done timed out
[ 6884.299279] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:primary A] flip_done timed out
[ 6894.539299] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:39:pipe A] flip_done timed out
[ 6904.779292] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:39:pipe A] flip_done timed out
[ 6915.019274] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CONNECTOR:52:LVDS-1] flip_done timed out
[ 6925.259279] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:primary A] flip_done timed out
[ 6935.499279] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:39:pipe A] flip_done timed out
[ 6945.739274] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:39:pipe A] flip_done timed out
[ 6955.979274] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CONNECTOR:52:LVDS-1] flip_done timed out
[ 6966.219282] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:primary A] flip_done timed out
[ 6976.459393] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:39:pipe A] flip_done timed out
[ 7023.179280] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:39:pipe A] flip_done timed out
[ 7033.419281] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CONNECTOR:52:LVDS-1] flip_done timed out
[ 7043.659273] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:primary A] flip_done timed out


Searching the Internet suggested to use the following boot parameter:
Code:
video=SVIDEO-1:d


This didn't help in my case.
lshw gives the following Infiormation of my graphic chip (Laptop: ThinkPad T420):
Code:
*-display
             description: VGA compatible controller
             product: 2nd Generation Core Processor Family Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 09
             width: 64 bits
             clock: 33MHz
             capabilities: msi pm vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:27 memory:d0000000-d03fffff memory:c0000000-cfffffff ioport:5000(size=64) memory:c0000-dffff


Any ideas what I could to?

Regards
olli
Back to top
View user's profile Send private message
olli.bo
Apprentice
Apprentice


Joined: 16 Jul 2003
Posts: 202
Location: Germany

PostPosted: Thu Nov 15, 2018 3:04 pm    Post subject: Reply with quote

Looks like unmerging x11-drivers/xf86-video-intel and removing i915 from VIDEO_CARDS-Variable in /etc/portage/make.conf and an emerge -uDvN world helped.

Everything incl. glxgears seems to work without it even I use the i915 module.

Code:
# lsmod | grep i915
i915                 1400832  4
iosf_mbi               16384  1 i915
i2c_algo_bit           16384  1 i915
drm_kms_helper        139264  1 i915
drm                   348160  5 drm_kms_helper,i915
i2c_core               53248  5 drm_kms_helper,i2c_algo_bit,i2c_i801,i915,drm
intel_gtt              20480  1 i915
video                  40960  2 thinkpad_acpi,i915


So does anyone know for what the VIDEO_CARDS="i915" variable and the x11-drivers/xf86-video-intel ebuild is needed?

Regards
olli


Last edited by olli.bo on Mon Nov 19, 2018 10:03 am; edited 1 time in total
Back to top
View user's profile Send private message
olli.bo
Apprentice
Apprentice


Joined: 16 Jul 2003
Posts: 202
Location: Germany

PostPosted: Mon Nov 19, 2018 10:01 am    Post subject: Reply with quote

Now I get the following error in my Xorg.0.log:
Code:
[    41.635] (EE) Failed to load module "intel" (module does not exist, 0)

But everything seems to work without problems. Hmm... so this error is OK and can be ignored?
Back to top
View user's profile Send private message
AJM
Tux's lil' helper
Tux's lil' helper


Joined: 25 Sep 2002
Posts: 99
Location: Aberdeen, Scotland

PostPosted: Mon Nov 19, 2018 5:56 pm    Post subject: Reply with quote

olli.bo wrote:
Now I get the following error in my Xorg.0.log:
Code:
[    41.635] (EE) Failed to load module "intel" (module does not exist, 0)

But everything seems to work without problems. Hmm... so this error is OK and can be ignored?


Well if X is working as you would like you can ignore it - it's only telling you that whatever driver you're using it isn't "intel". Somewhere else in the log it will tell you which driver is actually being used...
Back to top
View user's profile Send private message
olli.bo
Apprentice
Apprentice


Joined: 16 Jul 2003
Posts: 202
Location: Germany

PostPosted: Tue Nov 20, 2018 8:53 am    Post subject: Reply with quote

@AJM:
Right, looks like he uses modesetting.

Code:

Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] (II) Module glx: vendor="X.Org Foundation"
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] #011compiled for 1.20.3, module version = 1.0.0
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] #011ABI class: X.Org Server Extension, version 10.0
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] (==) Matched intel as autoconfigured driver 0
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] (==) Matched modesetting as autoconfigured driver 1
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] (==) Matched fbdev as autoconfigured driver 2
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] (==) Matched vesa as autoconfigured driver 3
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] (==) Assigned the driver to the xf86ConfigLayout
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] (II) LoadModule: "intel"
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] (WW) Warning, couldn't open module intel
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] (EE) Failed to load module "intel" (module does not exist, 0)
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] (II) LoadModule: "modesetting"
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] (II) Module modesetting: vendor="X.Org Foundation"
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] #011compiled for 1.20.3, module version = 1.20.3
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] #011Module class: X.Org Video Driver
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] #011ABI class: X.Org Video Driver, version 24.0
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] (II) LoadModule: "fbdev"
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.916] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.917] (II) Module fbdev: vendor="X.Org Foundation"
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.917] #011compiled for 1.20.3, module version = 0.5.0
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.917] #011Module class: X.Org Video Driver
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.917] #011ABI class: X.Org Video Driver, version 24.0
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.917] (II) LoadModule: "vesa"
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.917] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.917] (II) Module vesa: vendor="X.Org Foundation"
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.917] #011compiled for 1.20.3, module version = 2.4.0
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.917] #011Module class: X.Org Video Driver
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.917] #011ABI class: X.Org Video Driver, version 24.0
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.917] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.917] (II) FBDEV: driver for framebuffer: fbdev
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.917] (II) VESA: driver for VESA chipsets: vesa
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.917] (++) using VT number 7
Nov 19 22:45:46 small-gabosh Xorg[14078]:
Nov 19 22:45:46 small-gabosh Xorg[14078]: [ 14326.929] (II) modeset(0): using drv /dev/dri/card0


Is "modesetting" the new and better way?
Why is "intel" the first autoconfigured driver ?

Regards
olli
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum