Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to log in to Gnome 3.24 wayland session
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 432
Location: Stockholm, Sweden

PostPosted: Sun Sep 10, 2017 4:58 pm    Post subject: Unable to log in to Gnome 3.24 wayland session Reply with quote

I'm currently not able to log in using Wayland, since the Gnome 3.24 upgrade, using GDM 3.24.

When debugging the issue, I saw lots weird things being written to the system log though, like:

Quote:
Sep 03 18:58:17 skare dbus[358]: [system] Rejected send message, 0 matched rules; type="error", sender=":1.1" (uid=0 pid=362 comm="/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0>
Sep 03 18:58:17 skare dbus[358]: [system] Rejected send message, 0 matched rules; type="error", sender=":1.1" (uid=0 pid=362 comm="/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0>
Sep 03 18:58:17 skare dbus[358]: [system] Rejected send message, 0 matched rules; type="error", sender=":1.1" (uid=0 pid=362 comm="/lib/systemd/systemd-logind ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0>
Sep 03 18:58:18 skare dbus[358]: [system] Activating via systemd: service name='org.freedesktop.locale1' unit='dbus-org.freedesktop.locale1.service'


I googled the output, and found a systemd bug, that was introduced in 234 and has been fixed in what is to be 235, so it's not what's causing my problems.
https://github.com/systemd/systemd/issues/6375

I've patched systemd in my own overlay, with the patche supplied above, and I've now gotten rid of that specific error output. I'm however seeing some other weird stuff in the log, which might be the reason for me not being able to log in with Wayland (instead of Gnome on Xorg).

Quote:
...
...
Sep 03 16:29:18 skare systemd[1]: Started Session c1 of user gdm.
Sep 03 16:29:18 skare systemd[667]: pam_unix(systemd-user:session): session opened for user gdm by (uid=0)
Sep 03 16:29:18 skare systemd[667]: Reached target Timers.
Sep 03 16:29:18 skare systemd[667]: Reached target Paths.
Sep 03 16:29:18 skare systemd[667]: Reached target Sockets.
Sep 03 16:29:18 skare systemd[667]: Reached target Basic System.
Sep 03 16:29:18 skare systemd[667]: Reached target Default.
Sep 03 16:29:18 skare systemd[667]: Startup finished in 19ms.
Sep 03 16:29:18 skare systemd[1]: Started User Manager for UID 103.
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activating service name='org.freedesktop.systemd1'
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activating service name='org.freedesktop.systemd1'
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activating service name='org.freedesktop.systemd1'
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activating service name='org.freedesktop.systemd1'
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activating service name='org.freedesktop.systemd1'
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activating service name='org.freedesktop.systemd1'
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activating service name='org.freedesktop.systemd1'
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activating service name='org.freedesktop.systemd1'
Sep 03 16:29:18 skare /usr/libexec/gdm-wayland-session[672]: Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
Sep 03 16:29:19 skare gnome-shell[699]: Failed to apply DRM plane transform 0: Invalid argument
Sep 03 16:29:19 skare org.gnome.Shell.desktop[699]: glamor: EGL version 1.5 (DRI2):
Sep 03 16:29:19 skare /usr/libexec/gdm-wayland-session[672]: Activating service name='org.freedesktop.systemd1'
Sep 03 16:29:19 skare /usr/libexec/gdm-wayland-session[672]: Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
Sep 03 16:29:19 skare /usr/libexec/gdm-wayland-session[672]: Activating service name='org.freedesktop.systemd1'
Sep 03 16:29:19 skare /usr/libexec/gdm-wayland-session[672]: Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
Sep 03 16:29:19 skare /usr/libexec/gdm-wayland-session[672]: Activating service name='org.a11y.Bus'
Sep 03 16:29:19 skare /usr/libexec/gdm-wayland-session[672]: Successfully activated service 'org.a11y.Bus'
...
...


Is anybode else having issues with this. I've tried googling for problems with Gnome 3.24 and Wayland, and found some Arch-discussions, but nothing with a concrete solution. The bold text above feels suspicious to me.

I have no issues running Gnome on X.
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 432
Location: Stockholm, Sweden

PostPosted: Sun Oct 15, 2017 10:23 am    Post subject: Reply with quote

Nobody has any idea what might be causing this issue?
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
Juippisi
Guru
Guru


Joined: 30 Sep 2005
Posts: 341
Location: /home

PostPosted: Mon Oct 16, 2017 9:04 am    Post subject: Reply with quote

Well, a shot in the dark, but there was some discussion in gnome-without-systemd thread about wayland and egl. I dont use wayland so I cant help much but here are the relevant links, maybe you find something out of them:

https://forums.gentoo.org/viewtopic-t-1022050-start-325.html "GNOME Without Systemd" page 14
https://bugzilla.gnome.org/show_bug.cgi?id=785262

Good luck.
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 432
Location: Stockholm, Sweden

PostPosted: Mon Nov 12, 2018 9:17 pm    Post subject: Reply with quote

I've re-installed Gentoo from scratch, and now I'm hitting this issue again. I'm unable to start GDM both via systemd and from the tty. It's really annoying, since I can't remember if/how I was able to fix it the last time...
Now I'm stuck with a system where I'm able to start gnome directly, but not GDM, and gnome is nowdays quite crippled without gdm.
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum