Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-libs/libbsd media-sound/mpg123 errors?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
InvisibleRasta
Tux's lil' helper
Tux's lil' helper


Joined: 30 Mar 2011
Posts: 112

PostPosted: Sun Nov 11, 2018 8:07 pm    Post subject: dev-libs/libbsd media-sound/mpg123 errors? Reply with quote

hello guys, how can i solve this?
Code:
!!! existing preserved libs:
>>> package: dev-libs/libbsd-0.9.1
 *  - /usr/lib32/libbsd.so.0
 *  - /usr/lib32/libbsd.so.0.9.1
 *      used by /usr/lib32/libtalloc.so.2.1.14 (sys-libs/talloc-2.1.14)
 *      used by /usr/lib32/libtdb.so.1.3.16 (sys-libs/tdb-1.3.16)
 *      used by /usr/lib32/tevent/libreplace-tevent.so (sys-libs/tevent-0.9.37)
>>> package: media-sound/mpg123-1.25.10-r1
 *  - /usr/lib64/libmpg123.so.0
 *  - /usr/lib64/libmpg123.so.0.44.8
 *      used by /usr/lib64/vlc/plugins/codec/libmpg123_plugin.so (media-video/vlc-3.0.4)
Use emerge @preserved-rebuild to rebuild packages using these libraries
 nico@localhost  ~/Documents  emerge @preserved-rebuild
emerge: superuser access is required
 ✘ nico@localhost  ~/Documents  sudo emerge @preserved-rebuild
Password:
Calculating dependencies... done!
[ebuild   R    ] sys-libs/talloc-2.1.14  ABI_X86="-32*"
[ebuild   R    ] sys-libs/tdb-1.3.16  USE="-python*" ABI_X86="-32*"
[ebuild   R    ] sys-libs/tevent-0.9.37  USE="-python*" ABI_X86="-32*"
[ebuild   R    ] media-video/vlc-3.0.4

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/tevent:0

  (sys-libs/tevent-0.9.37:0/0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-libs/tevent-0.9.37:0/0::gentoo, installed) pulled in by
    >=sys-libs/tevent-0.9.36[python(+)?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-libs/ldb-1.3.6:0/1.3.6::gentoo, installed)


sys-libs/talloc:0

  (sys-libs/talloc-2.1.14:0/0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-libs/talloc-2.1.14:0/0::gentoo, installed) pulled in by
    >=sys-libs/talloc-2.1.13[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-libs/tevent-0.9.37:0/0::gentoo, installed)


sys-libs/tdb:0

  (sys-libs/tdb-1.3.16:0/0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-libs/tdb-1.3.16:0/0::gentoo, installed) pulled in by
    >=sys-libs/tdb-1.3.15[python?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-libs/ldb-1.3.6:0/1.3.6::gentoo, installed)
                          ^^^^^^^


!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might help emerge to give a more specific suggestion.

 ✘ nico@localhost  ~/Documents  sudo emerge @preserved-rebuild --newuse and --update
Password:
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "and".

emerge: searching for similar names...
emerge: Maybe you meant any of these: app-text/an, app-editors/sandy, dev-haskell/sandi?
 ✘ nico@localhost  ~/Documents  sudo emerge @preserved-rebuild --newuse --update
Calculating dependencies... done!

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

sys-libs/tevent:0

  (sys-libs/tevent-0.9.37:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=sys-libs/tevent-0.9.36[python(+),abi_x86_64(-)] required by (sys-libs/ldb-1.3.6:0/1.3.6::gentoo, installed)


sys-libs/talloc:0

  (sys-libs/talloc-2.1.14:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=sys-libs/talloc-2.1.13[abi_x86_32(-),abi_x86_64(-)] required by (sys-libs/tevent-0.9.37:0/0::gentoo, installed)


sys-libs/tdb:0

  (sys-libs/tdb-1.3.16:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=sys-libs/tdb-1.3.15[python,abi_x86_64(-)] required by (sys-libs/ldb-1.3.6:0/1.3.6::gentoo, installed)
                          ^^^^^^

>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.
 nico@localhost  ~/Documents 


[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 20099
Location: here

PostPosted: Sun Nov 11, 2018 8:30 pm    Post subject: Reply with quote

You removed abi_x86_32 to these packages
Code:
[ebuild   R    ] sys-libs/talloc-2.1.14  ABI_X86="-32*"
[ebuild   R    ] sys-libs/tdb-1.3.16  USE="-python*" ABI_X86="-32*"
[ebuild   R    ] sys-libs/tevent-0.9.37  USE="-python*" ABI_X86="-32*"

why?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
InvisibleRasta
Tux's lil' helper
Tux's lil' helper


Joined: 30 Mar 2011
Posts: 112

PostPosted: Sun Nov 11, 2018 8:40 pm    Post subject: Reply with quote

to get rid completely of 32 bit stuff.. but i am getting this errors
seems like sys-libs/tdb sys-libs/talloc sys-libs/tevent are part of the samba package. samba can only be built with 32 bit?
Code:
 emerge -cav sys-libs/tdb sys-libs/talloc sys-libs/tevent

Calculating dependencies... done!
  sys-libs/talloc-2.1.14 pulled in by:
    net-fs/samba-4.8.6-r2 requires >=sys-libs/talloc-2.1.11[python_targets_python2_7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),python_single_target_python2_7(+),abi_x86_64(-)]
    sys-libs/ldb-1.3.6 requires >=sys-libs/talloc-2.1.11[python,abi_x86_64(-)]
    sys-libs/tevent-0.9.37 requires >=sys-libs/talloc-2.1.13[abi_x86_32(-),abi_x86_64(-)]

  sys-libs/tdb-1.3.16 pulled in by:
    net-fs/samba-4.8.6-r2 requires >=sys-libs/tdb-1.3.15[python_targets_python2_7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),python_single_target_python2_7(+),abi_x86_64(-)]
    sys-libs/ldb-1.3.6 requires >=sys-libs/tdb-1.3.15[python,abi_x86_64(-)]

  sys-libs/tevent-0.9.37 pulled in by:
    net-fs/samba-4.8.6-r2 requires >=sys-libs/tevent-0.9.36[python_targets_python2_7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),python_single_target_python2_7(+),abi_x86_64(-)]
    sys-libs/ldb-1.3.6 requires >=sys-libs/tevent-0.9.36[python(+),abi_x86_64(-)]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 20099
Location: here

PostPosted: Sun Nov 11, 2018 8:50 pm    Post subject: Reply with quote

You tried before it to run
Code:
emerge -UD --with-bdeps y @world

for rebuild all packages where was removed abi_x86_32 use flag?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
InvisibleRasta
Tux's lil' helper
Tux's lil' helper


Joined: 30 Mar 2011
Posts: 112

PostPosted: Sun Nov 11, 2018 8:54 pm    Post subject: Reply with quote

this is the output. not sure on how to manage all this
http://dpaste.com/1QS33QC
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 20099
Location: here

PostPosted: Mon Nov 12, 2018 6:55 am    Post subject: Reply with quote

First add correct use flag to
Code:
sys-libs/tdb:0

  (sys-libs/tdb-1.3.16:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=sys-libs/tdb-1.3.15[python,abi_x86_64(-)] required by (sys-libs/ldb-1.3.6:0/1.3.6::gentoo, installed)
                          ^^^^^^       
sys-boot/grub:2

  (sys-boot/grub-2.02-r1:2/2.02-r1::gentoo, ebuild scheduled for merge) conflicts with
    sys-boot/grub:2[mount] required by (sys-boot/os-prober-1.76-r1:0/0::gentoo, installed)
                    ^^^^^
dev-libs/boost:0

  (dev-libs/boost-1.65.0:0/1.65.0::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-libs/boost-1.52.0-r6:0/1.65.0=[python,python_targets_python2_7(-),-python_single_target_python2_7(-)] required by (media-libs/vigra-1.11.1:0/0::gentoo, installed)
                                         ^^^^^^                                                               
    >=dev-libs/boost-1.52.0-r6:=[python,python_targets_python2_7(-),-python_single_target_python2_7(-)] required by (media-libs/vigra-1.11.1:0/0::gentoo, installed)
                                 ^^^^^^     

Grub need mount use flag, boost and tdb need python use flag. Then re-run command and see if work.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
InvisibleRasta
Tux's lil' helper
Tux's lil' helper


Joined: 30 Mar 2011
Posts: 112

PostPosted: Mon Nov 12, 2018 12:44 pm    Post subject: Reply with quote

i solved with what you suggested, i think i still have something broken tho:
Code:
emerge @preserved-rebuild
Calculating dependencies... done!
[ebuild   R    ] sys-libs/talloc-2.1.14  ABI_X86="-32*"
[ebuild   R    ] sys-libs/tevent-0.9.37  USE="-python*" ABI_X86="-32*"
[ebuild   R    ] media-video/vlc-3.0.4

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/tevent:0

  (sys-libs/tevent-0.9.37:0/0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-libs/tevent-0.9.37:0/0::gentoo, installed) pulled in by
    >=sys-libs/tevent-0.9.36[python(+)?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-libs/ldb-1.3.6:0/1.3.6::gentoo, installed)


sys-libs/talloc:0

  (sys-libs/talloc-2.1.14:0/0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-libs/talloc-2.1.14:0/0::gentoo, installed) pulled in by
    >=sys-libs/talloc-2.1.13[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (sys-libs/tevent-0.9.37:0/0::gentoo, installed)



!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might help emerge to give a more specific suggestion.


[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 20099
Location: here

PostPosted: Mon Nov 12, 2018 12:52 pm    Post subject: Reply with quote

Try what portage suggest
Code:
!!! Enabling --newuse and --update might solve this conflict.

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
InvisibleRasta
Tux's lil' helper
Tux's lil' helper


Joined: 30 Mar 2011
Posts: 112

PostPosted: Mon Nov 12, 2018 4:39 pm    Post subject: Reply with quote

i am getting dependency conflicts
Code:
 emerge @preserved-rebuild --newuse --update
Calculating dependencies... done!

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

sys-libs/tevent:0

  (sys-libs/tevent-0.9.37:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=sys-libs/tevent-0.9.36[python(+),abi_x86_64(-)] required by (sys-libs/ldb-1.3.6:0/1.3.6::gentoo, installed)
                                                     

sys-libs/talloc:0

  (sys-libs/talloc-2.1.14:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=sys-libs/talloc-2.1.13[abi_x86_32(-),abi_x86_64(-)] required by (sys-libs/tevent-0.9.37:0/0::gentoo, installed)
                                                         

>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 20099
Location: here

PostPosted: Mon Nov 12, 2018 7:08 pm    Post subject: Reply with quote

What return command emerge -UD --with-bdeps y @world --backtrack=100?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
InvisibleRasta
Tux's lil' helper
Tux's lil' helper


Joined: 30 Mar 2011
Posts: 112

PostPosted: Tue Nov 13, 2018 8:24 pm    Post subject: Reply with quote

here it is
http://dpaste.com/0S0X5WG
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum