Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Stellarium crashes on startup
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 508
Location: Cape Town, South Africa

PostPosted: Sat Nov 10, 2018 9:34 am    Post subject: Stellarium crashes on startup Reply with quote

Hi

I installed Stellarium okay (I see people had issues back in August) but it crashes on startup.

So wondering if this is "my system" at fault or the package. I see it has some fontconfig issues:

Code:

Fontconfig error: failed reading config file
Fontconfig error: Cannot load config file "infinality/conf.d"
 -------------------------------------------------------
[ This is Stellarium 0.16.0 - http://www.stellarium.org ]
[ Copyright (C) 2000-2017 Fabien Chereau et al.         ]
 -------------------------------------------------------
Writing log file to: "/home/ian/.stellarium/log.txt"
File search paths:
  0 .  "/home/ian/.stellarium"
  1 .  "/usr/share/stellarium"
Config file is:  "/home/ian/.stellarium/config.ini"
Default surface format:  QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize -1, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize -1, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(DefaultSwapBehavior), swapInterval 1, colorSpace QSurfaceFormat::ColorSpace(DefaultColorSpace), profile  QSurfaceFormat::OpenGLContextProfile(NoProfile))
Desired surface format:  QSurfaceFormat(version 2.1, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(DefaultSwapBehavior), swapInterval 1, colorSpace QSurfaceFormat::ColorSpace(DefaultColorSpace), profile  QSurfaceFormat::OpenGLContextProfile(NoProfile))
StelGLWidget constructor
StelGraphicsScene constructor
initializeGL
OpenGL supported version:  "4.6.0 NVIDIA 390.87"
Current Format:  QSurfaceFormat(version 4.6, options QFlags<QSurfaceFormat::FormatOption>(DeprecatedFunctions), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::SwapBehavior(DefaultSwapBehavior), swapInterval 1, colorSpace QSurfaceFormat::ColorSpace(DefaultColorSpace), profile  QSurfaceFormat::OpenGLContextProfile(CompatibilityProfile))
StelMainView::init
Detected: OpenGL "4.6"
Driver version string: "4.6.0 NVIDIA 390.87"
GL vendor is "NVIDIA Corporation"
GL renderer is "GeForce GTX 560/PCIe/SSE2"
GL Shading Language version is "4.60 NVIDIA"
GLSL Version Number detected:  4.6
GLSL version is fine, we should not see a graphics problem.
Cache directory is:  "/home/ian/.cache/stellarium/stellarium"
Sky language is  "en_ZA"
Application language is  "en_ZA"
Loading Solar System data (1: planets and moons) ...
Loading from : "/usr/share/stellarium/data/ssystem_major.ini"
Loaded 60 Solar System bodies
Loading Solar System data (2: minor bodies)...
Loading from : "/home/ian/.stellarium/data/ssystem_minor.ini"
Loaded 97 Solar System bodies
File ssystem_minor.ini is loaded successfully...
Loading star data ...
"Loading /usr/share/stellarium/stars/default/stars_0_0v0_7.cat: 0_0v0_7; 4979"
"Loading /usr/share/stellarium/stars/default/stars_1_0v0_7.cat: 1_0v0_7; 21806"
"Loading /usr/share/stellarium/stars/default/stars_2_0v0_7.cat: 2_0v0_7; 150850"
"Loading /usr/share/stellarium/stars/default/stars_3_1v0_4.cat: 3_1v0_4; 425807"
Finished loading star catalogue data, max_geodesic_level:  3
Loading scientific star names from "/usr/share/stellarium/stars/default/name.fab"
Loaded 4506 / 4506 scientific star names
Loading variable stars from "/usr/share/stellarium/stars/default/gcvs_hip_part.dat"
Loaded 6916 / 6916 variable stars
Loading double stars from "/usr/share/stellarium/stars/default/wds_hip_part.dat"
Loaded 16412 / 16412 double stars
Loading cross-identification data from "/usr/share/stellarium/stars/default/cross-id.dat"
Loaded 108278 / 108278 cross-identification data records for stars
navigation/preset_sky_time is a double - treating as jday: "2451514.25001"
Loading DSO data...
Loaded 10875 DSO records
LandscapeMgr: initialized Cache for 100 MB.
Loading star names from "/usr/share/stellarium/skycultures/western/star_names.fab"
Loaded 770 / 770 common star names
Loading DSO name data ...
Loaded 492 / 678 DSO name records successfully
Loaded 88 / 88 constellation records successfully for culture "western"
Loaded 85 / 85 constellation art records successfully for culture "western"
Loaded 88 / 88 constellation names
Loading constellation boundary data ...
Loaded 782 constellation boundary segments
Loaded 35 / 35 asterism records successfully for culture "western"
Loaded 35 / 35 asterism names
stel.OpenGLArray: Vertex Array Objects are supported
Initializing basic GL shaders...
Creating GUI ...
Loaded plugin "Exoplanets"
[Exoplanets] Version of the format of the catalog: 1
[Exoplanets] loading catalog file: "/home/ian/.stellarium/modules/Exoplanets/exoplanets.json"
Loaded plugin "FOV"
Loaded plugin "MeteorShowers"
MeteorShowersMgr: Loading catalog file: "/home/ian/.stellarium/modules/MeteorShowers/showers.json"
Loaded plugin "Novae"
[Novae] version of the catalog: 1
[Novae] loading catalog file: "/home/ian/.stellarium/modules/Novae/novae.json"
Loaded plugin "Oculars"
Ocular plugin - press Command-O to toggle eyepiece view mode. Press ALT-o for configuration.
Oculars::validateIniFile ocular.ini exists at:  "/home/ian/.stellarium/modules/Oculars/ocular.ini" . Checking version...
Oculars::validateIniFile found existing ini file version  3.1
Loaded plugin "Satellites"
[Satellites] loading catalog file: "/home/ian/.stellarium/modules/Satellites/satellites.json"
Satellite has invalid orbit: "MOLNIYA 1-44" "11474"
Satellite has invalid orbit: "IRIDIUM 43" "25039"
Satellite has invalid orbit: "IRIDIUM 40" "25041"
Satellite has invalid orbit: "TIANGONG 1" "37820"
Satellite has invalid orbit: "CZ-3B R/B" "38253"
Satellite has invalid orbit: "FIREFLY" "39404"
Satellite has invalid orbit: "BEVO 2" "41314"
Satellite has invalid orbit: "NODES 2" "41477"
Satellite has invalid orbit: "NODES 1" "41478"
Satellite has invalid orbit: "FLOCK 2E-8" "41566"
Satellite has invalid orbit: "LEMUR-2-DRMUZZ" "41595"
Satellite has invalid orbit: "TANCREDO-1" "41931"
Satellite has invalid orbit: "TUPOD" "41936"
Satellite has invalid orbit: "TECHEDSAT 5" "42066"
Satellite has invalid orbit: "ISS DEB" "42434"
Satellite has invalid orbit: "ISS DEB" "42697"
Satellite has invalid orbit: "DUTHSAT" "42724"
Satellite has invalid orbit: "NSIGHT-1" "42726"
Loaded plugin "SolarSystemEditor"
Using the ssystem_minor.ini file that already exists in the user directory...
Dubious result: Landscape  "Guereins"  not calibrated. Opacity test represents mathematical horizon only.
Initializing planets GL shaders...
terminate called after throwing an instance of 'std::runtime_error'
  what():  illegal value
Aborted


I have these lying around, should I delete them? Font / fontconfig issues have improved over recent months, but still some issues, like source code rendering in Firefox.

Code:

!!! Broken orphaned files: No installed package was found for the following:
        * /usr/local/lib64/font-manager/libfontmanager-0.7.3.so
        * /usr/local/bin/font-manager
        * /usr/local/lib64/font-manager/libfontmanager.la
        * /usr/local/lib/font-manager/libfontmanager.la


Thanks, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
Juippisi
Guru
Guru


Joined: 30 Sep 2005
Posts: 300
Location: /home

PostPosted: Sun Nov 11, 2018 7:35 am    Post subject: Reply with quote

Doesn't seem like fontconfig is the one causing issues, but I cant be sure.

You could try updating to latest version,
https://github.com/gentoo/gentoo/pull/10368

and if that doesn't work, maybe make a bug report with proper strace / gdb log attached?
Back to top
View user's profile Send private message
wjb
Guru
Guru


Joined: 10 Jul 2005
Posts: 394
Location: Fife, Scotland

PostPosted: Sun Nov 11, 2018 11:17 am    Post subject: Reply with quote

Try clearing your local settings (rename ~/.stellarium) - it might be a problem with the plugins you have
Back to top
View user's profile Send private message
bitnick
n00b
n00b


Joined: 07 Jan 2007
Posts: 24
Location: Stockholm, Sweden

PostPosted: Mon Nov 12, 2018 10:01 pm    Post subject: Reply with quote

I have the same problem with stellarium-0.16.0-r1. I removed ~/.stellarium; that didn't help. I then edited the (newly created) ~/.stellarium/config.ini to disable all plugins; that didn't help either. It's also not the known problem with corrupted .json files. A run with strace didn't show anything obvious. So I gave up on 0.16.0.

However stellarium-0.18.2 works fine. I attached an ebuild for that version here: https://bugs.gentoo.org/618158. But I had to disable TelescopeControl to get that version to build, so just be aware of that.

Edit: Fixed link.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6625
Location: Austria

PostPosted: Mon Nov 12, 2018 11:20 pm    Post subject: Reply with quote

0.18.2 had already been in preparation for some time via Gentoo github review, it is now in tree.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
bitnick
n00b
n00b


Joined: 07 Jan 2007
Posts: 24
Location: Stockholm, Sweden

PostPosted: Tue Nov 13, 2018 9:49 pm    Post subject: Reply with quote

Cool! Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum