Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't hide firefox's titlebar
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
G3ph4z
n00b
n00b


Joined: 31 Jul 2018
Posts: 4

PostPosted: Fri Nov 09, 2018 9:43 pm    Post subject: Can't hide firefox's titlebar Reply with quote

Hello Guys,

so I have fresh install gentoo + XFCE. Everything was fine until I installed consolkit + pulseaudio. Since that I can't hide titlebar.
Its firefox-bin 63.0.1

Screenshot
Back to top
View user's profile Send private message
arnvidr
Guru
Guru


Joined: 19 Aug 2004
Posts: 589
Location: Oslo, Norway

PostPosted: Sat Nov 10, 2018 11:57 am    Post subject: Reply with quote

Show what you've tried to hide it. Was it hidden before?
_________________
Noone wrote:
anything
Back to top
View user's profile Send private message
Hund
n00b
n00b


Joined: 18 Jul 2016
Posts: 40
Location: Sweden

PostPosted: Sat Nov 10, 2018 12:16 pm    Post subject: Reply with quote

Isn't that the window managers job? I don't see how either Consolekit or Pulseaudio has anything to do with it.

Maybe you had the option `Hide title of window when maximized` enabled before and it somehow got disabled now? You should find it in the settings `Window Manager Tweaks / Accessibility`. I don't use Xfce myself. I'm also pretty sure that you should be able to toggle the window decorations per client with a hotkey as well.

Edit: Why are you logged in as the root user and not as a regular user with limited permissions?
_________________
Screenshots | dotfiles | Blog
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21335
Location: here

PostPosted: Sat Nov 10, 2018 12:36 pm    Post subject: Reply with quote

It seems that xfce not support full CSD (client side decoration), see https://bugzilla.mozilla.org/show_bug.cgi?id=1419456
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
G3ph4z
n00b
n00b


Joined: 31 Jul 2018
Posts: 4

PostPosted: Sat Nov 10, 2018 12:41 pm    Post subject: Reply with quote

Hund wrote:
Isn't that the window managers job? I don't see how either Consolekit or Pulseaudio has anything to do with it.

Maybe you had the option `Hide title of window when maximized` enabled before and it somehow got disabled now? You should find it in the settings `Window Manager Tweaks / Accessibility`. I don't use Xfce myself. I'm also pretty sure that you should be able to toggle the window decorations per client with a hotkey as well.

Edit: Why are you logged in as the root user and not as a regular user with limited permissions?


Yep, that's working, but I want to make work the firefox's built-in "title bar hiding" function (Customization/Title Bar checkbox) because its worked before I installed those things.

Because I didn't made user yet, its fresh install.

arnvidr wrote:
Show what you've tried to hide it. Was it hidden before?


It was hidden before because the firefox's "hide title bar" functions worked fine until I installed consolekit and pulseaudio (and pavucontrol).

fedeliallalinea wrote:
It seems that xfce not support full CSD (client side decoration), see https://bugzilla.mozilla.org/show_bug.cgi?id=1419456


Maybe, but its worked fine and also its works on my debian machine. I am a bit confused now. :/


EDIT:
It was also problem with my previous KDE setup.
Back to top
View user's profile Send private message
Hund
n00b
n00b


Joined: 18 Jul 2016
Posts: 40
Location: Sweden

PostPosted: Sat Nov 10, 2018 1:10 pm    Post subject: Reply with quote

G3ph4z wrote:
Hund wrote:
Isn't that the window managers job? I don't see how either Consolekit or Pulseaudio has anything to do with it.

Maybe you had the option `Hide title of window when maximized` enabled before and it somehow got disabled now? You should find it in the settings `Window Manager Tweaks / Accessibility`. I don't use Xfce myself. I'm also pretty sure that you should be able to toggle the window decorations per client with a hotkey as well.

Edit: Why are you logged in as the root user and not as a regular user with limited permissions?


Yep, that's working, but I want to make work the firefox's built-in "title bar hiding" function (Customization/Title Bar checkbox) because its worked before I installed those things.

Because I didn't made user yet, its fresh install.

arnvidr wrote:
Show what you've tried to hide it. Was it hidden before?


It was hidden before because the firefox's "hide title bar" functions worked fine until I installed consolekit and pulseaudio (and pavucontrol).

fedeliallalinea wrote:
It seems that xfce not support full CSD (client side decoration), see https://bugzilla.mozilla.org/show_bug.cgi?id=1419456


Maybe, but its worked fine and also its works on my debian machine. I am a bit confused now. :/


EDIT:
It was also problem with my previous KDE setup.


I understand. I didn't know about that since I use a tiling window manager myself. :)
_________________
Screenshots | dotfiles | Blog
Back to top
View user's profile Send private message
Juippisi
Guru
Guru


Joined: 30 Sep 2005
Posts: 324
Location: /home

PostPosted: Sun Nov 11, 2018 7:40 am    Post subject: Reply with quote

XFce should support hiding titlebar. Have you checked in about:config that you have 'browser.tabs.drawInTitlebar = true'?

There was also some sort of variable you could force it on, but I don't remember it anymore. Check if 'env | grep XDG_CURRENT_DESKTOP' does return xfce...

Also make absolutely sure you're using firefox-63, there was some dependency problems that downgraded it to 52 for some people.
Back to top
View user's profile Send private message
G3ph4z
n00b
n00b


Joined: 31 Jul 2018
Posts: 4

PostPosted: Sun Nov 11, 2018 12:10 pm    Post subject: Reply with quote

Juippisi wrote:
XFce should support hiding titlebar. Have you checked in about:config that you have 'browser.tabs.drawInTitlebar = true'?

There was also some sort of variable you could force it on, but I don't remember it anymore. Check if 'env | grep XDG_CURRENT_DESKTOP' does return xfce...

Also make absolutely sure you're using firefox-63, there was some dependency problems that downgraded it to 52 for some people.


browser.tabs.drawInTitlebar = true, yes.

'env | grep XDG_CURRENT_DESKTOP' it doesn't give back anything.

I'am absolutely sure its 63.0.1
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum