Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 3.24.2: Where is the Power off Button
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Strong_1983
n00b
n00b


Joined: 07 Nov 2018
Posts: 4
Location: Guayaquil - Ecuador

PostPosted: Wed Nov 07, 2018 6:28 pm    Post subject: Gnome 3.24.2: Where is the Power off Button Reply with quote

Hi everybody,

I had a lot of time without update my laptop... finally after one week of resolving duplicate slots and dependencies problems... I could update!

Everything is working greate!

The thing is that I noticed that the power button is not where should be!.

I was looking on google about some similar problems but, it's appear that no-one are like mine.

Could you please give me a clue?

Thanks a lot.
_________________
Best regards,

Strong1983
Born to be root.
Back to top
View user's profile Send private message
Muso
l33t
l33t


Joined: 22 Oct 2002
Posts: 968
Location: The Holy city of Honolulu

PostPosted: Thu Nov 08, 2018 4:38 am    Post subject: Reply with quote

You could always just open a terminal and do :
Code:
su
halt


Or

Code:
sudo halt

_________________
Time is a great teacher, but unfortunately it kills all its pupils.
Back to top
View user's profile Send private message
Strong_1983
n00b
n00b


Joined: 07 Nov 2018
Posts: 4
Location: Guayaquil - Ecuador

PostPosted: Thu Nov 08, 2018 5:00 am    Post subject: Reply with quote

Muso wrote:
You could always just open a terminal and do :
Code:
su
halt


Or

Code:
sudo halt


Ofcourse I can!

In fact... I'm doing that since a few days ago... the think is that I don't know what happend with the power off button in Gnome :s

Best regards :)
_________________
Best regards,

Strong1983
Born to be root.
Back to top
View user's profile Send private message
Strong_1983
n00b
n00b


Joined: 07 Nov 2018
Posts: 4
Location: Guayaquil - Ecuador

PostPosted: Thu Nov 08, 2018 1:26 pm    Post subject: Reply with quote

Ok... I found a clue in /var/log/messages

Quote:
Nov 8 08:19:30 strong1983hp gnome-session-binary[13488]: WARNING: Calling CanPowerOff failed. Check that logind is properly installed and pam_systemd is getting used at login.
Nov 8 08:19:30 strong1983hp gnome-session-binary[13488]: WARNING: Calling CanReboot failed. Check that logind is properly installed and pam_systemd is getting used at login.
Nov 8 08:19:30 strong1983hp gnome-session[13488]: gnome-session-binary[13488]: WARNING: Calling CanSuspend failed. Check that logind is properly installed and pam_systemd is getting used at login.
Nov 8 08:19:30 strong1983hp gnome-session-binary[13488]: WARNING: Calling CanSuspend failed. Check that logind is properly installed and pam_systemd is getting used at login.
Nov 8 08:19:30 strong1983hp gnome-session[13488]: gnome-session-binary[13488]: WARNING: Calling CanHibernate failed. Check that logind is properly installed and pam_systemd is getting used at login.
Nov 8 08:19:30 strong1983hp gnome-session-binary[13488]: WARNING: Calling CanHibernate failed. Check that logind is properly installed and pam_systemd is getting used at login.
Nov 8 08:19:30 strong1983hp gnome-shell[13569]: JS ERROR: TypeError: childToShow is null
AltSwitcher<._sync@resource:///org/gnome/shell/ui/status/system.js:90:13
wrapper@resource:///org/gnome/gjs/modules/lang.js:178:22
Indicator<._updatePowerOff@resource:///org/gnome/shell/ui/status/system.js:337:62
wrapper@resource:///org/gnome/gjs/modules/lang.js:178:22
Indicator<._updateHaveShutdown/<@resource:///org/gnome/shell/ui/status/system.js:329:13
_proxyInvoker/asyncCallback@resource:///org/gnome/gjs/modules/overrides/Gio.js:90:13


I'm working on that now.
_________________
Best regards,

Strong1983
Born to be root.
Back to top
View user's profile Send private message
Strong_1983
n00b
n00b


Joined: 07 Nov 2018
Posts: 4
Location: Guayaquil - Ecuador

PostPosted: Thu Nov 08, 2018 2:28 pm    Post subject: Reply with quote

When I start the gnome session with root, the Power Off button appears!

I was checking the pam configuration, but with my user nothing appears to work, the Power Off button doesn't appears :s
_________________
Best regards,

Strong1983
Born to be root.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum