Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]Conky doesn't like my config in Gentoo, only in Arch
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Hund
n00b
n00b


Joined: 18 Jul 2016
Posts: 56
Location: Sweden

PostPosted: Tue Nov 06, 2018 4:49 pm    Post subject: [Solved]Conky doesn't like my config in Gentoo, only in Arch Reply with quote

This is my Conky configuration that I use with i3bar. It works in Arch Linux with Conky 1.10.8, but not with Conky 1.10.8 in Gentoo.

Code:
out_to_x no
own_window no
out_to_console yes
background no
max_text_width 0
update_interval 2.0
total_run_times 0
short_units yes
use_spacer left
override_utf8_locale no
cpu_avg_samples 2

TEXT

[\
# Volume
{ "full_text" : "${eval  }", "color" : "\#1ABC9C", "separator" : false, "separator_block_width" : 3 }, \
{ "full_text" : "${execi 5 sh "$HOME/Scripts/volume_print.sh"}", "color" : "\#CCCCCC", "separator" : false, "separator_block_width" : 3 }, \
{ "full_text" : "${eval |}", "color" : "\#333333", "separator" : false, "separator_block_width" : 3 }, \

# Clock
{ "full_text" : "${eval  }", "color" : "\#CCCCCC", "separator" : false, "separator_block_width" : 3 }, \
{ "full_text" : "${time %a %d %b, %H:%M}", "color" : "\#CCCCCC", "separator" : false, "separator_block_width" : 3 }, \

 { "full_text" : "", "color" : "\#EEE8D5", "separator" : false, "separator_block_width" : 3 } \
],


I only gives me this error message:

Quote:
conky: Syntax error (.config/i3/conky/2.rc:1: '=' expected near 'no') while reading config file.


I use the USE-flags iconv, ncurses and pulseaudio.

What could be wrong? I know it's an old syntax, but since it works in Arch, it should be working just fine here as well. :(
_________________
$_Linuxkompis.se


Last edited by Hund on Wed Nov 07, 2018 5:29 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22337
Location: here

PostPosted: Tue Nov 06, 2018 7:40 pm    Post subject: Reply with quote

You tried to convert your conkyrc in new format?
Make a backup of your conkyrc
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Hund
n00b
n00b


Joined: 18 Jul 2016
Posts: 56
Location: Sweden

PostPosted: Tue Nov 06, 2018 7:49 pm    Post subject: Reply with quote

fedeliallalinea wrote:
You tried to convert your conkyrc in new format?
Make a backup of your conkyrc


I tried that, but it didn't help.
_________________
$_Linuxkompis.se
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4272
Location: Dallas area

PostPosted: Tue Nov 06, 2018 7:53 pm    Post subject: Reply with quote

Try "out_to_x = no"
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Hund
n00b
n00b


Joined: 18 Jul 2016
Posts: 56
Location: Sweden

PostPosted: Tue Nov 06, 2018 8:00 pm    Post subject: Reply with quote

Anon-E-moose wrote:
Try "out_to_x = no"


That's the first line in my config. :)
_________________
$_Linuxkompis.se
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22337
Location: here

PostPosted: Tue Nov 06, 2018 8:01 pm    Post subject: Reply with quote

This not work?
Code:
conky.config = {
   out_to_x = false,
   own_window = false,
   out_to_console = true,
   background = false,
   max_text_width = 0,
   update_interval = 2.0,
   total_run_times = 0,
   short_units = true,
   use_spacer = 'left',
   override_utf8_locale = false,
   cpu_avg_samples = 2,

};

conky.text = [[
[
# Volume
{ "full_text" : "${eval  }", "color" : "\#1ABC9C", "separator" : false, "separator_block_width" : 3 },
{ "full_text" : "${execi 5 sh "$HOME/Scripts/volume_print.sh"}", "color" : "\#CCCCCC", "separator" : false, "separator_block_width" : 3 },
{ "full_text" : "${eval |}", "color" : "\#333333", "separator" : false, "separator_block_width" : 3 },

# Clock
{ "full_text" : "${eval  }", "color" : "\#CCCCCC", "separator" : false, "separator_block_width" : 3 },
{ "full_text" : "${time %a %d %b, %H:%M}", "color" : "\#CCCCCC", "separator" : false, "separator_block_width" : 3 },

{ "full_text" : "", "color" : "\#EEE8D5", "separator" : false, "separator_block_width" : 3 }
]
]]


_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Hund
n00b
n00b


Joined: 18 Jul 2016
Posts: 56
Location: Sweden

PostPosted: Tue Nov 06, 2018 8:07 pm    Post subject: Reply with quote

fedeliallalinea wrote:
This not work?
Code:
conky.config = {
   out_to_x = false,
   own_window = false,
   out_to_console = true,
   background = false,
   max_text_width = 0,
   update_interval = 2.0,
   total_run_times = 0,
   short_units = true,
   use_spacer = 'left',
   override_utf8_locale = false,
   cpu_avg_samples = 2,

};

conky.text = [[
[
# Volume
{ "full_text" : "${eval  }", "color" : "\#1ABC9C", "separator" : false, "separator_block_width" : 3 },
{ "full_text" : "${execi 5 sh "$HOME/Scripts/volume_print.sh"}", "color" : "\#CCCCCC", "separator" : false, "separator_block_width" : 3 },
{ "full_text" : "${eval |}", "color" : "\#333333", "separator" : false, "separator_block_width" : 3 },

# Clock
{ "full_text" : "${eval  }", "color" : "\#CCCCCC", "separator" : false, "separator_block_width" : 3 },
{ "full_text" : "${time %a %d %b, %H:%M}", "color" : "\#CCCCCC", "separator" : false, "separator_block_width" : 3 },

{ "full_text" : "", "color" : "\#EEE8D5", "separator" : false, "separator_block_width" : 3 }
]
]]



Nope. :(
_________________
$_Linuxkompis.se
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4272
Location: Dallas area

PostPosted: Tue Nov 06, 2018 8:53 pm    Post subject: Reply with quote

post your whole .conkyrc file
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14188

PostPosted: Wed Nov 07, 2018 2:47 am    Post subject: Re: Conky doesn't like my config in Gentoo, only in Arch? Reply with quote

Hund wrote:
What could be wrong? I know it's an old syntax, but since it works in Arch, it should be working just fine here as well. :(
Are you sure the Arch package was built from exactly the same source code and with exactly the same build options? It is not sufficient to check that they have the same base release version. If Arch started from the same base as Gentoo, but applied different patches or used different build options, you might get different results. For example, maybe the Arch maintainer added a patch to retain compatibility with the older file format, and Gentoo did not. Perhaps upstream has a configure option that chooses at build time whether to enable that compatibility, and the Gentoo and Arch builds picked opposing values for that option.
Back to top
View user's profile Send private message
Hund
n00b
n00b


Joined: 18 Jul 2016
Posts: 56
Location: Sweden

PostPosted: Wed Nov 07, 2018 4:58 am    Post subject: Re: Conky doesn't like my config in Gentoo, only in Arch? Reply with quote

Anon-E-moose wrote:
post your whole .conkyrc file


That's what I did in the in the first post.

Hu wrote:
Hund wrote:
What could be wrong? I know it's an old syntax, but since it works in Arch, it should be working just fine here as well. :(
Are you sure the Arch package was built from exactly the same source code and with exactly the same build options? It is not sufficient to check that they have the same base release version. If Arch started from the same base as Gentoo, but applied different patches or used different build options, you might get different results. For example, maybe the Arch maintainer added a patch to retain compatibility with the older file format, and Gentoo did not. Perhaps upstream has a configure option that chooses at build time whether to enable that compatibility, and the Gentoo and Arch builds picked opposing values for that option.


I did check their pkgbuild and I couldn't see anything, But I just checked `conky -v` and I noticed that they have a feature called `old configuration syntax`. I haven't figured out how to enable that yet, but I have something to go on now at least.

Edit: And yes, it's built from the same source. Here's the pkgbuild:

https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/conky
_________________
$_Linuxkompis.se
Back to top
View user's profile Send private message
Hund
n00b
n00b


Joined: 18 Jul 2016
Posts: 56
Location: Sweden

PostPosted: Wed Nov 07, 2018 5:28 am    Post subject: Reply with quote

I must have been tired yesterday, I checked the ebuild again and I now found this:

Code:
-DBUILD_OLD_CONFIG=OFF


Enabling it solves the problem. I wonder why the Gentoo packager specifically disabled that feature?
_________________
$_Linuxkompis.se
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22337
Location: here

PostPosted: Wed Nov 07, 2018 6:42 am    Post subject: Reply with quote

Hund wrote:
Enabling it solves the problem. I wonder why the Gentoo packager specifically disabled that feature?

You can open a new bug, but I think that this option sooner or later will be removed from conky.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Hund
n00b
n00b


Joined: 18 Jul 2016
Posts: 56
Location: Sweden

PostPosted: Wed Nov 07, 2018 6:53 am    Post subject: Reply with quote

fedeliallalinea wrote:
Hund wrote:
Enabling it solves the problem. I wonder why the Gentoo packager specifically disabled that feature?

You can open a new bug, but I think that this option sooner or later will be removed from conky.


I was going to do that. :) And that's what I'm afraid of, I'll cross my fingers that they don't remove it though.
_________________
$_Linuxkompis.se
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum