Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plasma and Xfce4 Issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
InvisibleRasta
Tux's lil' helper
Tux's lil' helper


Joined: 30 Mar 2011
Posts: 112

PostPosted: Mon Nov 05, 2018 1:37 am    Post subject: Plasma and Xfce4 Issues Reply with quote

hello guys i have xfce installed and i cant emerge plasma without a bunch of problems... i ahve the prrofile to plasma and systemd enabled. this is what happens when i run
emerge --ask --changed-use --deep @world
Code:
* IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-libs/libusb-1.0.21  ABI_X86="32*"
[ebuild   R    ] virtual/libusb-1-r2  ABI_X86="32*"
[ebuild   R    ] dev-libs/glib-2.52.3  ABI_X86="32*"
[ebuild   R    ] dev-util/pkgconfig-0.29.2  ABI_X86="32*"
[ebuild   R    ] virtual/pkgconfig-0-r1  ABI_X86="32*"
[ebuild   R    ] x11-libs/libSM-1.2.3  ABI_X86="32*"
[ebuild   R    ] x11-libs/xcb-util-keysyms-0.4.0-r1  ABI_X86="32*"
[ebuild   R    ] net-libs/gnutls-3.5.19  ABI_X86="32*"
[ebuild   R    ] x11-libs/xcb-util-renderutil-0.3.9-r2  ABI_X86="32*"
[ebuild   R    ] x11-libs/xcb-util-wm-0.4.1-r2  ABI_X86="32*"
[ebuild   R    ] net-libs/libtirpc-1.0.2-r1  ABI_X86="32*"
[ebuild   R    ] media-libs/libvorbis-1.3.6  ABI_X86="32*"
[ebuild   R    ] sys-libs/gpm-1.20.7-r2  ABI_X86="32*"
[ebuild   R    ] media-libs/flac-1.3.2-r1  ABI_X86="32*"
[ebuild   R    ] app-crypt/mit-krb5-1.16-r2  ABI_X86="32*"
[ebuild   R    ] dev-libs/check-0.12.0  ABI_X86="32*"
[ebuild   R    ] media-libs/libexif-0.6.21-r2  ABI_X86="32*"
[ebuild   R    ] sys-libs/tevent-0.9.37  ABI_X86="32*"
[ebuild   R    ] dev-python/subunit-1.2.0-r1  ABI_X86="32*"
[ebuild   R    ] net-libs/libnsl-1.2.0  ABI_X86="32*"
[ebuild   R    ] sys-libs/ldb-1.3.6  ABI_X86="32*"
[ebuild   R   ~] sys-apps/dbus-1.12.10  USE="-user-session*"
[ebuild   R    ] media-libs/fontconfig-2.13.0-r4  ABI_X86="32*"
[ebuild   R    ] net-print/cups-2.2.7  ABI_X86="32*"
[ebuild  N     ] net-wireless/bluez-5.50  USE="alsa btpclient cups mesh obex readline systemd udev -debug -deprecated -doc -experimental -extra-tools (-selinux) -test -test-programs -user-session" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7"
[ebuild   R    ] net-fs/samba-4.8.6  USE="winbind*" ABI_X86="32*"
[ebuild   R    ] x11-libs/xcb-util-0.4.0-r1  ABI_X86="32*"
[ebuild   R    ] x11-libs/xcb-util-image-0.4.0-r1  ABI_X86="32*"
[ebuild   R    ] x11-libs/xcb-util-cursor-0.1.3-r2  ABI_X86="32*"
[ebuild   R    ] app-crypt/pinentry-1.1.0-r2  USE="qt5*"
[ebuild  N    *] media-libs/phonon-vlc-9999  USE="-debug"
[ebuild  N     ] sys-auth/consolekit-1.2.1  USE="acl pam policykit udev -cgroups -debug -doc -evdev -pm-utils (-selinux) -test"
[ebuild   R    ] sys-auth/pambase-20150213-r2  USE="consolekit*"
[ebuild   R    ] x11-misc/sddm-0.18.0  USE="consolekit*"
[ebuild   R    ] app-crypt/gpgme-1.11.1  USE="qt5*"
[ebuild   R    ] x11-misc/lightdm-1.26.0-r1  USE="qt5*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/dbus:0

  (sys-apps/dbus-1.12.10:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/dbus-1.6:=[user-session=] required by (net-wireless/bluez-5.50:0/3::gentoo, ebuild scheduled for merge)
                          ^^^^^^^^^^^^^                                                                                                                   

  (sys-apps/dbus-1.12.10:0/0::gentoo, installed) pulled in by
    sys-apps/dbus[user-session] required by (kde-plasma/plasma-workspace-5.14.2:5/5::gentoo, installed)
                  ^^^^^^^^^^^^                                                                                                             


It might be possible to solve this slot collision
by applying all of the following changes:
   - sys-apps/dbus-1.12.10 (Change USE: +user-session)
   - net-wireless/bluez-5.50 (Change USE: +user-session)



/etc/portage/make.conf
Code:
https://paste.pound-python.org/show/6heKNdStdsFGRmeRK7Kj/

/etc/portage/package.use/package.use
Code:
https://paste.pound-python.org/show/IZLwUDAotPsGFLoP8C0H/

/etc/portage/package.use/zz-autounmask
Code:
https://paste.pound-python.org/show/L5b6pNxMjeA2t9LWFlu2/


i am also trying to emerge wine-staging and i get this error aswell
Code:
emerge wine-staging

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!
[ebuild   R    ] dev-libs/libusb-1.0.21  ABI_X86="32*"
[ebuild   R    ] virtual/libusb-1-r2  ABI_X86="32*"
[ebuild  N     ] virtual/opencl-0-r5  ABI_X86="32 (64) (-x32)" VIDEO_CARDS="amdgpu -i965 -nvidia"
[ebuild   R    ] dev-libs/glib-2.52.3  ABI_X86="32*"
[ebuild   R    ] dev-util/pkgconfig-0.29.2  ABI_X86="32*"
[ebuild   R    ] virtual/pkgconfig-0-r1  ABI_X86="32*"
[ebuild   R    ] x11-libs/libSM-1.2.3  ABI_X86="32*"
[ebuild   R    ] x11-libs/xcb-util-keysyms-0.4.0-r1  ABI_X86="32*"
[ebuild   R    ] net-libs/gnutls-3.5.19  ABI_X86="32*"
[ebuild   R    ] x11-libs/xcb-util-wm-0.4.1-r2  ABI_X86="32*"
[ebuild   R    ] x11-libs/xcb-util-renderutil-0.3.9-r2  ABI_X86="32*"
[ebuild   R    ] net-libs/libtirpc-1.0.2-r1  ABI_X86="32*"
[ebuild   R    ] media-libs/flac-1.3.2-r1  ABI_X86="32*"
[ebuild   R    ] media-libs/libvorbis-1.3.6  ABI_X86="32*"
[ebuild   R    ] app-crypt/mit-krb5-1.16-r2  ABI_X86="32*"
[ebuild  N     ] x11-libs/libXinerama-1.1.4  USE="-static-libs" ABI_X86="32 (64) (-x32)"
[ebuild   R    ] dev-libs/check-0.12.0  ABI_X86="32*"
[ebuild  N     ] media-libs/gd-2.2.5-r1  USE="jpeg png tiff truetype zlib -fontconfig -static-libs -webp -xpm" ABI_X86="32 (64) (-x32)"
[ebuild   R    ] media-libs/libexif-0.6.21-r2  ABI_X86="32*"
[ebuild   R    ] sys-libs/tevent-0.9.37  ABI_X86="32*"
[ebuild  N     ] media-libs/libgphoto2-2.5.16  USE="exif jpeg nls -doc -examples -gd -serial" ABI_X86="32 (64) (-x32)" CAMERAS="adc65 agfa_cl20 aox ax203 barbie canon casio_qv clicksmart310 digigr8 digita dimagev dimera3500 directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 jl2005a jl2005c kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica konica_qm150 largan lg_gsm mars mustek panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 pccam300 pccam600 pentax polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ptp2 ricoh ricoh_g3 samsung sierra sipix_blink2 sipix_web2 smal sonix sony_dscf1 sony_dscf55 soundvision spca50x sq905 st2205 stv0674 stv0680 sx330z topfield toshiba_pdrm11 tp6801"
[ebuild   R    ] media-libs/libsndfile-1.0.28-r4  ABI_X86="32*"
[ebuild   R    ] dev-python/subunit-1.2.0-r1  ABI_X86="32*"
[ebuild   R    ] net-libs/libnsl-1.2.0  ABI_X86="32*"
[ebuild  N     ] virtual/krb5-0-r1  ABI_X86="32 (64) (-x32)"
[ebuild   R   ~] sys-apps/dbus-1.12.10  USE="-user-session*"
[ebuild   R    ] sys-libs/ldb-1.3.6  ABI_X86="32*"
[ebuild  N     ] net-libs/libpcap-1.8.1  USE="dbus usb -bluetooth -netlink -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild   R    ] media-libs/fontconfig-2.13.0-r4  ABI_X86="32*"
[ebuild   R    ] net-print/cups-2.2.7  ABI_X86="32*"
[ebuild  N     ] net-wireless/bluez-5.50  USE="alsa btpclient cups mesh obex readline systemd udev -debug -deprecated -doc -experimental -extra-tools (-selinux) -test -test-programs -user-session" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7"
[ebuild   R    ] net-fs/samba-4.8.6  USE="winbind*" ABI_X86="32*"
[ebuild  N     ] sys-auth/rtkit-0.11-r2
[ebuild   R    ] x11-libs/xcb-util-0.4.0-r1  ABI_X86="32*"
[ebuild   R    ] x11-libs/xcb-util-image-0.4.0-r1  ABI_X86="32*"
[ebuild   R    ] x11-libs/xcb-util-cursor-0.1.3-r2  ABI_X86="32*"
[ebuild  N    ~] app-emulation/vkd3d-1.0  USE="-spirv-tools" ABI_X86="32 (64) (-x32)"
[ebuild  N     ] x11-libs/libva-1.7.3  USE="X drm opengl -egl -vdpau -wayland" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="dummy intel nouveau -i965 -nvidia"
[ebuild  N     ] x11-libs/libva-intel-driver-1.7.3  USE="X drm -wayland" ABI_X86="32 (64) (-x32)"
[ebuild  N     ] x11-libs/libva-vdpau-driver-0.7.4-r4  USE="opengl -debug" ABI_X86="32 (64) (-x32)"
[ebuild  N     ] media-sound/pulseaudio-11.1-r1  USE="X alsa alsa-plugin asyncns bluetooth caps dbus gdbm glib gtk ipv6 orc qt5 ssl systemd tcpd udev webrtc-aec -doc -equalizer -gnome -jack -libressl -libsamplerate -lirc -native-headset (-neon) -ofono-headset (-oss) -realtime (-selinux) -sox (-system-wide) -test -zeroconf" ABI_X86="32 (64) (-x32)"
[ebuild  N     ] media-plugins/alsa-plugins-1.1.6  USE="mix pulseaudio usb_stream -arcam_av -debug -ffmpeg -jack -libav -libsamplerate -oss -speex" ABI_X86="32 (64) (-x32)"
[ebuild  N    ~] app-emulation/wine-staging-3.18  USE="X alsa capi cups fontconfig gecko gphoto2 gsm gssapi jpeg kerberos lcms ldap mono mp3 ncurses netapi nls odbc opencl opengl osmesa pcap perl pipelight png pulseaudio realtime run-exes samba sdl ssl (staging) threads truetype udev udisks vaapi vkd3d vulkan xcomposite xinerama xml -custom-cflags -dos (-ffmpeg) -gstreamer -openal -oss -prelink -scanner (-selinux) -test -themes -v4l" ABI_X86="32 64 (-x32)"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/dbus:0

  (sys-apps/dbus-1.12.10:0/0::gentoo, installed) pulled in by
    sys-apps/dbus[user-session] required by (kde-plasma/plasma-workspace-5.14.2:5/5::gentoo, installed)
                  ^^^^^^^^^^^^                                                                                                             

  (sys-apps/dbus-1.12.10:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/dbus-1.6:=[user-session=] required by (net-wireless/bluez-5.50:0/3::gentoo, ebuild scheduled for merge)
                          ^^^^^^^^^^^^^                                                                                                                   


It might be possible to solve this slot collision
by applying all of the following changes:
   - sys-apps/dbus-1.12.10 (Change USE: +user-session)
   - net-wireless/bluez-5.50 (Change USE: +user-session)
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21362
Location: here

PostPosted: Mon Nov 05, 2018 6:48 am    Post subject: Reply with quote

You should also activate user-session use flag to net-wireless/bluez package (and remove >=sys-apps/dbus-1.12.10 -user-session entry in /etc/portage/package.use/zz-autounmask)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
InvisibleRasta
Tux's lil' helper
Tux's lil' helper


Joined: 30 Mar 2011
Posts: 112

PostPosted: Mon Nov 05, 2018 6:53 am    Post subject: Reply with quote

media-libs/phonon-vlc-0.10.1 is failing to build
Code:
http://termbin.com/ghvr
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21362
Location: here

PostPosted: Mon Nov 05, 2018 7:06 am    Post subject: Reply with quote

What version of vlc you installed?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
InvisibleRasta
Tux's lil' helper
Tux's lil' helper


Joined: 30 Mar 2011
Posts: 112

PostPosted: Mon Nov 05, 2018 7:25 am    Post subject: Reply with quote

i rebuilt vlc, unmerged consolekit and then everything went fine for plasma.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum