Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Anyone know the reason why stable is still kernel 4.14?
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Gentoo Chat
View previous topic :: View next topic  
Author Message
zigford
n00b
n00b


Joined: 16 Feb 2005
Posts: 14

PostPosted: Tue Nov 27, 2018 10:00 pm    Post subject: Reply with quote

I wonder if there should be another portage flag for longterm?
_________________
----------------------------------------
Say hi to your mum for me
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Tue Nov 27, 2018 10:03 pm    Post subject: Reply with quote

...what should that flag do?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5586
Location: Removed by Neddy

PostPosted: Tue Nov 27, 2018 10:05 pm    Post subject: Reply with quote

Wouldn't that just be adding ~arch to package.keywords
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
zigford
n00b
n00b


Joined: 16 Feb 2005
Posts: 14

PostPosted: Tue Nov 27, 2018 10:20 pm    Post subject: Reply with quote

We have ~arch for unstable, arch for stable, another flag like !arch for longterm would set you on packages that have a longterm release option like the longterm supported kernel.
_________________
----------------------------------------
Say hi to your mum for me
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Tue Nov 27, 2018 10:27 pm    Post subject: Reply with quote

Gentoo arch and ~arch do not reflect the upstream status at all, they are purely representations of Gentoo support. That just so happens to align with an LTS kernel in this case. Some people whom I disagree with already think that arch is superfluous, but it does add considerable effort to package maintenance. A duplicate 'stable' category is not viable.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Tue Nov 27, 2018 10:30 pm    Post subject: Reply with quote

The "other flag" exists: p.mask versions newer than the LTS you want to stay on.

To unpack the XY problem here, if you're expecting a rolling release distro to automatically steer you between old kernels with years of differences between them, you're already screwed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Chat All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum