Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Invalid MIT-MAGIC-COOKIE-1 key
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo Chat
View previous topic :: View next topic  
Author Message
sao98021
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2012
Posts: 144
Location: Michigan

PostPosted: Mon Nov 12, 2018 1:29 pm    Post subject: [SOLVED]Invalid MIT-MAGIC-COOKIE-1 key Reply with quote

for about a month or two, once in a while... about once or twice a week almost random, this laptop will get that error when starting programs(any programs) (with or without optirun/bumblebee)

Code:
Invalid MIT-MAGIC-COOKIE-1 key
(gedit:14188): Gtk-WARNING **: cannot open display: :0


i usually just reboot, cause indeed it only happens midway into the week, and i should reboot the pc anyway. I've had gentoo installed for years, but this only started happening relatively recently, i see that it could be a number of things, but i wanted to check here to see if this happening now specifically for other people as well.

come to think of it, i think it actually first had happened immediately after switching to comcast ISP over att, dunno if thats related or not.

lol, is someone haxing me via pen+steal/alter/createnew/takepwnership of my display cookie

interestingly, my cookie upon boot with everything working, just looks like a default xauthority with my name, but after the situation arises, it will be alterd with defunct symbols and itll have the word COMCAST added into it along with a bunch of symbols..

well, after digging around a bit on the forums i've narrowed it down and now have a pretty good idea of whats happening, so even though i haven't done anything yet i'll mark topic as solved, thanks.

if anyone is wondering, or facing something similar.. its probably due to nm-applet reassigning hostname after suspend/reconnecting to a network which then causes confliction, if you don't have or use nm-applet, then it could be NetworkManager doing something similar.
Back to top
View user's profile Send private message
tholin
Apprentice
Apprentice


Joined: 04 Oct 2008
Posts: 179

PostPosted: Mon Nov 12, 2018 2:23 pm    Post subject: Reply with quote

I had the same problem a while ago. It took me quite a while to figure out what was wrong. For me the problem was caused by dhcpcd changing my hostname to "localhost". It uses localhost as fallback in case the dhcp server doesn't set any hostname. I worked around the problem by setting "nohook hostname" in /etc/dhcpcd.conf.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 6044

PostPosted: Mon Nov 12, 2018 5:23 pm    Post subject: Reply with quote

A better workaround would be to get the hostname from `xauth list` and add it as a loopback address in /etc/hosts, so it's always valid.
Back to top
View user's profile Send private message
mortonP
n00b
n00b


Joined: 22 Dec 2015
Posts: 16

PostPosted: Mon Nov 12, 2018 8:13 pm    Post subject: Reply with quote

I have dhcpcd and I have this problem since a few days when I setup a new system - but did not copy the dhcpcd.conf over....

Thanx you for posting this!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Chat All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum