Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
thikpad external display via dock
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
efreet
n00b
n00b


Joined: 30 Oct 2018
Posts: 2

PostPosted: Tue Oct 30, 2018 6:58 pm    Post subject: thikpad external display via dock Reply with quote

Hi all, i have an old problem. I am user of thinkpad t430 laptop with intel and 5400 quadro nvidia graphics adapters. Also i have a dock station. Main problem is disabled monitor pluged in DVI port of dockstation. I have read many info about same problems. A main reason people says is outputing DVI signal only via nvidia chip. I dont want to swith off Optimus option in BIOS. Just for test i have tried a Ubuntu last live iso and buntu detected external DVI display. xrandr providers was nomodeset and nouveau. Now i compiled a XFCE DE (without dm) and my xrandr show me Intel and nouveau providers, but i didnot see any external dvi port in output. I cant realize the "magic" of buntu (or mint) in this case. I am using a genkernel-all kernel. Also i tried to use a nvidia driver, but it was failed, i think it's all about version of module, portage has newest version of drivers and it useless for this chip, i think it needs version about 390.x.x . I started rebuilding @world and can't copy some outputs from my laptop.
Do somebody has ideas to solve this problem? I am ready to give up... i just need to output video signal to external monitor and don't need correct work of other dock's actions.
PS: also, i had same problem on this device year ago. I was a Archlinux user and after several days i found some solution. If be honest, dont remember details, but it was all about xrandr tricks and maybe playing with some small configs in xorg.d dir.
Back to top
View user's profile Send private message
efreet
n00b
n00b


Joined: 30 Oct 2018
Posts: 2

PostPosted: Wed Oct 31, 2018 12:16 pm    Post subject: Reply with quote

ok. i have detected dock monitor using command
Code:
xrandr --setprovideroutputsource nouveau Intel

Mate can work with monitor, but still there is no normal image on monitor, just stripes.
xrandr -q
Code:
Screen 0: minimum 8 x 8, current 3286 x 1080, maximum 32767 x 32767
LVDS1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 310mm x 170mm
   1366x768      59.98*+
   1280x720      59.74 
   1024x768      60.00 
   1024x576      60.00    59.90    59.82 
   960x540       60.00    59.63    59.82 
   800x600       60.32    56.25 
   864x486       60.00    59.92    59.57 
   640x480       59.94 
   720x405       59.51    60.00    58.99 
   680x384       60.00 
   640x360       59.84    59.32    60.00 
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
LVDS-1-2 disconnected (normal left inverted right x axis y axis)
VGA-1-2 disconnected (normal left inverted right x axis y axis)
DP-1-1 disconnected (normal left inverted right x axis y axis)
DP-1-2 disconnected (normal left inverted right x axis y axis)
DP-1-3 connected 1920x1080+1366+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080     60.00*+
   1680x1050     59.88 
   1280x1024     75.02    60.02 
   1440x900      74.98    59.90 
   1280x720      60.00 
   1024x768      75.03    60.00 
   800x600       75.00    60.32 
   640x480       75.00    72.81    66.67    59.94 
   720x400       70.08 
  1024x768 (0x6f) 65.000MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock  48.36KHz
        v: height  768 start  771 end  777 total  806           clock  60.00Hz
  800x600 (0x71) 40.000MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock  37.88KHz
        v: height  600 start  601 end  605 total  628           clock  60.32Hz
  640x480 (0x75) 25.175MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.47KHz
        v: height  480 start  490 end  492 total  525           clock  59.94Hz



Code:
 ~ $ xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x9d cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 3 associated providers: 1 name:Intel
Provider 1: id: 0x66 cap: 0x7, Source Output, Sink Output, Source Offload crtcs: 2 outputs: 5 associated providers: 1 name:nouveau


Code:

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [NVS 5400M] (rev a1)



Code:
uname -a
Linux inferno 4.14.65-gentoo #1 SMP Mon Oct 29 12:21:31 MSK 2018 x86_64 Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz GenuineIntel GNU/Linux


Foto of monitor after redetecting monitor in Mate DE:
http://i68.tinypic.com/2py15ci.jpg
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum