Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ksshaskpass not working anymore
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
equaeghe
Guru
Guru


Joined: 22 Feb 2005
Posts: 466

PostPosted: Fri Oct 26, 2018 10:24 am    Post subject: ksshaskpass not working anymore Reply with quote

Since the update to Plasma 5.13.5, it appears that ksshaskpass is not working for me anymore. Namely, when I want to git push to remote repositories requiring ssh authentication, I am prompted to enter the ssh passphrase on the command line. Before, the passphrase was read from kdewallet.

I looked at my setup and everything seems fine:
Code:
$ eix ksshaskpass
[I] kde-plasma/ksshaskpass
     Available versions:  (5) ~5.12.7 5.13.5 ~5.14.2
       {debug}
     Installed versions:  5.13.5(5)(05:54:38 18-10-18)(-debug)
     Homepage:            https://cgit.kde.org/ksshaskpass.git
     Description:         KDE implementation of ssh-askpass with Kwallet integration

Code:
$ echo $SSH_ASKPASS
ksshaskpass

Code:
$ ps a -N | grep ssh-agent
 8559 ?        Ss     0:00 /usr/bin/ssh-agent -s

Code:
$ ls -l ~/.config/autostart-scripts/
totaal 4
-rwxr-xr-x 1 equaeghe equaeghe 29 26 okt 11:46 ssh-add.sh

Code:
$ cat ~/.config/autostart-scripts/ssh-add.sh
#!/bin/sh
ssh-add </dev/null

[edit] In the logs:
Code:
ksmserver[8617]: org.kde.kf5.ksmserver: Starting autostart script  "/home/equaeghe/.config/autostart-scripts/ssh-add.sh"

[/edit]

Any idea about what could be broken?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum