Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto]The ebuild selected to satisfy
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Thu Nov 01, 2018 1:03 pm    Post subject: [Risolto]The ebuild selected to satisfy Reply with quote

buongiorno è da qualche giorno che ricevo questo messaggio

Code:
!!! The ebuild selected to satisfy "media-libs/libsdl2[sound,video,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]" has unmet requirements.
- media-libs/libsdl2-2.0.8-r2::gentoo USE="X alsa dbus joystick opengl pulseaudio sound threads udev video wayland (-altivec) (-aqua) (-custom-cflags) -gles -haptic -kms -libsamplerate -nas -oss -static-libs -tslib -xinerama -xscreensaver" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx sse sse2 -3dnow" VIDEO_CARDS="(-vc4)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    wayland? ( gles )

  The above constraints are a subset of the following complete expression:
    alsa? ( sound ) gles? ( video ) nas? ( sound ) opengl? ( video ) pulseaudio? ( sound ) wayland? ( gles ) xinerama? ( X ) xscreensaver? ( X )

(dependency required by "media-video/ffmpeg-3.3.6::gentoo" [installed])
(dependency required by "www-client/firefox-bin-63.0::gentoo[ffmpeg]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


a cosa si riferisce ?


Last edited by trigg on Thu Nov 01, 2018 4:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 684

PostPosted: Thu Nov 01, 2018 1:34 pm    Post subject: Reply with quote

media-libs/libsdl2

con USE "wayland" abilitata

richiede anche "gles" la quale è disabilitata er il pacchetto in questione.

PS : utilizzi il server grafico wayland ?

se non ti interessa wayland puoi considerare di disabilitarlo globalmente

inoltre portage ti informa che :
Code:
The above constraints are a subset of the following complete expression:
    alsa? ( sound ) gles? ( video ) nas? ( sound ) opengl? ( video ) pulseaudio? ( sound ) wayland? ( gles ) xinerama? ( X ) xscreensaver? ( X )


Se abiliti le USE (sempre per il pacchetto in questione)

alsa , devi abilitare anche "sound"
gles , devi abilitare "video"
nas , devi abilitare "sound"
opengl , devi abilitare "video"
pulseaudio , devi abilitare "sound"
wayland --> gles
xinerama --> X
screensaver --> X
_________________
BOINC ed il calcolo distribuito

My LiveRecoverySystem Repo
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21538
Location: here

PostPosted: Thu Nov 01, 2018 2:54 pm    Post subject: Reply with quote

Puoi abilitare le use flag mancanti al singolo pacchetto con package.use
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Thu Nov 01, 2018 4:29 pm    Post subject: Reply with quote

si ho risolto abilitando gles e disabilitando wayland in media-libs/libsdl2

tutto si era scombinato quando ho provato ad installare anbox *

questo è la parte finale di zz-autonmask di /package.use interessata
Code:
# required by app-emulation/anbox-9999.2018.07.19-r1::unity-gentoo
# required by app-emulation/anbox (argument)
=app-emulation/lxc-2.1.1-r1 cgmanager
# required by app-emulation/anbox-9999.2018.07.19-r1::unity-gentoo
# required by app-emulation/anbox (argument)
>=media-libs/libsdl2-2.0.8-r2 wayland
# required by media-libs/libsdl2-2.0.8-r2::gentoo[gles]
# required by media-video/ffmpeg-3.3.6::gentoo[sdl]
# required by virtual/ffmpeg-9-r2::gentoo[-libav]
# required by media-sound/mps-youtube-0.2.8::localrepo
# required by @selected
# required by @world (argument)
>=media-libs/mesa-18.1.9 gles2 wayland


penso di aver risolto reimpostando le flag così come suggerito da sabayonino

* magari apro un post su anbox oerchè pur installandolo non viene lanciato e
quando ho provato a disinstallarlo mi ha detto che non esiste .
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum