Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] can not login with slim or lightdm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
klas
Tux's lil' helper
Tux's lil' helper


Joined: 30 Aug 2017
Posts: 98
Location: Bradford, UK

PostPosted: Wed Oct 10, 2018 10:21 pm    Post subject: [SOLVED] can not login with slim or lightdm Reply with quote

I get a dark blank screen when I log with slim.
my /var/log/slim.log complain
Quote:

slim: waiting for X server to begin accepting connections.
slim: get_x11_device: cannot open display



Code:

lspci -k

gives https://paste.pound-python.org/show/u8KGPeXyZCWaEJ1J98hR/

Code:
/var/log/Xorg.0.log
gives https://paste.pound-python.org/show/QrKA2BwGLC1TsyvChNDi/

Code:
 emerge --info
gives https://paste.pound-python.org/show/RdOQv4PDvge66ovSAISm/


Code:
/usr/src/linux/.config
gives https://paste.pound-python.org/show/aEEPj408SUUqCz2uPAO7/


Any advice please?
kind regards


Last edited by klas on Sat Oct 20, 2018 10:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
klas
Tux's lil' helper
Tux's lil' helper


Joined: 30 Aug 2017
Posts: 98
Location: Bradford, UK

PostPosted: Thu Oct 11, 2018 10:24 am    Post subject: Reply with quote

I just install sddm and remove slim and works . It s a bit weird
Back to top
View user's profile Send private message
n05ph3r42
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jul 2016
Posts: 98

PostPosted: Fri Oct 12, 2018 6:22 pm    Post subject: Reply with quote

i experienced same issue about 2 month ago. xdm crashes for unknown reason with slim.
I switched to sddm, then sddm stopped working too, after a month. I switched back to slim and... its working now. have no idea what was that.
Back to top
View user's profile Send private message
spidark
Tux's lil' helper
Tux's lil' helper


Joined: 01 Sep 2011
Posts: 142

PostPosted: Fri Oct 12, 2018 7:23 pm    Post subject: Re: can not login with slim or lightdm Reply with quote

klas wrote:
I get a dark blank screen when I log with slim.


Hi klas.
It may or may not help you.
I have both slim and lightdm working over here.
/etc/slim.conf
Code:

login_cmd           exec /bin/sh - ~/.xinitrc %session

.xinitrc
Code:

#ck-launch-session dbus-launch --sh-syntax --exit-with-session xfce4-session
exec ck-launch-session dbus-launch --sh-syntax --exit-with-session openbox-session


Code:

equery u x11-misc/slim
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for x11-misc/slim-1.3.6-r5:
 U I
 + + branding   : Enable Gentoo specific branding
 + + consolekit : Enable native consolekit support
 + + pam        : Add support for PAM (Pluggable Authentication Modules) -
                  DANGEROUS to arbitrarily flip




dbus and Consolekit
Code:
rc-status
Runlevel: default
 dbus                                                              [  started  ]
 metalog                                                           [  started  ]
 consolekit                                                        [  started  ]
 auditd                                                            [  started  ]
 nftables                                                          [  started  ]
 psd                                                               [  started  ]
 cronie                                                            [  started  ]
 wpa_supplicant                                                    [  started  ]
 netmount                                                          [  started  ]
 xdm                                                               [  started  ]
 local                                                             [  started  ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed/wanted
 dhcpcd                                                            [  started  ]
 xdm-setup                                                         [  started  ]
Dynamic Runlevel: manual


lightdm /etc/lightdm/lightdm.conf
Code:

[Seat:*]
#type=local
pam-service=lightdm
#pam-autologin-service=lightdm-autologin
pam-greeter-service=lightdm-greeter
session-wrapper=/etc/lightdm/Xsession


Code:

equery u lightdm     
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for x11-misc/lightdm-1.26.0-r1:
 U I
 + + audit         : Enable support for Linux audit subsystem using
                     sys-process/audit
 - - gnome         : Add GNOME support
 + + gtk           : Pull in the gtk+ greeter
 + + introspection : Add support for GObject based introspection
 + + qt5           : Add support for the Qt 5 application and UI framework
 - - vala          : Enable bindings for dev-lang/vala



Code:

equery u xorg-server
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for x11-base/xorg-server-1.19.5-r2:
 U I
 - - debug       : Enable extra debug codepaths, like asserts and extra output.
                   If you want to get meaningful backtraces see https://wiki.ge
                   ntoo.org/wiki/Project:Quality_Assurance/Backtraces
 - - dmx         : Build the Distributed Multiheaded X server
 - - doc         : Add extra documentation (API, Javadoc, etc). It is
                   recommended to enable per package instead of globally
 + + glamor      : Enable Glamor OpenGL 2D acceleration
 + + ipv6        : Add support for IP version 6
 - - kdrive      : Build the kdrive X servers
 + + libressl    : Use dev-libs/libressl instead of dev-libs/openssl when
                   applicable (see also the ssl useflag)
 - - minimal     : Install a very minimal build (disables, for example,
                   plugins, fonts, most drivers, non-critical features)
 - - static-libs : Build static versions of dynamic libraries as well
 + + suid        : Enable setuid root program, with potential security risks
 - - systemd     : Enable use of systemd-specific libraries and features like
                   socket activation or session tracking
 - - tslib       : Build with tslib support for touchscreen devices
 + + udev        : Enable virtual/udev integration (device discovery, power and
                   storage device support, etc)
 - - unwind      : Enable libunwind usage for backtraces
 - - wayland     : Enable dev-libs/wayland backend
 - - xcsecurity  : Build Security extension
 - - xephyr      : Build the Xephyr server
 - - xnest       : Build the Xnest server
 + + xorg        : Build the Xorg X server (HIGHLY RECOMMENDED)
 - - xvfb        : Build the Xvfb server

Cheers :wink:
_________________
Laptop HP Pavilion G6 2310-SD Intel(R) Core(TM) i7-3632QM CPU @ 2.20GHz
Back to top
View user's profile Send private message
klas
Tux's lil' helper
Tux's lil' helper


Joined: 30 Aug 2017
Posts: 98
Location: Bradford, UK

PostPosted: Thu Oct 18, 2018 8:28 am    Post subject: Reply with quote

Thanks guys. i switched to systemd lvm but still experience the same problem with gnome gdm login. I tried switch to systemd with lvm but still the problem come back
i get this error on /var/log/X.0.log
Quote:

localhost /home/maxx # tail -12 /var/log/Xorg.0.log
[ 64.884] (II) event3 - DELL Dell USB Entry Keyboard: device removed
[ 64.885] input-thread: unregistered device: 22
[ 64.885] (**) Option "fd" "29"
[ 64.885] (II) event4 - Logitech USB Optical Mouse: device removed
[ 64.885] input-thread: InputThreadDoWork waiting for devices
[ 64.885] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 64.915] (II) systemd-logind: got pause for 13:64
[ 64.915] (II) systemd-logind: got pause for 13:67
[ 64.915] (II) systemd-logind: got pause for 13:68
[ 64.915] (II) systemd-logind: got pause for 13:65
[ 64.915] (II) systemd-logind: got pause for 226:0
[ 64.915] (II) systemd-logind: got pause for 13:66


Any one with more ideas .
Thanks
Back to top
View user's profile Send private message
spidark
Tux's lil' helper
Tux's lil' helper


Joined: 01 Sep 2011
Posts: 142

PostPosted: Sat Oct 20, 2018 9:12 am    Post subject: Reply with quote

klas wrote:
Thanks guys. i switched to systemd lvm but still experience the same problem with gnome gdm login. I tried switch to systemd with lvm but still the problem come back
i get this error on /var/log/X.0.log
Quote:

localhost /home/maxx # tail -12 /var/log/Xorg.0.log
[
Code:
64.884] (II) event3  - DELL Dell USB Entry Keyboard: device removed

[ 64.885] input-thread: unregistered device: 22
[ 64.885] (**) Option "fd" "29"
[ 64.885] (II) event4 - Logitech USB Optical Mouse: device removed
[ 64.885] input-thread: InputThreadDoWork waiting for devices
[ 64.885] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 64.915] (II) systemd-logind: got pause for 13:64
[ 64.915] (II) systemd-logind: got pause for 13:67
[ 64.915] (II) systemd-logind: got pause for 13:68
[ 64.915] (II) systemd-logind: got pause for 13:65
[ 64.915] (II) systemd-logind: got pause for 226:0
[ 64.915] (II) systemd-logind: got pause for 13:66


Any one with more ideas .
Thanks

Hi Klas,
Sorry can't help with lvm or systemd, no knowledge about them.
I'm guessing you still have a black screen at login or after login ?
Maybe adding your user to the video group ?
see what helps.

But funny thing noticed.
What or who is removing your keyboard and mouse and why ?
Code:
64.884] (II) event3  - DELL Dell USB Entry Keyboard: device removed

Code:
[    64.885] (II) event4  - Logitech USB Optical Mouse: device removed

_________________
Laptop HP Pavilion G6 2310-SD Intel(R) Core(TM) i7-3632QM CPU @ 2.20GHz
Back to top
View user's profile Send private message
klas
Tux's lil' helper
Tux's lil' helper


Joined: 30 Aug 2017
Posts: 98
Location: Bradford, UK

PostPosted: Sat Oct 20, 2018 9:13 pm    Post subject: [SOLVED] can not login with slim or lightdm Reply with quote

No blank screen , only some delays but I figured out that it s just some flags missing , xorg freezing

And I also created an /etc/portage/package.mask

then added

Code:

=x11-drivers/xf86-video-intel-2.99.917_p20161024
Back to top
View user's profile Send private message
spidark
Tux's lil' helper
Tux's lil' helper


Joined: 01 Sep 2011
Posts: 142

PostPosted: Sat Oct 20, 2018 10:41 pm    Post subject: Re: [SOLVED] can not login with slim or lightdm Reply with quote

klas wrote:
No blank screen , only some delays but I figured out that it s just some flags missing , xorg freezing

And I also created an /etc/portage/package.mask

then added

Code:

=x11-drivers/xf86-video-intel-2.99.917_p20161024

Glad everything worked out.
Cheers.
_________________
Laptop HP Pavilion G6 2310-SD Intel(R) Core(TM) i7-3632QM CPU @ 2.20GHz
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum