Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
remerged nvidia-drivers, now fvwm's fonts are huge [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1170
Location: Stuttgart, Germany

PostPosted: Mon Oct 08, 2018 6:17 pm    Post subject: remerged nvidia-drivers, now fvwm's fonts are huge [SOLVED] Reply with quote

So, I updated my kernel today to 4.18.12. As I always do, I reinstalled nvidia-drivers before rebooting (but the same version, 390.87, as previously, which I am stuck on because newer versions no longer support my GTX580).

So those were the only two packages I emerged, and then I rebooted. Now, the window title-bar and menu fonts in FVWM are all a good 50% larger than they were, eating up a bunch of screen real-estate.

checking /var/log/Xorg.0.log for "dpi" returns the following:

Code:
 # cat /var/log/Xorg.0.log | grep -i dpi
[    60.600] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    60.600]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    60.600] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    60.600]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    62.585] (--) NVIDIA(0): DPI set to (93, 92); computed from "UseEdidDpi" X config
[    62.590] (--) NVIDIA(1): DPI set to (93, 92); computed from "UseEdidDpi" X config


I have a dual monitor setup.

Is this a problem with the dpi settings? Or with FVWM's font configs? What might be causing it? How do I debug?

Thanks for the help,

EE


Last edited by ExecutorElassus on Wed Oct 10, 2018 6:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
duane
n00b
n00b


Joined: 03 Jun 2002
Posts: 29
Location: Oklahoma City

PostPosted: Mon Oct 08, 2018 7:08 pm    Post subject: Reply with quote

Has your "Xft.dpi" changed when you do "xrdb -query"? You might be able to set that in an .Xresources file and import it in .xinitrc. I set mine to 140 since my screen resolution is better than my eyes.
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1170
Location: Stuttgart, Germany

PostPosted: Mon Oct 08, 2018 7:30 pm    Post subject: Reply with quote

'xrdb -query' returns the following:

Code:
Xft.dpi:   96


So there's obviously a mismatch here between what xft is setting and what the edid is reporting back to the nvidia driver. Should I change that somewhere?

Cheers,

EE
Back to top
View user's profile Send private message
duane
n00b
n00b


Joined: 03 Jun 2002
Posts: 29
Location: Oklahoma City

PostPosted: Mon Oct 08, 2018 8:00 pm    Post subject: Reply with quote

Well, what I do is put this in .Xresources:

Xft.dpi: 140

Then put this in .xinitrc:

/usr/bin/xrdb -merge /home/duaner/.Xresources &

Without that, my openbox fonts are way too small for my taste.
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1170
Location: Stuttgart, Germany

PostPosted: Wed Oct 10, 2018 6:09 pm    Post subject: Reply with quote

Update: turns out that my Xft.dpi setting was wrong, and setting it to the correct value helped a bit.

But also, the main font definition in .fvwm/decorations was also garbage. I'm not sure why I just copied over somebody else's xorg regular font definition, but just setting it to the appropriate Xft definition resulted in a much nicer-looking font, and now I can control its size.

So, I'll put [SOLVED] in the subject, now that it's sorted.

Cheers,

EE
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum