Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] pppoe reconnections
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Vieri
Guru
Guru


Joined: 18 Dec 2005
Posts: 498

PostPosted: Mon Oct 08, 2018 1:54 pm    Post subject: [SOLVED] pppoe reconnections Reply with quote

Hi,

I configured pppoe links to my internet provider. This is part of my net config:

Code:
config_ppp3="ppp"
link_ppp3="enp8s5"
plugins_ppp3="pppoe"
pppd_ppp3="
noauth
defaultroute
persist
holdoff 0
maxfail 0
noaccomp noccp nobsdcomp nodeflate nopcomp novj novjccomp
"
username_ppp3="user@provider"
password_ppp3="pwd"
config_enp8s5="192.168.101.2/24"
rc_net_ppp3_need="net.enp8s5"


The link goes up fine and traffic flows despite the UNKNOWN state below.

Code:
# ip addr show ppp3
11: ppp3: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc fq_codel state UNKNOWN group default qlen 3
    link/ppp
    inet x.x.x.x peer 192.168.144.1/32 scope global ppp3
       valid_lft forever preferred_lft forever


The issue is when I reboot my modem. No matter how long I wait the pppoe link does "not work" (ie. traffic does not flow). This link has a dynamic public IP address, and it all starts working again only if I manually run:

Code:
# /etc/init.d/net.ppp3 restart


The ppp link can then receive a new public IP address (or the same one), and everything starts working again.

I thought the ppp options "persist, holdoff 0, maxfail 0" would do the magic for me.

I see no ppp log activity in /var/log/messages after I reboot the modem and before I manually restart the ppp3 service.

What have I misconfigured?

Thanks,

Vieri


Last edited by Vieri on Sat Oct 13, 2018 11:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ralphred
Tux's lil' helper
Tux's lil' helper


Joined: 31 Dec 2013
Posts: 77

PostPosted: Thu Oct 11, 2018 1:56 am    Post subject: Reply with quote

Try it with

Code:
pppd_ppp3="
noauth
defaultroute
persist
holdoff 3
lcp-echo-interval 15
lcp-echo-failure 9
noaccomp noccp nobsdcomp nodeflate nopcomp novj novjccomp
"


If it's still not working add the debug option to see extra info in /var/log/daemon.log (syslog conf withstanding)
Back to top
View user's profile Send private message
Vieri
Guru
Guru


Joined: 18 Dec 2005
Posts: 498

PostPosted: Sat Oct 13, 2018 11:03 pm    Post subject: Reply with quote

Thanks for the feedback.

It seems that the ppp options "lcp-echo-*" do the trick.

Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum