Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GNOME control center Segmentation fault
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
sirzarmo
n00b
n00b


Joined: 22 Sep 2018
Posts: 3

PostPosted: Sat Sep 22, 2018 3:48 pm    Post subject: GNOME control center Segmentation fault Reply with quote

Fresh install, my first time and I'm very proud, so far everything worked flawlessly, had some trouble with Nouveau but I managed to blacklist with relative ease.
I speak Hebrew as well as English on a day by day basis, thus I NEED support for them both, I can view Hebrew Web pages and thus I'm sure it's not a font problem but when trying to add Hebrew via the GNOME control center I get a segfault every time.
Here's my GDB output: Thread 1
Code:
gnome-control-c" received signal SIGSEGV, Segmentation fault.
0x00007ffff1066aca in ?? () from /lib64/libc.so.6

I figured before I file a bug report I'll discuss it some in a forum of others who might be able to help.
it only happens when I press the + in "input sources" under the "Region and Language" tab.
I'd LOVE some help, I can provide any info you think you need.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2207
Location: Germany

PostPosted: Sat Sep 22, 2018 7:26 pm    Post subject: Reply with quote

Hello sirzarmo,

welcome to the Gentoo-Community!
Do you need just the Keyboard layout? That you will get if you add this he Support in the gnome-control-center as you described when your program crash.

Or do you want to have your System with full language Support, an Settings or Programms in hebrew?

Did you follow the Localization Guide?

If you do and follow the next steps you will get a system that Support likely hebrew and your Programms Settings will be in that language.
Take a Look for that and other settings at the Localizatin Guide.

Myself do not know if the follow one is the right for Hebrew. But i suppose it is. Then the Procedure should be like this:

Not sure if he_IL.UTF-8 is the right one for you. Take a look at...

Code:
# ls /usr/share/i18n/locales/


..and you will fine some other possible Language Codes.

1. Add locales to /etc/locale.gen

Run as root:
Code:
 echo "he_IL.UTF-8 UTF8" >>  /etc/locale.gen


2. Run local-gen

Run as root:
Code:
 locale-gen


3. Run as User your local -a

On my System it looks like this:
$ locale -a
C
de_DE
de_DE@euro
de_DE.iso88591
de_DE.iso885915@euro
de_DE.utf8
en_US.utf8
POSIX


If you add "he_IL.UTF-8 UTF8" you should find that line.

Use as root
Code:
eselect locale list


Use as root eselect locale set to set it so some Specific Number.

On my System it looks like:
Code:
 # eselect locale list
Available targets for the LANG variable:
  [1]   C
  [2]   de_DE
  [3]   de_DE@euro
  [4]   de_DE.iso88591
  [5]   de_DE.iso885915@euro
  [6]   de_DE.utf8 *
  [7]   en_US.utf8
  [8]   POSIX
  [ ]   (free form)


As you see Number 6 is set here, marked with a star.
I set it with the line
Code:
eselect locale set 6


You have to do this for he_IL.UTF-8.

The Localization guide should be read, because its more complex and you can adjust it better to your system.
In order to build a Gentoo-System with Applications with Language Support (Menue or Settings in that Language), you have to add the Language Support (L10N="he") to your /etc/portage/make.conf File. This is described in the Localisation guide too.

I withhold some steps in my little howto, because its better you check the official wiki. You need more steps if you use systemd or open-rc, and if you want to chance your keyboard layout and so on. And you have at some point run # env-update && source /etc/profile.

Not 100% sure but i think you got a segmentation fault because you did not set (an compile the support to) it, and some Gnome-Program try to use it. Or you have not set some Fonts to display this. However a Segmentation fault can bee a hardware bug too or many other reasons. Its hard to tell.

Good Luck!

Edit:
Quote:
it only happens when I press the + in "input sources" under the "Region and Language" tab.

Usually if you do this a Box should appear where you languages will be Listed and one entry with three dots in a row, like ":" but tree and not only two. If you click on that you will create a new like, where you can click on it again and you could add some more... languages.

As far as i know this is just for Gnome 3, and you can create a virtual Keyboard and gain a little switch on the Bar above (later) where you can just klick and switch between en and he (Keyboard Layout), for example.

Do you need just the Keyboard layout? I described more for the case that you installed gentoo first time and want the system and your applications in your Language Support.
Back to top
View user's profile Send private message
sirzarmo
n00b
n00b


Joined: 22 Sep 2018
Posts: 3

PostPosted: Sat Sep 22, 2018 10:04 pm    Post subject: Reply with quote

ChrisJumper wrote:
Good Luck!



So, as far as you wrote, you were correct and the issue was a Locale one.
I had a good reason to skip the step in the handbook which was the fact that Hebrew support, on account of it being an RTL language, is REALLY BAD, Terminals show broken i/o and as English is "Lingua Franca" the LTR layout is usually the default and I'm used to it, immediately after the reboot I saw it did work! Thank you for that, sincerely.
I added the Hebrew keyboard layout but GNOME's and Firefox's layouts were still weird.
thus I reverted the changes and now it seems I can switch between Hebrew and English keyboard layouts but after the changes have been reverted GNOME control center still crushes.
is there a way to make it so GNOME control center wont crush but the GNOME layout would remain the English layout?
Thank you, really :) .
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2207
Location: Germany

PostPosted: Sun Sep 23, 2018 10:25 pm    Post subject: Reply with quote

hi sirzarmo,

I don't know why your gnome-control-center crash. Maybe its not retailed to the Language Setting.

You can switch the keyboard layout from a (gnome Terminal) too (with xserver, for wayland its different), with
Code:
$ setxkbmap il
and back to english with
Code:
$ setxkbmap en
.
I would prepare one open terminal with the command for the english layout, just to get it back if you have no access to english "letters" after setting to hebrew keyboard layout. ;D

I am not sure if you have a font Issue with that wired settings. Maybe you should check out https://wiki.gentoo.org/wiki/UTF-8 too or just have a (default) font which can not display hebrew? I am not sure.

For the Language Setting of the Desktop and some other Programs lets explain some stuff from the Localization guide:

Take a look on the LANG Variable and it different types. You can have multiple LANG Support and can use it. For example you can open a new Terminal in your Gnome Desktop and set the LANG Variable to a different Setting, and when you launch a Program it starts (if its supported at Compilation time, in that Language).

Here is a example from my system:

You see the system Available Local Settings
Code:
 $ locale -a
C
de_DE
de_DE@euro
de_DE.iso88591
de_DE.iso885915@euro
de_DE.utf8
en_US.utf8
POSIX


Lets open a Terminal and look into the LANG Variable, i do it as bash usually with the $ Sign before the Variable.

Code:
$ echo $LANG
de_DE.utf8


If i want to start the chromiun Browser with English Menue and Settings i can do this with:

Code:
 $ LANG="en_US.utf8" chromium


The first Part Overwrite the LANG Variable in just this Terminal and launch the Browser with that LANG Setting. Without the Dollar Sign before the Variable Name you can write to it.

The Localization Guide explains how to set the default Variables for example per User in its Home Directory. ~/.bashrc
This way you can launch the Environment for the User.

Have you installed app-portage/eix ?
Code:
$ eix chromium
[I] www-client/chromium
     Available Version:   69.0.3497.100^d ~70.0.3538.16^d ~70.0.3538.22^d [M]~71.0.3554.4^d {component-build cups custom-cflags gnome-keyring +hangouts jumbo-build kerberos neon pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +system-icu +system-libvpx +tcmalloc widevine KERNEL="linux" L10N="+am +ar +bg +bn +ca +cs +da +de +el +en-GB +es +es-419 +et +fa +fi +fil +fr +gu +he +hi +hr +hu +id +it +ja +kn +ko +lt +lv +ml +mr +ms +nb +nl +pl +pt-BR +pt-PT +ro +ru +sk +sl +sr +sv +sw +ta +te +th +tr +uk +vi +zh-CN +zh-TW"}
    Installed Version: 70.0.3521.2^d(XX:XX:XX XX.09.2018)(cups hangouts pic proprietary-codecs pulseaudio suid -component-build -custom-cflags -gnome-keyring -jumbo-build -kerberos -neon -selinux -system-ffmpeg -system-icu -system-libvpx -tcmalloc -widevine KERNEL="linux" L10N="de -am -ar -bg -bn -ca -cs -da -el -en-GB -es -es-419 -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt-BR -pt-PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh-CN -zh-TW")


As you see i set my L10N and LANG in /etc/portage/make.conf and compiled the Support for de (L10N="de ..") in. Yes there is no en or en_US.. i think its because its the default one.
I would suggest to add this to your /etc/portage/make.conf
Code:

L10N="en he"


If you not intend to redistribute binary packages you could set LINGUAS in make.conf too.

Code:

LINGUAS="en he"


If you have a system that boots with systemd, set the default with

Code:
# localectl  set-locale LANG=he_IL.UTF-8


Or if you use OPENRC set it in /etc/env.d/02locale

I have a systemd system and use /etc/env.d/02locale too, here i have this setting:
Code:
 $ cat /etc/env.d/02locale
LANG="de_DE.utf8"
GDM_LANG="de_DE.utf8"
LC_NUMERIC="de_DE.utf8"
LC_PAPER="de_DE.utf8"
LC_TIME="de_DE.utf8"
LC_COLLATE="C"


GDM for Gnome Display Manager (The Login Gnome Manager).

I am not sure if you should set the /etc/env.d/02locale to Hebrew, or the systemd LANG. Because you may need english layout to login with your users (english) Password. ;)

Or for native hebrew Support with hebrew Passwords you should set it different. The setxkbmap wont work for gdm i thnk... but by setting the LANG Variable in users ~/.bashrc, it should be the default. His/her Gnome session and programs would start in that Language.
So if you want to use an english gnome you should set in your ~/.bashrc

Code:

LANG=en_US.utf8


if your en_US locale looks like this. ATTENTION - My example is set in lowercase letters, usually the docs use Uppercase one.. it was defined by the add into /etc/locale.gen and depend on that example in my first post here.. before run as root the local-gen command.

I am a little tired right now and hope i don't confuse you to much. My english is not as good right know as it should be. Hope it helps on some way.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum