Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] How to go back one version of an ebuild?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
GhostTyper
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2004
Posts: 77
Location: Germany; BW

PostPosted: Tue Sep 18, 2018 4:45 pm    Post subject: [SOLVED] How to go back one version of an ebuild? Reply with quote

I have a small perl script doin' some (my)sql queries. After my last emerge --sync && emerge -ptvuND world this script crashes with:
Code:
double free or corruption (!prev)

Another one crashes with:
Code:
malloc(): memory corruption

While debugging I found out that those errors originate from within the DBI module. dev-lang/perl and dev-perl/DBI didn't change in version.

But mysql changed from dev-db/mysql-5.6.40:0/18::gentoo to dev-db/mysql-5.6.40-r2:0/18::gentoo.

My question is: How can I reverse to dev-db/mysql-5.6.40:0/18::gentoo? Specifying the exact package with = didn't work.


Last edited by GhostTyper on Sat Sep 29, 2018 1:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41705
Location: 56N 3W

PostPosted: Tue Sep 18, 2018 4:55 pm    Post subject: Reply with quote

GhostTyper,

Its still in my tree.
Code:
$ ls /usr/portage/dev-db/mysql -l
total 139
drwxr-xr-x 2 root root  1024 Apr 23 16:58 files
-rw-r--r-- 1 root root  7636 Sep 15 11:39 Manifest
-rw-r--r-- 1 root root  1916 Sep 15 11:39 metadata.xml
-rw-r--r-- 1 root root  4381 Sep 15 11:39 mysql-5.5.60.ebuild
-rw-r--r-- 1 root root 25516 Aug  5 02:39 mysql-5.5.61.ebuild
-rw-r--r-- 1 root root  6466 Jan 23  2018 mysql-5.6.38.ebuild
-rw-r--r-- 1 root root  6520 Mar 30 13:09 mysql-5.6.39.ebuild
-rw-r--r-- 1 root root  6521 Sep  2 00:39 mysql-5.6.40.ebuild
-rw-r--r-- 1 root root 25127 Sep 15 00:39 mysql-5.6.40-r2.ebuild
-rw-r--r-- 1 root root 25132 Aug  5 02:39 mysql-5.6.41.ebuild
-rw-r--r-- 1 root root 27020 Aug  5 02:39 mysql-5.7.23.ebuild



Code:
emerge =dev-db/mysql-5.6.40
should get you the older mysql.
You might want to mask =dev-db/mysql-5.6.40-r2 so portage doesn't update to that version for you again.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
GhostTyper
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2004
Posts: 77
Location: Germany; BW

PostPosted: Tue Sep 18, 2018 5:27 pm    Post subject: Reply with quote

I'm confused. I just have this list:
Code:
# ls /usr/portage/dev-db/mysql -l
insgesamt 128
drwxr-xr-x 2 root root  4096  7. Mai 18:59 files
-rw-r--r-- 1 root root  4853 17. Sep 23:09 Manifest
-rw-r--r-- 1 root root  1436 17. Sep 23:09 metadata.xml
-rw-r--r-- 1 root root 25516  5. Aug 03:39 mysql-5.5.61.ebuild
-rw-r--r-- 1 root root 25125 17. Sep 20:09 mysql-5.6.40-r2.ebuild
-rw-r--r-- 1 root root 25132  5. Aug 03:39 mysql-5.6.41.ebuild
-rw-r--r-- 1 root root 27020  5. Aug 03:39 mysql-5.7.23.ebuild

Why is my list incomplete? This system exists for years now and I didn't delete something on purpose.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3552
Location: Dallas area

PostPosted: Tue Sep 18, 2018 6:11 pm    Post subject: Reply with quote

GhostTyper wrote:
I'm confused. I just have this list:
Code:
# ls /usr/portage/dev-db/mysql -l
insgesamt 128
drwxr-xr-x 2 root root  4096  7. Mai 18:59 files
-rw-r--r-- 1 root root  4853 17. Sep 23:09 Manifest
-rw-r--r-- 1 root root  1436 17. Sep 23:09 metadata.xml
-rw-r--r-- 1 root root 25516  5. Aug 03:39 mysql-5.5.61.ebuild
-rw-r--r-- 1 root root 25125 17. Sep 20:09 mysql-5.6.40-r2.ebuild
-rw-r--r-- 1 root root 25132  5. Aug 03:39 mysql-5.6.41.ebuild
-rw-r--r-- 1 root root 27020  5. Aug 03:39 mysql-5.7.23.ebuild

Why is my list incomplete? This system exists for years now and I didn't delete something on purpose.


That's the same as what I have. If I look in my backup from the 15th, I have most of what Neddy shows.
I just looked mysql-5.6.40.ebuild isn't in the attic yet.
Maybe Neddy can paste it so you can copy it down.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41705
Location: 56N 3W

PostPosted: Tue Sep 18, 2018 6:29 pm    Post subject: Reply with quote

Anon-E-moose,

It will be in git, but since I have it,
Code:
$ wgetpaste /usr/portage/dev-db/mysql/mysql-5.6.40.ebuild
Your paste can be seen here: https://paste.pound-python.org/show/2rqJ8O61A1uXs1Q1WpAu/


I did not check for patches in the ./files dir.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
GhostTyper
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2004
Posts: 77
Location: Germany; BW

PostPosted: Tue Sep 18, 2018 7:08 pm    Post subject: Reply with quote

I'll copied this ebuild from another server, which hasn't been synced. (Luckily this happened to my test-system.)
Code:
# emerge =dev-db/mysql-5.6.40

 * IMPORTANT: 28 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies / * Missing digest for '/usr/portage/dev-db/mysql/mysql-5.6.40.ebuild'
... done!

!!! All ebuilds that could satisfy "=dev-db/mysql-5.6.40" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-db/mysql-5.6.40::gentoo (masked by: corruption)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

I never had masked by corruption.

Thank you for your copy, but I just didn't know that I just need to copy the ebuild. However, it didn't work. :-/
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3552
Location: Dallas area

PostPosted: Tue Sep 18, 2018 7:16 pm    Post subject: Reply with quote

you can't just put the file there, you have to run "ebuild <ebuild name including .ebuild> manifest"
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
GhostTyper
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2004
Posts: 77
Location: Germany; BW

PostPosted: Tue Sep 18, 2018 7:38 pm    Post subject: Reply with quote

Thank you. Now it works again. <3
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41705
Location: 56N 3W

PostPosted: Tue Sep 18, 2018 8:05 pm    Post subject: Reply with quote

GhostTyper,

Put it in your local overlay.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3552
Location: Dallas area

PostPosted: Tue Sep 18, 2018 8:13 pm    Post subject: Reply with quote

NeddySeagoon wrote:
GhostTyper,

Put it in your local overlay.


Yes, if you don't put it in the local overlay, the next time you sync it will disappear.
Put it in local and then run the ebuild manifest command in that directory.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
GhostTyper
Tux's lil' helper
Tux's lil' helper


Joined: 03 Apr 2004
Posts: 77
Location: Germany; BW

PostPosted: Tue Sep 18, 2018 8:28 pm    Post subject: Reply with quote

Well, I hope that this is fixed next time I sync. XD

How would I report this bug?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum