Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cannot access to the virtual terminals
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dr_berta
n00b
n00b


Joined: 07 Mar 2016
Posts: 24
Location: Carpi (MO)

PostPosted: Mon Sep 17, 2018 2:09 pm    Post subject: cannot access to the virtual terminals Reply with quote

Hi,
I just have installed gentoo kernel 4.14 on a panel pc where i want to run a grphic application under X.
My problem is that when I start xdm, I cannot go into a virtual terminal doing CTRL+ALT+Fx
Xdm works on VT2 and the logs are on VT1, but unfortunately all the other VT cannot be used and I don't understand why.

into the /etc/inittab file I foresaw 6 VT that are present if I work in command line mode:
Code:
c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:2345:respawn:/sbin/agetty 38400 tty2 linux
c3:2345:respawn:/sbin/agetty 38400 tty3 linux
c4:2345:respawn:/sbin/agetty 38400 tty4 linux
c5:2345:respawn:/sbin/agetty 38400 tty5 linux
c6:2345:respawn:/sbin/agetty 38400 tty6 linux


Where could be the problem?
Thanks
Claudio
Back to top
View user's profile Send private message
PCmaniaK
n00b
n00b


Joined: 18 Aug 2018
Posts: 15

PostPosted: Mon Sep 17, 2018 5:51 pm    Post subject: Reply with quote

chvt N may help. Also try FN+CTRL+ALT+Fx if your panel pc has FN key
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1372
Location: Montréal

PostPosted: Mon Sep 17, 2018 6:13 pm    Post subject: Reply with quote

You can make a section for Xorg by creating the directory /etc/X11/xorg.conf.d if not yet there in which you create the file ServerFlags.conf with this contain
Code:
Section "ServerFlags"
    Option "DontVTSwitch"       "off"
   EndSection

It will tell explicitely to Xorg to allow you to switch VT. Your problem may be elsewhere. Have logs on tty1 and X on tty2 is quite weird. Systemd reserve tty1 for X by default. You can configure Xdm to open the X session on tty7 what is the standard. On tty1 and tty2 you already have a login connexion from inittab your better to not use them for something else.

En passant, Xdm is a poor display manager.
_________________
Paul
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum