Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
flightdm-gtk-greeter update now depens on xfce? [resolved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
roki942
Apprentice
Apprentice


Joined: 18 Apr 2005
Posts: 283
Location: Seattle

PostPosted: Sun Sep 16, 2018 8:09 pm    Post subject: flightdm-gtk-greeter update now depens on xfce? [resolved] Reply with quote

This seems very strange to me and google didn't shed any light on it.
Code:

[ebuild     U  ] x11-misc/lightdm-gtk-greeter-2.0.5-r1 [2.0.1-r1] USE="-branding*"
[ebuild  N     ]  xfce-base/exo-0.12.0
[ebuild  N     ]   xfce-base/libxfce4ui-4.13.4  USE="startup-notification -debug -glade -introspection -vala"
[ebuild  N     ]    xfce-base/xfconf-4.12.1  USE="-debug -perl"
[ebuild  N     ]     xfce-base/libxfce4util-4.13.1  USE="-introspection"


Last edited by roki942 on Thu Sep 27, 2018 1:45 am; edited 1 time in total
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5588
Location: Removed by Neddy

PostPosted: Sun Sep 16, 2018 8:10 pm    Post subject: Reply with quote

add -t to find out what is pulling it in
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13509

PostPosted: Sun Sep 16, 2018 8:22 pm    Post subject: Reply with quote

That output is indented, so he is already using -t. According to ebuild, xfce-base/exo is now in $DEPEND. I cannot say why that is the case.
Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 458
Location: Earth

PostPosted: Sun Sep 16, 2018 8:52 pm    Post subject: Reply with quote

look at geki's Overlay - there's a Version without this dependency.

https://data.gpo.zugaina.org/geki/x11-misc/lightdm-gtk-greeter/files/

working fine here :D
_________________
beQuiet! Silent Base 800 Black - MSI C236A - Xeon E3-1245v5 - 32GB RAM Kingston - Sapphire Nitro+ Radeon RX590 8G - Samsung PM961 M.2 128GB - Samsung 840 EVO 120GB - Creative Sound Blaster RX PCIe - Logitech Z623 2.1 - G110 Keyboard - Mouse G400
Back to top
View user's profile Send private message
roki942
Apprentice
Apprentice


Joined: 18 Apr 2005
Posts: 283
Location: Seattle

PostPosted: Mon Sep 17, 2018 9:34 pm    Post subject: Reply with quote

Thanks for your answers. At first I was surprised that a DM would depend on a DE and wondered if it was going the way of GDM but what really kept me from it was the concern that it may mess with some of my desktop settings.

Until I understand why it's depending on exo I'll use the one at geki's overlay - thanks CooSee
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1636
Location: United Kingdom

PostPosted: Mon Sep 17, 2018 11:49 pm    Post subject: Reply with quote

Could LightDM GTK+ Greeter bug report #1635816 have something to do with it?:

https://bugs.launchpad.net/lightdm-gtk-greeter/+bug/1635816

Hanno Meyer-Thurow wrote:
AFAIS the exo-csource dependency is required only in maintainer-mode[0]. Would it be possible to update configure.ac[1], so that it is required conditionally on maintainer-mode being enabled?

That would be great and thank you in advance.

[0] http://bazaar.launchpad.net/~lightdm-gtk-greeter-team/lightdm-gtk-greeter/trunk/view/head:/src/Makefile.am#L49

[1] http://bazaar.launchpad.net/~lightdm-gtk-greeter-team/lightdm-gtk-greeter/trunk/view/head:/configure.ac#L34

_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
roki942
Apprentice
Apprentice


Joined: 18 Apr 2005
Posts: 283
Location: Seattle

PostPosted: Tue Sep 18, 2018 1:23 am    Post subject: Reply with quote

Fitzcarraldo wrote:
Could LightDM GTK+ Greeter bug report #1635816 have something to do with it?:

https://bugs.launchpad.net/lightdm-gtk-greeter/+bug/1635816

Hanno Meyer-Thurow wrote:
AFAIS the exo-csource dependency is required only in maintainer-mode[0]. Would it be possible to update configure.ac[1], so that it is required conditionally on maintainer-mode being enabled?

That would be great and thank you in advance.

[0] http://bazaar.launchpad.net/~lightdm-gtk-greeter-team/lightdm-gtk-greeter/trunk/view/head:/src/Makefile.am#L49

[1] http://bazaar.launchpad.net/~lightdm-gtk-greeter-team/lightdm-gtk-greeter/trunk/view/head:/configure.ac#L34

Thank you! I have an understanding of it after googling maintainer-mode and reading https://flameeyes.blog/2008/06/13/maintaner-mode/
It's a shame the bug is 2 years old. On the off chance it may affect my desktop I'll go with geki's ebuild.

Edit: geki's ebuild calls for eapi 7 and doesn't build for me so I'm happy to say that the Gentoo ebuild pulling in the xfce libs didn't mess with my desktop.
Thanks again everyone.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum