Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] "Mismatch between the program and library build..."
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
papandreoos
Apprentice
Apprentice


Joined: 17 Dec 2014
Posts: 162

PostPosted: Sun Sep 16, 2018 11:04 am    Post subject: [SOLVED] "Mismatch between the program and library buil Reply with quote

the problem is with amule (2.3.2-r2) and audacity (2.2.2).
they both compiled and installed just fine.
the problem is that they do not open when i try to open them.
if i open them from terminal i get (for both of them) this error message:
Code:
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8).
Aborted (core dumped)


Last edited by papandreoos on Sun Sep 16, 2018 6:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
Anon-E-moose
Watchman
Watchman


Joined: 23 May 2008
Posts: 5251
Location: Dallas area

PostPosted: Sun Sep 16, 2018 11:24 am    Post subject: Reply with quote

rebuild wxGTK
_________________
PRIME x570-pro, 3700x, RX 550 - 5.11 zen kernel
Acer E5-575 (laptop), i3-7100u - i965 - 5.5 zen kernel
---both---
gcc 9.3.0, profile 17.1 amd64-no-multilib, eudev, openrc, openbox, wayland

The New OTW
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3989
Location: Germany

PostPosted: Sun Sep 16, 2018 5:11 pm    Post subject: Mismatch between the program and library build version Reply with quote

Yes, rebuild the right wxGTK Slot should help:
Code:
emerge -av1 x11-libs/wxGTK:3.0
Back to top
View user's profile Send private message
papandreoos
Apprentice
Apprentice


Joined: 17 Dec 2014
Posts: 162

PostPosted: Sun Sep 16, 2018 6:01 pm    Post subject: Reply with quote

great thank you very much.
they both working now after rebuild wxGTK.
Back to top
View user's profile Send private message
Progman3K
l33t
l33t


Joined: 03 Jan 2004
Posts: 694

PostPosted: Tue Dec 25, 2018 8:08 pm    Post subject: Doesn't solve for me, maybe it's the mixed repos? Reply with quote

Hi!
Code:
emerge -vDa audacity wxGTK
Quote:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-libs/wxGTK-3.1.1-r302:3.1-gtk3/3.1.1::stefantalpalaru USE="X gstreamer libnotify opengl sdl tiff (-aqua) -debug -doc -webkit" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild R ] media-sound/audacity-2.2.2::gentoo USE="alsa flac id3tag ladspa lame lv2 mad midi nls portmixer soundtouch twolame vamp vorbis vst -doc -ffmpeg -jack -libav -sbsms" CPU_FLAGS_X86="sse" 0 KiB

Total: 2 packages (2 reinstalls), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] Yes

[...] modules succesfully build and install
Code:
audacity
Quote:
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).
Aborted (core dumped)


What did I miss?
Thanks
Back to top
View user's profile Send private message
grumblebear
Apprentice
Apprentice


Joined: 26 Feb 2008
Posts: 196

PostPosted: Tue Dec 25, 2018 11:46 pm    Post subject: Reply with quote

In your emerge command you rebuilt wxGTK (v. 3.1.1) from an overlay. I think you want the 3.0 version from the official portage tree instead.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 17054

PostPosted: Wed Dec 26, 2018 3:26 am    Post subject: Reply with quote

According to your error message, the program is newer than the library. Rebuild the library with a compiler that uses C++ ABI 1011.
Back to top
View user's profile Send private message
Progman3K
l33t
l33t


Joined: 03 Jan 2004
Posts: 694

PostPosted: Wed Dec 26, 2018 5:16 pm    Post subject: Reply with quote

Tried this:
Code:
emerge -vDa =x11-libs/wxGTK-3.0.4-r301

Same problem.

Hu, I thought you might be on to something, but look
Code:
gcc-config -l
Quote:
[1] x86_64-pc-linux-gnu-6.4.0
[2] x86_64-pc-linux-gnu-7.3.0 *

Should I select 6.4 instead?

Thank you very much for your help, gentlepeople!
Back to top
View user's profile Send private message
grumblebear
Apprentice
Apprentice


Joined: 26 Feb 2008
Posts: 196

PostPosted: Wed Dec 26, 2018 5:44 pm    Post subject: Reply with quote

Progman3K wrote:
Tried this:
Code:
emerge -vDa =x11-libs/wxGTK-3.0.4-r301

Same problem.


I fear your again selected the wrong version. The 3.0 slot seems to be required. That is wxGTK-3.0.4 or 3.0.4-r1. If not needed elsewhere, I would advise you to remove the others from your installation.
Back to top
View user's profile Send private message
Progman3K
l33t
l33t


Joined: 03 Jan 2004
Posts: 694

PostPosted: Wed Dec 26, 2018 8:10 pm    Post subject: Reply with quote

grumblebear wrote:
Progman3K wrote:
Tried this:
Code:
emerge -vDa =x11-libs/wxGTK-3.0.4-r301

Same problem.

I fear your again selected the wrong version. The 3.0 slot seems to be required. That is wxGTK-3.0.4 or 3.0.4-r1. If not needed elsewhere, I would advise you to remove the others from your installation.

Code:
emerge -vDa =x11-libs/wxGTK-3.0.4-r1

That did the trick!
As for other versions of wxGTK, they don't show up in the output of emerge --depclean -a
Code:
emerge -s wxGTK
Quote:
[ Results for search key : wxGTK ]

* x11-libs/wxGTK
Latest version available: 3.1.1-r302
Latest version installed: 3.1.1-r302
If I uninstall 3.1.1-r302, won't it break something else?
Back to top
View user's profile Send private message
grumblebear
Apprentice
Apprentice


Joined: 26 Feb 2008
Posts: 196

PostPosted: Wed Dec 26, 2018 9:12 pm    Post subject: Reply with quote

If you ran emerge as shown (that is without option -1) those wxGTK version are now all added to your world file. Remove them from there and try again emerge --depclean.
You can always use qdepends or equery d to determine what pulls in a particular version.
Back to top
View user's profile Send private message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 402
Location: Switzerland

PostPosted: Mon Dec 31, 2018 2:22 am    Post subject: Reply with quote

Unfortunately nothing of all this is helping. Audacity is still broken with the exact error message shown. Any other tricks? Maybe something in wxGTK itself is broken trickling through?
_________________
Leader and Head Programmer: Epsylon, Drag[en]gine and others
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 17054

PostPosted: Mon Dec 31, 2018 4:37 am    Post subject: Reply with quote

There are two different error messages shown in this thread, although they are at least similar. In both cases shown, the program had been built with a newer C++ ABI than the library. For those cases, the resolution is to rebuild the library with the same C++ ABI as the program is trying to use.
Back to top
View user's profile Send private message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 402
Location: Switzerland

PostPosted: Mon Dec 31, 2018 12:20 pm    Post subject: Reply with quote

Hu wrote:
There are two different error messages shown in this thread, although they are at least similar. In both cases shown, the program had been built with a newer C++ ABI than the library. For those cases, the resolution is to rebuild the library with the same C++ ABI as the program is trying to use.

It's this one:
Code:
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).
Aborted (core dumped)


I did rebuild wxGTK (wxGTK-3.0.4-r300) and audacity (audacity-2.2.2) multiple times. These are the newest packages after a fresh sync today.
_________________
Leader and Head Programmer: Epsylon, Drag[en]gine and others
Back to top
View user's profile Send private message
grumblebear
Apprentice
Apprentice


Joined: 26 Feb 2008
Posts: 196

PostPosted: Mon Dec 31, 2018 2:09 pm    Post subject: Reply with quote

Dragonlord wrote:
I did rebuild wxGTK (wxGTK-3.0.4-r300) and audacity (audacity-2.2.2) multiple times. These are the newest packages after a fresh sync today.

Have you really read the posts above? You need wxGTK-3.0.4 from the 3.0 slot, not 3.0.4-r300 from the 3.0-gtk3 slot.
Back to top
View user's profile Send private message
Anon-E-moose
Watchman
Watchman


Joined: 23 May 2008
Posts: 5251
Location: Dallas area

PostPosted: Mon Dec 31, 2018 2:31 pm    Post subject: Reply with quote

all wxGTK-*-r3xx are gtk3 versions

Code:
equery l -po wxGTK
 * Searching for wxGTK ...
[-P-] [  ] x11-libs/wxGTK-3.0.3:3.0
[-P-] [  ] x11-libs/wxGTK-3.0.3-r300:3.0-gtk3
[IP-] [  ] x11-libs/wxGTK-3.0.4:3.0
[-P-] [ ~] x11-libs/wxGTK-3.0.4-r1:3.0
[-P-] [  ] x11-libs/wxGTK-3.0.4-r300:3.0-gtk3
[-P-] [ ~] x11-libs/wxGTK-3.0.4-r301:3.0-gtk3

_________________
PRIME x570-pro, 3700x, RX 550 - 5.11 zen kernel
Acer E5-575 (laptop), i3-7100u - i965 - 5.5 zen kernel
---both---
gcc 9.3.0, profile 17.1 amd64-no-multilib, eudev, openrc, openbox, wayland

The New OTW
Back to top
View user's profile Send private message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 402
Location: Switzerland

PostPosted: Tue Jan 01, 2019 3:43 pm    Post subject: Reply with quote

grumblebear wrote:
Dragonlord wrote:
I did rebuild wxGTK (wxGTK-3.0.4-r300) and audacity (audacity-2.2.2) multiple times. These are the newest packages after a fresh sync today.

Have you really read the posts above? You need wxGTK-3.0.4 from the 3.0 slot, not 3.0.4-r300 from the 3.0-gtk3 slot.

3.0.4-r1 is masked. You don't want to claim I need to emerge a masked package?

EDIT:
Okay... now I'm confused. I've got "wxGTK-3.0.4-r300" installed. It's is more recent than r1. Why is "3.0.4" not "3.0.4"? I'm confused.
_________________
Leader and Head Programmer: Epsylon, Drag[en]gine and others
Back to top
View user's profile Send private message
Anon-E-moose
Watchman
Watchman


Joined: 23 May 2008
Posts: 5251
Location: Dallas area

PostPosted: Tue Jan 01, 2019 4:55 pm    Post subject: Reply with quote

Once more

x11-libs/wxGTK-3.0.4:3.0 -------- gtk2 version

x11-libs/wxGTK-3.0.4-r300:3.0-gtk3 --------- gtk3 version
_________________
PRIME x570-pro, 3700x, RX 550 - 5.11 zen kernel
Acer E5-575 (laptop), i3-7100u - i965 - 5.5 zen kernel
---both---
gcc 9.3.0, profile 17.1 amd64-no-multilib, eudev, openrc, openbox, wayland

The New OTW
Back to top
View user's profile Send private message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 402
Location: Switzerland

PostPosted: Tue Jan 01, 2019 6:50 pm    Post subject: Reply with quote

I see. That did actually help. Quite confusing this naming there. I always attributed slots to layman and mixing repositories...
_________________
Leader and Head Programmer: Epsylon, Drag[en]gine and others
Back to top
View user's profile Send private message
Anon-E-moose
Watchman
Watchman


Joined: 23 May 2008
Posts: 5251
Location: Dallas area

PostPosted: Tue Jan 01, 2019 11:00 pm    Post subject: Reply with quote

Yes, the naming sucks. I would have chosen something different ... but no one asked me :lol:
_________________
PRIME x570-pro, 3700x, RX 550 - 5.11 zen kernel
Acer E5-575 (laptop), i3-7100u - i965 - 5.5 zen kernel
---both---
gcc 9.3.0, profile 17.1 amd64-no-multilib, eudev, openrc, openbox, wayland

The New OTW
Back to top
View user's profile Send private message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 402
Location: Switzerland

PostPosted: Wed Jan 02, 2019 1:12 pm    Post subject: Reply with quote

Anon-E-moose wrote:
(...) but no one asked me :lol:

It's always like this in life :lol:
_________________
Leader and Head Programmer: Epsylon, Drag[en]gine and others
Back to top
View user's profile Send private message
allaboutmike
n00b
n00b


Joined: 25 May 2004
Posts: 19

PostPosted: Tue Oct 22, 2019 4:50 am    Post subject: Reply with quote

grumblebear wrote:
Dragonlord wrote:
I did rebuild wxGTK (wxGTK-3.0.4-r300) and audacity (audacity-2.2.2) multiple times. These are the newest packages after a fresh sync today.

Have you really read the posts above? You need wxGTK-3.0.4 from the 3.0 slot, not 3.0.4-r300 from the 3.0-gtk3 slot.


AH HA!
Thankyou grumblebear.
I read this thread thinking I had already rebuilt everything, but the slot naming was apparently too subtle for me.
Thanks for clarifying this.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum