Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
peculiar dependency problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
mikefot
Guru
Guru


Joined: 19 Nov 2014
Posts: 351

PostPosted: Sat Sep 15, 2018 2:49 pm    Post subject: peculiar dependency problem Reply with quote

Dear All,

I have got an odd dependency problem occuring in a world update (I am running gentoo testing on an amd64 kaveri box).

see here:

https://pastebin.com/8By5eVfP

If I try to list the packages at fault they are not present in my installation apparently:

E.g.

Code:
djt /home/mikef # equery --quiet list dev-python/pluggy
djt /home/mikef # equery --quiet list dev-python/coverage
djt /home/mikef # equery --quiet list dev-python/nose
djt /home/mikef #


My make.conf file looks like this:

https://pastebin.com/zQZZwvPR

Comments appreciated

Regards

Michael Fothergill
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1673

PostPosted: Sat Sep 15, 2018 3:02 pm    Post subject: Reply with quote

Well, as the output mentioned, try this:

Code:
It might be possible to break this cycle
by applying the following change:
- dev-python/coverage-4.2 (Change USE: -test)


Though, it is strange to see the test use flag enabled, as usually people leave it disabled and only enable on the necessary packages.
Back to top
View user's profile Send private message
mikefot
Guru
Guru


Joined: 19 Nov 2014
Posts: 351

PostPosted: Sat Sep 15, 2018 3:08 pm    Post subject: Reply with quote

Many thanks for the suggestion.

This seems to have cured the problem.

Cheers

MF
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6623
Location: Austria

PostPosted: Sat Sep 15, 2018 3:09 pm    Post subject: Reply with quote

ct85711 wrote:
Though, it is strange to see the test use flag enabled, as usually people leave it disabled and only enable on the necessary packages.

It is part of the OP's make.conf.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum