Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] qtcore/libs/gui 5.9.6 won't let me upgrade to 5.11
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
HL521
n00b
n00b


Joined: 07 Jul 2013
Posts: 12

PostPosted: Thu Sep 06, 2018 2:45 am    Post subject: [SOLVED] qtcore/libs/gui 5.9.6 won't let me upgrade to 5.11 Reply with quote

I tried masking 5.9.6, however that still did not solve my problem and I'm not sure how to proceed.

Code:
These are the packages that would be merged, in order:

Calculating dependencies  . .. .. ........ done!
[ebuild     U  ] sys-devel/bison-3.0.5-r1::gentoo [3.0.4-r1::gentoo] USE="nls -examples -static {-test}" 1,915 KiB
[ebuild     U ~] dev-qt/qtcore-5.11.1:5/5.11::gentoo [5.9.6:5/5.9::gentoo] USE="icu -debug -systemd {-test}" 45,763 KiB
[ebuild     U ~] dev-qt/qtdbus-5.11.1:5/5.11::gentoo [5.9.6:5/5.9::gentoo] USE="-debug {-test}" 0 KiB
[ebuild   R    ] x11-base/xorg-server-1.19.5-r2:0/1.19.5::gentoo  USE="glamor ipv6 suid udev xorg -debug -dmx -doc -kdrive -libressl -minimal (-selinux) -static-libs -systemd -tslib -unwind -wayland* -xcsecurity -xephyr -xnest -xvfb" 0 KiB
[ebuild     U ~] dev-qt/qtgui-5.11.1:5/5.11::gentoo [5.9.6:5/5.9::gentoo] USE="dbus egl gif jpeg libinput png udev xcb -accessibility -debug -eglfs -evdev (-gles2) -ibus {-test} -tslib -tuio -vnc" 0 KiB
[ebuild   R    ] x11-libs/gtk+-3.22.30:3::gentoo  USE="X cups introspection vim-syntax (-aqua) -broadway -cloudprint -colord -examples {-test} -wayland* -xinerama" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U ~] dev-qt/qtwidgets-5.11.1:5/5.11::gentoo [5.9.6-r1:5/5.9::gentoo] USE="gtk png xcb -debug (-gles2) {-test}" 0 KiB
[ebuild   R    ] dev-cpp/gtkmm-3.22.2:3.0::gentoo  USE="X (-aqua) -doc {-test} -wayland*" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] x11-drivers/nvidia-drivers-396.54:0/396::gentoo [396.45:0/396::gentoo] USE="X acpi driver kms multilib tools -compat -gtk3 -pax_kernel -static-libs -uvm -wayland*" ABI_X86="32 (64) (-x32)" 86,000 KiB
[ebuild   R    ] media-libs/libsdl2-2.0.8-r1::gentoo  USE="X alsa dbus gles joystick opengl pulseaudio sound threads udev video (-altivec) (-aqua) (-custom-cflags) -haptic -libsamplerate -nas -oss -static-libs -tslib -wayland* -xinerama -xscreensaver" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx sse sse2 -3dnow" 0 KiB
[ebuild     U  ] net-analyzer/wireshark-2.6.3:0/2.6.3::gentoo [2.6.2:0/2.6.2::gentoo] USE="capinfos captype dftest dumpcap editcap filecaps gtk mergecap netlink pcap qt5 randpkt randpktdump reordercap sharkd ssl text2pcap tshark udpdump zlib -adns -androiddump -bcg729 -ciscodump -doc -kerberos -libxml2 -lua -lz4 -maxminddb -nghttp2 -portaudio -sbc (-selinux) -smi -snappy -spandsp -sshdump -tfshark" 27,719 KiB
[ebuild   R    ] media-video/vlc-3.0.3-r1:0/5-9::gentoo  USE="X a52 alsa dbus dts dvbpsi dvd encode ffmpeg flac gcrypt jpeg libnotify libsamplerate mp3 mpeg ncurses ogg png pulseaudio qt5 samba ssl svg truetype udev vorbis x264 xml (-altivec) (-aom) -archive -bidi -bluray -cddb -chromaprint -chromecast -dc1394 -debug (-directx) -faad -fdk -fluidsynth -fontconfig -gme -gnome-keyring -gstreamer -ieee1394 -jack -kate -libass (-libav) -libcaca -libtar -libtiger -linsys -lirc -live -lua -macosx-notifications (-macosx-qtkit) -matroska -modplug -mtp -musepack (-neon) -nfs -omxil -opencv -optimisememory -opus -postproc -projectm -rdp -rtsp -run-as-root -schroedinger -sdl-image -sftp -shout -sid -skins -soxr -speex (-srt) -taglib {-test} -theora -tremor -twolame -upnp -v4l -vaapi -vdpau -vnc -vpx -wayland* -wma-fixed -x265 -zeroconf -zvbi" CPU_FLAGS_X86="mmx sse" 0 KiB
[ebuild   R    ] kde-frameworks/plasma-5.46.0:5/5.46::gentoo  USE="X -debug -doc (-gles2) {-test} -wayland*" 0 KiB
[ebuild   R    ] kde-plasma/breeze-5.12.5:5::gentoo  USE="X -debug -wayland*" 0 KiB
[ebuild   R    ] kde-plasma/oxygen-5.12.5:5::gentoo  USE="-debug -wayland*" 0 KiB
[ebuild   R    ] kde-plasma/kinfocenter-5.12.5:5::gentoo  USE="handbook opengl pci -debug (-gles2) -ieee1394 -wayland*" 0 KiB

Total: 16 packages (7 upgrades, 9 reinstalls), Size of downloads: 161,395 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.11.1 required by (dev-qt/qtwidgets-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^                                                                                 
    ~dev-qt/qtcore-5.11.1 required by (dev-qt/qtgui-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^                                                                             
    ~dev-qt/qtcore-5.11.1 required by (dev-qt/qtdbus-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^                                                                               

  (dev-qt/qtcore-5.9.6:5/5.9::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtxml-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                           
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/linguist-tools-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                                   
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtpaths-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                             
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtgraphicaleffects-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                                       
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtopengl-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                             
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtquickcontrols-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                                     
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtsql-5.9.6-r1:5/5.9.6::gentoo, installed)
    ^              ^^^^^                                                               
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtscript-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                             
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtx11extras-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                                 
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtnetwork-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                               
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtdeclarative-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                                   
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtquickcontrols2-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                                     
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtdbus-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                           
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtmultimedia-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                                 
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtprintsupport-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                                   
    >=dev-qt/qtcore-5.9.4:5/5.9= required by (kde-frameworks/kxmlgui-5.46.0:5/5.46::gentoo, installed)
                         ^^^^^^^                                                                       
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qttest-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                           
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtvirtualkeyboard-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                                       
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/designer-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                             
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtwidgets-5.9.6-r1:5/5.9::gentoo, installed)
    ^              ^^^^^                                                                 
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtgui-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                           
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtxmlpatterns-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                                   
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qdbus-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                           
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtwayland-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                               
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtsensors-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                               
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtconcurrent-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                                 
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtsvg-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                           

dev-qt/qtgui:5

  (dev-qt/qtgui-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.11.1[gles2=,png=,xcb?] required by (dev-qt/qtwidgets-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^             ^^^^^^                                                                                                   
    ~dev-qt/qtgui-5.11.1[dbus] required by (dev-qt/qtwidgets-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^             ^^^^^^                                                                                       

  (dev-qt/qtgui-5.9.6:5/5.9::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.9.6 required by (dev-qt/qtvirtualkeyboard-5.9.6:5/5.9::gentoo, installed)
    ^             ^^^^^                                                                       
    ~dev-qt/qtgui-5.9.6 required by (dev-qt/qtgraphicaleffects-5.9.6:5/5.9::gentoo, installed)
    ^             ^^^^^                                                                       
    ~dev-qt/qtgui-5.9.6[gles2=] required by (dev-qt/qtdeclarative-5.9.6:5/5.9::gentoo, installed)
    ^             ^^^^^                                                                           
    ~dev-qt/qtgui-5.9.6 required by (dev-qt/qtscript-5.9.6:5/5.9::gentoo, installed)
    ^             ^^^^^                                                             
    ~dev-qt/qtgui-5.9.6[gles2=,png=,xcb?] required by (dev-qt/qtwidgets-5.9.6-r1:5/5.9::gentoo, installed)
    ^             ^^^^^                                                                                   
    ~dev-qt/qtgui-5.9.6[gles2=] required by (dev-qt/qtopengl-5.9.6:5/5.9::gentoo, installed)
    ^             ^^^^^                                                                     
    ~dev-qt/qtgui-5.9.6[gles2=] required by (dev-qt/qtprintsupport-5.9.6:5/5.9::gentoo, installed)
    ^             ^^^^^                                                                           
    ~dev-qt/qtgui-5.9.6[dbus] required by (dev-qt/qtwidgets-5.9.6-r1:5/5.9::gentoo, installed)
    ^             ^^^^^                                                                       
    >=dev-qt/qtgui-5.9.1:5/5.9=[-gles2] required by (kde-plasma/kwin-5.12.5:5/5::gentoo, installed)
                        ^^^^^^^                                                                     
    >=dev-qt/qtgui-5.9.1:5/5.9=[dbus] required by (kde-plasma/plasma-integration-5.12.5:5/5::gentoo, installed)
                        ^^^^^^^                                                                                 
    ~dev-qt/qtgui-5.9.6[xcb] required by (dev-qt/qtx11extras-5.9.6:5/5.9::gentoo, installed)
    ^             ^^^^^                                                                     
    ~dev-qt/qtgui-5.9.6[egl,libinput?] required by (dev-qt/qtwayland-5.9.6:5/5.9::gentoo, installed)
    ^             ^^^^^                                                                             
    ~dev-qt/qtgui-5.9.6 required by (dev-qt/qtsvg-5.9.6:5/5.9::gentoo, installed)
    ^             ^^^^^                                                           
    ~dev-qt/qtgui-5.9.6 required by (dev-qt/qtquickcontrols-5.9.6:5/5.9::gentoo, installed)
    ^             ^^^^^                                                                     
    ~dev-qt/qtgui-5.9.6 required by (dev-qt/qtquickcontrols2-5.9.6:5/5.9::gentoo, installed)
    ^             ^^^^^                                                                     
    ~dev-qt/qtgui-5.9.6 required by (dev-qt/designer-5.9.6:5/5.9::gentoo, installed)
    ^             ^^^^^                                                             
    ~dev-qt/qtgui-5.9.6[gles2=] required by (dev-qt/qtmultimedia-5.9.6:5/5.9::gentoo, installed)
    ^             ^^^^^                                                                         

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtwidgets-5.9.6-r1:5/5.9::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.9.6 required by (dev-qt/qtscript-5.9.6:5/5.9::gentoo, installed)
    ^                 ^^^^^                                                             
    ~dev-qt/qtwidgets-5.9.6[gles2=] required by (dev-qt/qtprintsupport-5.9.6:5/5.9::gentoo, installed)
    ^                 ^^^^^                                                                           
    ~dev-qt/qtwidgets-5.9.6[gles2=] required by (dev-qt/qtmultimedia-5.9.6:5/5.9::gentoo, installed)
    ^                 ^^^^^                                                                         
    ~dev-qt/qtwidgets-5.9.6 required by (dev-qt/qtquickcontrols2-5.9.6:5/5.9::gentoo, installed)
    ^                 ^^^^^                                                                     
    ~dev-qt/qtwidgets-5.9.6[gles2=] required by (dev-qt/qtopengl-5.9.6:5/5.9::gentoo, installed)
    ^                 ^^^^^                                                                     
    ~dev-qt/qtwidgets-5.9.6 required by (dev-qt/qtquickcontrols-5.9.6:5/5.9::gentoo, installed)
    ^                 ^^^^^                                                                     
    ~dev-qt/qtwidgets-5.9.6 required by (dev-qt/qtsvg-5.9.6:5/5.9::gentoo, installed)
    ^                 ^^^^^                                                           
    ~dev-qt/qtwidgets-5.9.6[gles2=] required by (dev-qt/qtdeclarative-5.9.6:5/5.9::gentoo, installed)
    ^                 ^^^^^                                                                           
    ~dev-qt/qtwidgets-5.9.6 required by (dev-qt/designer-5.9.6:5/5.9::gentoo, installed)
    ^                 ^^^^^                                                             

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.11.1 required by (dev-qt/qtgui-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^                                                                             

  (dev-qt/qtdbus-5.9.6:5/5.9::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.9.6 required by (dev-qt/qtgui-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                           
    ~dev-qt/qtdbus-5.9.6 required by (dev-qt/qdbus-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                           
    ~dev-qt/qtdbus-5.9.6 required by (dev-qt/qtsensors-5.9.6:5/5.9::gentoo, installed)
    ^              ^^^^^                                                               


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
 


Last edited by HL521 on Thu Sep 06, 2018 1:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Thu Sep 06, 2018 5:29 am    Post subject: Reply with quote

Please show your emerge command. Qt-5.11.1 is unmasked *completely*?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21346
Location: here

PostPosted: Thu Sep 06, 2018 5:39 am    Post subject: Reply with quote

asturm wrote:
Qt-5.11.1 is unmasked *completely*?

You can add dev-qt/*:5 entry in package.accept_keywords
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
HL521
n00b
n00b


Joined: 07 Jul 2013
Posts: 12

PostPosted: Thu Sep 06, 2018 11:03 am    Post subject: Reply with quote

asturm wrote:
Please show your emerge command. Qt-5.11.1 is unmasked *completely*?


I was running:
Code:
sudo emerge -avuDN --verbose-conflicts @world
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21346
Location: here

PostPosted: Thu Sep 06, 2018 11:46 am    Post subject: Reply with quote

And what you write in package.accept_keywords for unmask all qt library?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
HL521
n00b
n00b


Joined: 07 Jul 2013
Posts: 12

PostPosted: Thu Sep 06, 2018 12:20 pm    Post subject: Reply with quote

fedeliallalinea wrote:
And what you write in package.accept_keywords for unmask all qt library?


Before, I put the various qt 5.11.1 packages in, as well as masking the qt 5.9.6 packages, however that didn't work so I removed both. Unmasking all of them sounds like it would pull all incoming packages that are not in the stable release channel
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21346
Location: here

PostPosted: Thu Sep 06, 2018 12:26 pm    Post subject: Reply with quote

HL521 wrote:
Before, I put the various qt 5.11.1 packages in, as well as masking the qt 5.9.6 packages, however that didn't work so I removed both. Unmasking all of them sounds like it would pull all incoming packages that are not in the stable release channel

If you want unmask all qt package put dev-qt/*:5 in package.accept_keywords. You can't mix qt version
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
HL521
n00b
n00b


Joined: 07 Jul 2013
Posts: 12

PostPosted: Thu Sep 06, 2018 1:18 pm    Post subject: Reply with quote

fedeliallalinea wrote:
HL521 wrote:
Before, I put the various qt 5.11.1 packages in, as well as masking the qt 5.9.6 packages, however that didn't work so I removed both. Unmasking all of them sounds like it would pull all incoming packages that are not in the stable release channel

If you want unmask all qt package put dev-qt/*:5 in package.accept_keywords. You can't mix qt version


Yeah that fixed the issue!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum