Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mate update -Inexistant Package x11-proto [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Sun Sep 02, 2018 8:26 am    Post subject: Mate update -Inexistant Package x11-proto [Solved] Reply with quote

Hello,

In desperation, I post here the problem that i encounter

At the beginning, I wanted upgrade ma desktop mate version 1.12 to a more recent version.
So I install the overlay gentoo-mate with the command layman

When I launch the command
Code:
#emerge --ask mate
or
#emerge --ask --update --deep --with-bdeps=y --newuse @world


The pretendant mate-desktop jump from 1.12 to 1.18 (fine, I thought) but I get this message that I cannot solve :
Code:
# emerge --ask --update --deep --with-bdeps=y --newuse @world
[...]
emerge: there are no ebuilds to satisfy ">=x11-proto/randrproto-1.3:0".
(dependency required by "mate-base/mate-desktop-1.18.0::gentoo-mate" [ebuild])
(dependency required by "mate-extra/caja-extensions-1.18.2::gentoo-mate[open-terminal]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
#

Sometime the result change to :
Code:
emerge: there are no ebuilds to satisfy ">=x11-proto/rextproto.

As I have read in threads that randrproto move to x11-base I tried with no more luck :
Code:
# emerge --ask x11-base/randrproto
These are the packages that would be merged, in order:
Calculating dependencies... done!
emerge: there are no ebuilds to satisfy "x11-base/randrproto"


reading bugs reports here : https://bugs.gentoo.org/657822 and there : https://bugs.gentoo.org/656250 doesn' help me.

Emerge info is here :

Code:
# wgetpaste -s bpaste -c 'emerge --info'
Your paste can be seen here: http://bpaste.net/show/76911cf761cb
 


What I have Missed ? thanks,


Last edited by sitro on Sun Sep 02, 2018 3:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21362
Location: here

PostPosted: Sun Sep 02, 2018 9:25 am    Post subject: Re: Mate update -Inexistant Package x11-proto Reply with quote

sitro wrote:
What I have Missed ? thanks,

Nothing but the ebuilds from gentoo-mate are outdated.
Gentoo have moved all x11-proto/* packages in x11-base/xorg-proto, but the gentoo-mate overlay haven't changed ebuilds.

gentoo-mate mate-desktop-1.18.0.ebuild:
DEPEND="${COMMON_DEPEND}
   app-text/docbook-xml-dtd:4.1.2
   dev-util/gtk-doc
   dev-util/gtk-doc-am
   >=dev-util/intltool-0.40:*
   sys-devel/gettext:*
   >=x11-proto/randrproto-1.3:0  <--- wrong
   x11-proto/xproto:0            <--- wrong
   virtual/pkgconfig:*"


official gentoo mate-desktop-1.18.0.ebuild:
DEPEND="${COMMON_DEPEND}
        app-text/docbook-xml-dtd:4.1.2
        dev-util/gtk-doc
        dev-util/gtk-doc-am
        >=dev-util/intltool-0.40:*
        sys-devel/gettext:*
        virtual/pkgconfig:*
        x11-base/xorg-proto"   <--- correct

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Sun Sep 02, 2018 9:38 am    Post subject: Re: Mate update -Inexistant Package x11-proto Reply with quote

hello,

fedeliallalinea wrote:
sitro wrote:
What I have Missed ? thanks,

Nothing but the ebuilds from gentoo-mate are outdated.
Gentoo have moved all x11-proto/* packages in x11-base/xorg-proto, but the gentoo-mate overlay haven't changed ebuilds.


ok thank you , i understand now, but one more question :
How I migrate from gentoo-mate overlay to the official overlay (which one ?) to have gentoo mate-desktop-1.18.0.ebuild ?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6831
Location: Austria

PostPosted: Sun Sep 02, 2018 9:41 am    Post subject: Reply with quote

Code:
$ eshowkw mate-desktop
Keywords for mate-base/mate-desktop:
          |                           a     |       | 
          |                           m     |       | 
          |                           d   x |       | 
          |                           6   8 |       | 
          |                           4   6 |   u   | 
          | a a   a     p           s |   | |   n   | 
          | l m   r i   p   h m s   p f m f | e u s | r
          | p d a m a p c x p 6 3   a b i b | a s l | e
          | h 6 r 6 6 p 6 8 p 8 9 s r s p s | p e o | p
          | a 4 m 4 4 c 4 6 a k 0 h c d s d | i d t | o
----------+---------------------------------+-------+-------
1.12.1-r2 | o + ~ o o o o + o o o o o o o o | 6 o 0 | gentoo
1.14.1    | o ~ ~ o o o o ~ o o o o o o o o | 6 #   | gentoo
1.16.2    | o ~ ~ o o o o ~ o o o o o o o o | 6 #   | gentoo
1.18.0    | o ~ ~ ~ o o o ~ o o o o o o o o | 6 o   | gentoo


It appears to be in the tree, so simply drop the overlay. If the emerge conflict persists, rebuild those packages previously built from the overlay using `emerge --newrepo`.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42596
Location: 56N 3W

PostPosted: Sun Sep 02, 2018 10:10 am    Post subject: Reply with quote

sitro,

Mate-1.18 works well on arm64, amd64 and x86.

There is an overlay with Mate-1.20 too, which is what I'm using today.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Sun Sep 02, 2018 10:55 am    Post subject: Reply with quote

too much cool.
I didn't know the command eshowkw, very pretty!

So it's done.

I remove the overlay mate-gentoo

Code:
#layman -d gentoo-mate


emerge the new version of mate (i had to unmerge some blocked packages)

Code:
# emerge --ask =mate-base/mate-1.18


Now, suppose I should want the version 1.20 or testing version, which official overlay I have to get ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21362
Location: here

PostPosted: Sun Sep 02, 2018 11:46 am    Post subject: Reply with quote

sitro wrote:
Now, suppose I should want the version 1.20 or testing version, which official overlay I have to get ?

The only official repo is gentoo tree. There is also gentoo-mate (used by mate developers and used previously by you) but as you see it has some problems.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Sun Sep 02, 2018 12:40 pm    Post subject: Reply with quote

hi NeddySeagoon
NeddySeagoon wrote:

There is an overlay with Mate-1.20 too, which is what I'm using today.


surprising
Which one ? because I tried again to add the gentoo-mate overlay.
Code:
# eshowkw --overlay mate
Keywords for mate-base/mate:
           |                           a     |       | 
           |                           m     |       | 
           |                           d   x |       | 
           |                           6   8 |       | 
           |                           4   6 |   u   | 
           | a a   a     p           s |   | |   n   | 
           | l m   r i   p   h m s   p f m f | e u s | r
           | p d a m a p c x p 6 3   a b i b | a s l | e
           | h 6 r 6 6 p 6 8 p 8 9 s r s p s | p e o | p
           | a 4 m 4 4 c 4 6 a k 0 h c d s d | i d t | o
-----------+---------------------------------+-------+------------
   1.12-r1 | o + ~ o o o o + o o o o o o o o | 6 # 0 | gentoo     
   1.12-r1 | o + ~ o o o o + o o o o o o o o | 6 o   | gentoo-mate
   1.14    | o ~ ~ o o o o ~ o o o o o o o o | 6 #   | gentoo     
   1.14    | o ~ ~ o o o o ~ o o o o o o o o | 6 #   | gentoo-mate
   1.16    | o ~ ~ o o o o ~ o o o o o o o o | 6 #   | gentoo     
   1.16    | o ~ ~ o o o o ~ o o o o o o o o | 6 #   | gentoo-mate
[I]1.18    | o ~ ~ ~ o o o ~ o o o o o o o o | 6 #   | gentoo     
   1.18    | o ~ ~ ~ o o o ~ o o o o o o o o | 6 o   | gentoo-mate
   9999    | o o o o o o o o o o o o o o o o | 6 o   | gentoo-mate


according to the eshowkw the only version over 1.18 is a testing version

or
Code:
# emerge --ask =mate-base/mate-1.20

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=mate-base/mate-1.20".


I guess that mate-9999 should install netherless the ebuilds are not right as said fedeliallalinea in the previous posts
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5802

PostPosted: Sun Sep 02, 2018 2:56 pm    Post subject: Reply with quote

I believe that would be my overlay, see link in signature. 8)
_________________
overlay | patches
Neddyseagoon wrote:
The problem with leaving is that you can only do it once and it reduces your influence.
Back to top
View user's profile Send private message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Sun Sep 02, 2018 3:34 pm    Post subject: Reply with quote

bunder wrote:
I believe that would be my overlay, see link in signature. 8)


ok, i will see later to add your overlay when i shall be more experienced in gentoo :lol:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum