Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installed new nvidia card, now GDM does not appear
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
MALDATA
n00b
n00b


Joined: 07 Apr 2011
Posts: 41

PostPosted: Sat Oct 13, 2018 9:10 pm    Post subject: Installed new nvidia card, now GDM does not appear Reply with quote

Hi all,

I had an old video card in my machine. It was a nvidia card that was about 10 years old, so I had to use the older nvidia drivers, and I simply masked out anything >x11-drivers/nvidia-drivers-341. I finally got a new one (GTX 1070), and ran into some problems after replacing the old one.

After I replaced the hardware and booted up the machine, I assumed that there would be trouble with the older driver. So, I booted into recovery mode, removed that line from package.mask, and emerged the newest version, 410.57. It emerged fine, and I rebooted. Now, the machine seems to boot OK, but GDM never appears. It seems to be running. I can log in via SSH with X forwarding from a remote machine, so I know X is running. lsmod reports that nvidia, nvidia_drm, and nvidia_modeset modules are all inserted. Also, systemctl reports that GDM is active. So, it seems like the driver, X, and GDM are all fine. However, I never see GDM. I just get a black screen. I can switch to another tty and log in, but I can't log in to a graphical session.

I'm not quite sure where to go with this. I've done some googling, and it has turned up a lot of stuff like this:
https://askubuntu.com/questions/826622/booting-problem-ubuntu-gnome-16-04-01-lts
https://devtalk.nvidia.com/default/topic/1033110/linux/unable-to-start-xorg-gdm-on-ubuntu-18-04-with-nvidia-drivers-on-1060-gtx/2

None of that seems to help. I re-emerged xorg-server, I removed my old /etc/X11/xorg.conf file, and so on. Still, same result.

If you have any thoughts, I'd appreciate it. Thanks!
Back to top
View user's profile Send private message
MALDATA
n00b
n00b


Joined: 07 Apr 2011
Posts: 41

PostPosted: Sat Oct 13, 2018 9:27 pm    Post subject: Reply with quote

Quick follow-up: the nvidia web site shows the 390-series driver as the right one for the GTX 1070. I unmerged the 410 version and masked out anything greater than 390. Same behavior.
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2539
Location: Canada

PostPosted: Sun Oct 14, 2018 12:42 am    Post subject: Reply with quote

Can you avoid launching GDM and just start X with 'startx' from one of the consoles ?

Also, what does /var/log/Xorg.0.log contain after the start ?
Back to top
View user's profile Send private message
dspahn
Guru
Guru


Joined: 22 Jun 2006
Posts: 360

PostPosted: Sun Oct 14, 2018 3:39 am    Post subject: Optimus Issue? Reply with quote

You should check for the presence of an Intel display device- this could indicate Optimus, which requires adding intel kms support to your kernel. I am puzzling through a similar issue right now... watch my other thread on this for updates if you don't solve this first! it's under Desktop Environments.
Back to top
View user's profile Send private message
jburns
Veteran
Veteran


Joined: 18 Jan 2007
Posts: 1059
Location: Massachusetts USA

PostPosted: Sun Oct 14, 2018 3:45 am    Post subject: Reply with quote

The problem could with the kernel configuration and the USE flags for nvidia-drivers. The new nvidia-drivers have more compatibility problems with the kernel console drivers.
Back to top
View user's profile Send private message
MALDATA
n00b
n00b


Joined: 07 Apr 2011
Posts: 41

PostPosted: Sun Oct 14, 2018 4:35 am    Post subject: Reply with quote

Quote:
Can you avoid launching GDM and just start X with 'startx' from one of the consoles ?


Yes, this does work. I stopped the gdm daemon and used startx to get a gnome session open. Then I was able to run nvidia-settings, and after a reboot, GDM started correctly.

I don't know what changed, so this isn't a very satisfying solution. But... it seems to be working, so I guess I'm all set. Thanks for chiming in, I appreciate it!
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2539
Location: Canada

PostPosted: Sun Oct 14, 2018 4:32 pm    Post subject: Reply with quote

MALDATA wrote:
Quote:
Can you avoid launching GDM and just start X with 'startx' from one of the consoles ?


Yes, this does work. I stopped the gdm daemon and used startx to get a gnome session open. Then I was able to run nvidia-settings, and after a reboot, GDM started correctly.

I don't know what changed, so this isn't a very satisfying solution. But... it seems to be working, so I guess I'm all set. Thanks for chiming in, I appreciate it!


What did you do in nvidia-settings ?
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2539
Location: Canada

PostPosted: Sun Oct 14, 2018 4:37 pm    Post subject: Reply with quote

MALDATA wrote:
Quote:
Can you avoid launching GDM and just start X with 'startx' from one of the consoles ?


Yes, this does work. I stopped the gdm daemon and used startx to get a gnome session open. Then I was able to run nvidia-settings, and after a reboot, GDM started correctly.

I don't know what changed, so this isn't a very satisfying solution. But... it seems to be working, so I guess I'm all set. Thanks for chiming in, I appreciate it!



So it seems it was GDM issue, rather than nvidia-drivers. I do not know much about GDM under systemd, but, for example, using SDDM and elogind I had once symptoms like
that when SDDM could not get some permissions in time to launch the greeter.

You should look in GDM log files (maybe old ones are preserved) to see where it was hanging. Again, I do not know systemd to advise where are the log files.
Back to top
View user's profile Send private message
chrisyu
Apprentice
Apprentice


Joined: 10 Apr 2003
Posts: 206
Location: China

PostPosted: Tue Oct 16, 2018 5:45 am    Post subject: Reply with quote

It's a bug, don't know gdm or nvidia-drivers.

You can use nvidia-drivers-384.130, this works fine with me.
Or switch to lightdm, avoid gdm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum