Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Font issues becoming excessively annoying
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 516
Location: Cape Town, South Africa

PostPosted: Wed Aug 29, 2018 7:12 pm    Post subject: Font issues becoming excessively annoying Reply with quote

hi

Further to https://forums.gentoo.org/viewtopic-t-1085574.html , where the offered solutions did not work.

My fonts are borked in some way. Eg in Firefox, some text is displayed in Times Roman when I know it should be sans.

Just updated blender, and got this at the end:

Code:

Error in file "usr/share/applications/org.kde.kfontview.desktop": "font/otf" is an invalid MIME type ("font" is an unregistered media type)
Error in file "usr/share/applications/org.kde.kfontview.desktop": "font/ttf" is an invalid MIME type ("font" is an unregistered media type)
 * QA Notice: .desktop files with MimeType= were found installed
 * but desktop mimeinfo cache has not been updated:
 *   /usr/share/applications/blender.desktop
 * Please make sure to call xdg_desktop_database_update()
 * in pkg_postinst() and pkg_postrm() phases of appropriate pkgs.
>>> media-gfx/blender-2.79b-r1 merged.
>>> Auto-cleaning packages...


And for example, trying to start Telegram does not start it, it ends up doing nothing but using 12% CPU.

Starting from command line produces this:

Code:

~ $ /home/ian/downloads/soft/Telegram/Telegram -- %u
Fontconfig warning: line 5: unknown element "its:rules"
Fontconfig warning: line 6: unknown element "its:translateRule"
Fontconfig error: line 6: invalid attribute 'translate'
Fontconfig error: line 6: invalid attribute 'selector'
Fontconfig error: line 7: invalid attribute 'xmlns:its'
Fontconfig error: line 7: invalid attribute 'version'
Fontconfig warning: line 9: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/10-hinting-slight.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/10-hinting-slight.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/10-hinting-slight.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/10-hinting-slight.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/10-hinting-slight.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/10-hinting-slight.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/10-hinting-slight.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/45-generic.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/45-generic.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/45-generic.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/45-generic.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/45-generic.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/45-generic.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/45-generic.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/60-generic.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/60-generic.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/60-generic.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/60-generic.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/60-generic.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/60-generic.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/60-generic.conf", line 8: unknown element "description"
Fontconfig error: Cannot load default config file
^C


I have no idea WHAT is broken, thus no idea where to start with a solution... any ideas gratefully received :-)

Thanks, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
freifunk_connewitz
Apprentice
Apprentice


Joined: 08 Feb 2006
Posts: 181

PostPosted: Wed Aug 29, 2018 8:08 pm    Post subject: Reply with quote

probably related, since it appeared after a fontconfig update to 2.13.0-r4:

https://forums.gentoo.org/viewtopic-t-1085500-highlight-fontconfig.html
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 516
Location: Cape Town, South Africa

PostPosted: Wed Aug 29, 2018 10:21 pm    Post subject: Reply with quote

I tried downgrading fontconfig but that created issues for hundreds of other packages so re-emerged the current version instead.

Fonts in Firefox now appear normal.

Telegram still refuses to start.

After the install, emerge printed all this, which is not reassuring. So dunno if there's still something I need to fix or what ...

Code:

* QA Notice: This ebuild installs into paths that should be created at runtime.
 *  To fix, simply do not install into these directories.  Instead, your package
 *  should create dirs on the fly at runtime as needed via init scripts/etc...
 *
 *   var/cache
 *   var/cache/fontconfig
 * One or more empty directories installed to /var:
 *
 *   /var/cache/fontconfig
 *
 * If those directories need to be preserved, please make sure to create
 * or mark them for keeping using 'keepdir'. Future versions of Portage
 * will strip empty directories from installation image.
strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment -R .GCC.command.line -R .note.gnu.gold-version
   usr/bin/i686-pc-linux-gnu-fc-cache
   usr/lib32/libfontconfig.so.1.11.1
   usr/bin/fc-cat
   usr/bin/fc-conflist
   usr/bin/fc-list
   usr/bin/fc-match
   usr/bin/fc-pattern
   usr/bin/fc-query
   usr/bin/fc-scan
   usr/bin/fc-validate
   usr/bin/x86_64-pc-linux-gnu-fc-cache
   usr/lib64/libfontconfig.so.1.11.1
ecompressdir: bzip2 -9 /usr/share/doc
ecompressdir: bzip2 -9 /usr/share/man

>>> Installing (1 of 1) media-libs/fontconfig-2.13.0-r4::gentoo
 * Syncing fontconfig configuration to system ...                                                                                                                                                                                                                                                                     [ !! ]
 * Cleaning broken symlinks in /etc/fonts/conf.d/
 * Please make fontconfig configuration changes using `eselect
 * fontconfig`. Any changes made to /etc/fonts/fonts.conf will be
 * overwritten. If you need to reset your configuration to upstream
 * defaults, delete the directory /etc/fonts/conf.d/ and re-emerge
 * fontconfig.
 *
 * (Note: Above message is only printed the first time package is
 * installed. Please look at /usr/share/doc/fontconfig-2.13.0-r4/README.gentoo*
 * for future reference)
 * abi_x86_32.x86: running multilib_pkg_postinst
 * Creating global font cache for x86 ...
Fontconfig error: failed reading config file
Fontconfig error: Cannot load config file "infinality/conf.d"                                                                                                                                                                                                                                                         [ ok ]
 * abi_x86_64.amd64: running multilib_pkg_postinst
 * Creating global font cache for amd64 ...
Fontconfig error: failed reading config file
Fontconfig error: Cannot load config file "infinality/conf.d"                                                                                                                                                                                                                                                         [ ok ]

>>> Recording media-libs/fontconfig in "world" favorites file...
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.


Thanks, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 516
Location: Cape Town, South Africa

PostPosted: Wed Aug 29, 2018 10:35 pm    Post subject: Reply with quote

different distro, different packages, same problem:

https://github.com/voidlinux/void-packages/issues/14161

weird.

More:

https://bugs.freedesktop.org/show_bug.cgi?id=105818
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 516
Location: Cape Town, South Africa

PostPosted: Wed Aug 29, 2018 10:44 pm    Post subject: Reply with quote

Could this possibly be related to locale issues?
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3699
Location: Dallas area

PostPosted: Wed Aug 29, 2018 11:00 pm    Post subject: Reply with quote

I've not had any problems show up after the upgrade of fontconfig (I don't use opera, just firefox and palemoon)
and all the apps I use don't have a problem, including urxvt. I don't use infinality(sp?) fonts at all.

I did fix the (to my mind) weird things left in /etc/fonts/conf.d, ie lots of files starting with ._c*
which in my opinion shouldn't have been there as everything in that directory is a symbolic link, not a real file, they're in confs.avail
(I just deleted them as the symbolic links were fine).
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3699
Location: Dallas area

PostPosted: Wed Aug 29, 2018 11:08 pm    Post subject: Reply with quote

iandoug wrote:
After the install, emerge printed all this, which is not reassuring. So dunno if there's still something I need to fix or what ...


It should have told you to run etc-update at the end of the ebuild session.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1599
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Thu Aug 30, 2018 3:23 am    Post subject: Reply with quote

iandoug wrote:
I tried downgrading fontconfig but that created issues for hundreds of other packages so re-emerged the current version instead.



Do the downgrade again but use the --noconfmem option. After in downgrades run etc-update or dispatch-conf and use the new configs, there should be 17 or 18 files changed. If you upgrade after this, again use the --noconfmem option, but this time DO NOT use the new configs, zap them (dispatch-conf) or whatever that option is with etc-update. The changes to /etc/fonts files added things like this which is in the fonts.conf file and cause errors.

Code:

    <its:rules xmlns:its="http://www.w3.org/2005/11/its" version="1.0">
                <its:translateRule translate="no" selector="/fontconfig/*[not(self::description)]"/>
        </its:rules>

        <description>Default configuration file</description>



Code:

Fontconfig warning: "/etc/fonts/fonts.conf", line 5: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/fonts.conf", line 6: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/fonts.conf", line 6: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/fonts.conf", line 6: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/fonts.conf", line 7: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/fonts.conf", line 7: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/fonts.conf", line 9: unknown element "description"
Fontconfig error: Cannot load config file from /etc/fonts/fonts.conf

_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 516
Location: Cape Town, South Africa

PostPosted: Thu Aug 30, 2018 5:27 am    Post subject: Reply with quote

firephoto wrote:
iandoug wrote:
I tried downgrading fontconfig but that created issues for hundreds of other packages so re-emerged the current version instead.



Do the downgrade again but use the --noconfmem option. After in downgrades run etc-update or dispatch-conf and use the new configs, there should be 17 or 18 files changed. If you upgrade after this, again use the --noconfmem option, but this time DO NOT use the new configs, zap them (dispatch-conf) or whatever that option is with etc-update. The changes to /etc/fonts files added things like this which is in the fonts.conf file and cause errors.


I should have been more explicit. I masked the current version, uninstalled it, then tried to emerge world, at which point I think something like 123 packages had conflicts because they wanted the new version.
So at that point I re-installed the new version again.

Should there not be an updated ebuild to sort this out?

Thanks, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3699
Location: Dallas area

PostPosted: Thu Aug 30, 2018 10:16 am    Post subject: Reply with quote

firephoto wrote:
iandoug wrote:
I tried downgrading fontconfig but that created issues for hundreds of other packages so re-emerged the current version instead.



Do the downgrade again but use the --noconfmem option. After in downgrades run etc-update or dispatch-conf and use the new configs, there should be 17 or 18 files changed. If you upgrade after this, again use the --noconfmem option, but this time DO NOT use the new configs, zap them (dispatch-conf) or whatever that option is with etc-update. The changes to /etc/fonts files added things like this which is in the fonts.conf file and cause errors.

Code:

    <its:rules xmlns:its="http://www.w3.org/2005/11/its" version="1.0">
                <its:translateRule translate="no" selector="/fontconfig/*[not(self::description)]"/>
        </its:rules>

        <description>Default configuration file</description>



Code:

Fontconfig warning: "/etc/fonts/fonts.conf", line 5: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/fonts.conf", line 6: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/fonts.conf", line 6: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/fonts.conf", line 6: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/fonts.conf", line 7: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/fonts.conf", line 7: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/fonts.conf", line 9: unknown element "description"
Fontconfig error: Cannot load config file from /etc/fonts/fonts.conf


I didn't mess with --noconfmem, I do have the fonts.conf with the "its" stuff and my system still works fine.
Every file that came with fontconfig, that's in conf.avail has an "its" portion. And again all my stuff works fine.
It's something else other than that.


ETA: 3 things that I have on my system
I got rid of the crud left in /etc/fonts/conf.d (that shouldn't have been there)
I have my own fonts.conf in ~/.config/fontconfig
and I modify xorg.conf to use the Files section for font path

I don't know if any of these actually made a difference, but I've had no problems with any of the fontconfig stuff
I'm also running a strictly 64 bit system, no multilib.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3699
Location: Dallas area

PostPosted: Thu Aug 30, 2018 10:51 am    Post subject: Reply with quote

For those having error reporting problems and not resolved, do this "ls -la /etc/fonts/conf.d" and post results


ETA: if you google the problem lots of different distros w/lots of different binaries affected by this but NO concrete reasons for any of it,
sometimes downgrading and re-upgrading fixes the problem, for things like wine, rebuilding the 32 bit libs/binaries seems to work, for others it's simply *shrug*

You should also be running x11-libs/pango-1.42.4 (it should have been a forced upgrade, was in my case)
and it should have been rebuilt AFTER fontconfig.

Though it shouldn't make a difference, anything that depends on pango/fontconfig might need to be rebuilt (might try any one package that's giving problems just to see)
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1599
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Thu Aug 30, 2018 3:34 pm    Post subject: Reply with quote

iandoug wrote:

I should have been more explicit. I masked the current version, uninstalled it, then tried to emerge world, at which point I think something like 123 packages had conflicts because they wanted the new version.
So at that point I re-installed the new version again.

Should there not be an updated ebuild to sort this out?

Thanks, Ian


My notes from my mask file said I had to unmerge fontconfig then remerge to downgrade.

This is the change upstream that broke everything.
https://cgit.freedesktop.org/fontconfig/commit/?id=9a0fcb948fe7346f6c68028b2e54ab600a2a2a6f

All those conf file changes.

Code:

+  <its:rules xmlns:its="http://www.w3.org/2005/11/its" version="1.0">
+    <its:translateRule translate="no" selector="/fontconfig/*[not(self::description)]"/>
+  </its:rules>
+
+  <description>Enable autohinter</description>


You could just remove that from every font conf file, and if the rest of your files are stock (unknown unless you use --noconfmem)
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3699
Location: Dallas area

PostPosted: Thu Aug 30, 2018 3:42 pm    Post subject: Reply with quote

and the next time you install fontconfig the its rules would be right back, best to fix the problem not try and bandaid it.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1599
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Thu Aug 30, 2018 3:46 pm    Post subject: Reply with quote

Anon-E-moose wrote:

I didn't mess with --noconfmem, I do have the fonts.conf with the "its" stuff and my system still works fine.
Every file that came with fontconfig, that's in conf.avail has an "its" portion. And again all my stuff works fine.
It's something else other than that.


ETA: 3 things that I have on my system
I got rid of the crud left in /etc/fonts/conf.d (that shouldn't have been there)
I have my own fonts.conf in ~/.config/fontconfig
and I modify xorg.conf to use the Files section for font path

I don't know if any of these actually made a difference, but I've had no problems with any of the fontconfig stuff
I'm also running a strictly 64 bit system, no multilib.


You have modified your fonts conf files, the system knows that, so you're never prompted to change those files from previously diff decision with etc-update or disp-conf... unless you use --noconfmem.

I literally had new fontconfig confs, changed to old fontconfig confs. problem solved. The errors I posted above were from chrome which has worked around it still functions despite the error but I changed those the other day too to get rid of that error.. changed as in commented out those exact lines I posted from the git commit.

https://bugs.gentoo.org/651556

Quote:

Jura 2018-08-21 12:18:25 UTC
Temporary fix:
Code:

emerge -av1 "=fontconfig-2.12.6"
mkdir /tmp/fc
cp -a /etc/fonts/* /tmp/fc
emerge -av1 fontconfig
cp -af /tmp/fc/* /etc/fonts


_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3699
Location: Dallas area

PostPosted: Thu Aug 30, 2018 3:48 pm    Post subject: Reply with quote

What version of gettext are you running? what does "emerge -pv gettext" return

Edit to add: the its: rules are simply the way forward
https://www.gnu.org/software/gettext/manual/html_node/Preparing-ITS-Rules.htm
I doubt they are going away.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon


Last edited by Anon-E-moose on Thu Aug 30, 2018 3:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3699
Location: Dallas area

PostPosted: Thu Aug 30, 2018 3:50 pm    Post subject: Reply with quote

using the pre fontconfig-13* is a bandaid and doesn't solve the problem except for the moment.
The next time fontconfig is emerged or reemerged the problem will be right back.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3699
Location: Dallas area

PostPosted: Thu Aug 30, 2018 3:52 pm    Post subject: Reply with quote

firephoto wrote:

You have modified your fonts conf files, the system knows that, so you're never prompted to change those files from previously diff decision with etc-update or disp-conf... unless you use --noconfmem.


I already stated earlier that I was prompted to do etc-update at the end of the ebuild and I didn't use --noconfmem, so there goes that theory.
What I did do and always do is go look at what files etc-update would change, and noticed that they were simply replacing one symbolic link with another.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1599
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Thu Aug 30, 2018 4:05 pm    Post subject: Reply with quote

Anon-E-moose wrote:
firephoto wrote:

You have modified your fonts conf files, the system knows that, so you're never prompted to change those files from previously diff decision with etc-update or disp-conf... unless you use --noconfmem.


I already stated earlier that I was prompted to do etc-update at the end of the ebuild and I didn't use --noconfmem, so there goes that theory.
What I did do and always do is go look at what files etc-update would change, and noticed that they were simply replacing one symbolic link with another.


Yes, your diff you are presented with is based on the previously diff'd and saved configuration so anything before you had changed is ignored and only uniquely new changes are shown.

But that doesn't matter, the point is the problem exists, there is a solution, it works without hurting the system and in the future when you update then again you can decide if you want to overwrite your fonts conf files while doing the administrative tasks required by your system you are updating. There is no "it's just all lost when you update", that's just mis-information.
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3699
Location: Dallas area

PostPosted: Thu Aug 30, 2018 4:09 pm    Post subject: Reply with quote

I think the problem is gettext, as that's what the its: stuff resolves to. That's why I asked what version people were running.
If you and others don't want to solve it but simply patch around it every time, that's ok too.


Quote:
There is no "it's just all lost when you update", that's just mis-information.


If you don't save the old version it will disappear. But as I said that a bandaid, not a solution.

Anyway, glad it works for you.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1599
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Thu Aug 30, 2018 4:21 pm    Post subject: Reply with quote

Anon-E-moose wrote:
I think the problem is gettext, as that's what the its: stuff resolves to. That's why I asked what version people were running.
If you and others don't want to solve it but simply patch around it every time, that's ok too.


Quote:
There is no "it's just all lost when you update", that's just mis-information.


If you don't save the old version it will disappear. But as I said that a bandaid, not a solution.

Anyway, glad it works for you.


That's not the case. I just "emerge fontconfig -va1" after I copied the /etc/fonts for safe keeping. Because I had previously --noconfmem (all my @world updates actually) it knew my actions from disp-conf so when it re-installed my previously diff'd changes where retained, all the commented sections of all the conf files for those 5 line changes were still there. --noconfmem allows you to diff to the default configurations then going forward retain any changes you saved from there as is expected. If your files are *not modified you just get the new conf files. I started doing this with updates because long ago changed things were being retained and breaking things and it takes only a few seconds to confirm to keep or discard configuration updates.
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3699
Location: Dallas area

PostPosted: Thu Aug 30, 2018 5:04 pm    Post subject: Reply with quote

There is a local directory for both the fonts.conf and conf.d/* (~/.config/fontconfig/fonts.conf and ~/.config/fontconfig/conf.d)

Code:
   $XDG_CONFIG_HOME/fontconfig/conf.d and ~/.fonts.conf.d is the
   conventional name for a per-user directory of (typically
   auto-generated) configuration files, although the actual
   location is specified in the global fonts.conf file. please
   note that ~/.fonts.conf.d is deprecated now. it will not be
   read by default in the future version.

   $XDG_CONFIG_HOME/fontconfig/fonts.conf and ~/.fonts.conf is the
   conventional location for per-user font configuration, although
   the actual location is specified in the global fonts.conf file.
   please note that ~/.fonts.conf is deprecated now. it will not
   be read by default in the future version.


One way not to have to keep messing with the system files, is disable everything except 50-user.conf (with eselect fontconfig) and copy all the files you want activated
into ~/.config/fontconfig/conf.d, ie untar fontconfig-2.12* to /tmp, go to /tmp/fontconfig*/conf.d and copy whatever you want to your local directory.

Edit to add: older conf files will work with the newer libs from fonconfig, etc --- for now
newer conf files won't work with older libs such as what's compiled in gentoo's version of telegram-bin (arch is supposed to have a newer version that does work with the newer conf files), the same problem holds with chromium, firefox or anything else not built from scratch with newer libs. If it's a program from the kde directories, rebuilding it should fix the problem.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 516
Location: Cape Town, South Africa

PostPosted: Fri Aug 31, 2018 5:54 am    Post subject: Reply with quote

Anon-E-moose wrote:
What version of gettext are you running? what does "emerge -pv gettext" return


Code:

[I] sys-devel/gettext
     Available versions:  0.19.8.1 {acl -cvs +cxx doc emacs git java ncurses nls openmp static-libs ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" ELIBC="FreeBSD"}
     Installed versions:  0.19.8.1(13:45:26 23/01/2018)(acl cxx git java ncurses nls openmp -cvs -doc -emacs -static-libs ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32" ELIBC="-FreeBSD")
     Homepage:            https://www.gnu.org/software/gettext/
     Description:         GNU locale utilities


Code:

trooper /home/ian # emerge -pv gettext

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-devel/gettext-0.19.8.1::gentoo  USE="acl cxx git java ncurses nls openmp -cvs -doc -emacs -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB


_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
freifunk_connewitz
Apprentice
Apprentice


Joined: 08 Feb 2006
Posts: 181

PostPosted: Tue Sep 04, 2018 6:54 pm    Post subject: Reply with quote

If you don't want to mess with your fontconfig files: I have a rather similar setup and problem since fontconfig-2.13.0-r4. My solution was to downgrade to media-libs/fontconfig-2.12.6 AND x11-libs/pango-1.40.14-r1 by manually installing the mentioned versions (and masking the newer ones).
Back to top
View user's profile Send private message
papu
Guru
Guru


Joined: 25 Jan 2008
Posts: 599
Location: Sota algun pi o alzina...

PostPosted: Sun Sep 16, 2018 7:03 pm    Post subject: Reply with quote

i have same problem with telegram binary it taks a lot to start 2 minutes.
then now i am using a compilated net-im/telegram-desktop from overlay, and it starts normally.

Code:
~ $ eix -I net-im/telegram-desktop
[I] net-im/telegram-desktop
     Available versions:  (~)0.8.50[5] (~)1.3.10[7] (~)1.3.12^p[4] (~)1.3.12^p[1] (~)1.3.13^p[4] (~)1.3.15[2] (~)1.3.15[6] (~)1.3.16^p[1] [b](~)1.3.16^p[3] [/b]**9999[4] **9999[7] **9999[1] **9999[2] **9999[3] **9999[6] {crash-report crashreporter custom-api-id debug gtk (+)gtk3 gtkstyle libressl (+)pulseaudio test +webp wide-baloons}
     Installed versions:  [b]1.3.16^p[1][/b](19:27:54 16/9/18)(gtk webp -test)
     Homepage:            https://desktop.telegram.org
     Description:         Official desktop client for Telegram

[1] "4nykey" /var/lib/layman/4nykey
[2] "mva" /var/lib/layman/mva
[b][3] "4nykey" layman/4nykey[/b]
[4] "bright" layman/bright
[5] "gentoo-zh" layman/gentoo-zh
[6] "mva" layman/mva
[7] "reagentoo" layman/reagentoo



[Moderator edit: changed [color=orange] tags to [code] tags to preserve output layout and make the text readable. -Hu]
_________________
--Intel i5 6600 --GA-Z170-HD3P --Ripjaws V 2x8 2400 --Radeon RX 470 G1 4G --Gentoo & Windows
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum