Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't add a route, net.enp0s31f6 starts fine
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Wizumwalt
Guru
Guru


Joined: 20 Aug 2006
Posts: 452

PostPosted: Sat Aug 25, 2018 6:20 pm    Post subject: Can't add a route, net.enp0s31f6 starts fine Reply with quote

Just did a new install and my ethernet interface appears to start fine. I've filled out /etc/resolv.conf and /etc/conf.d/net. However, I can't ping my gateway.

I've noticed when I give the route command, it just hangs and there are no routes listed.

Did I forget to enable a specific module somewhere's?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41413
Location: 56N 3W

PostPosted: Sat Aug 25, 2018 6:38 pm    Post subject: Reply with quote

Wizumwalt,

Move /etc/conf.d/net and /etc/resolv.conf out of the way.
Run
Code:
/etc/init.d/net.enp0s31f6 restart


That should get an automatic setup from your dhcp server in your router.
Unless you deliberately turned off the dhcp server.

As long as your ip address does not start 169.254. it looks promising.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Wizumwalt
Guru
Guru


Joined: 20 Aug 2006
Posts: 452

PostPosted: Sat Aug 25, 2018 6:57 pm    Post subject: Reply with quote

And here's the result of that.

Code:
$ /etc/init.d/net.enp0s31f6 restart
* Caching service dependencies
* config_enp0s3f6 not specified; defaulting to DHCP
RTNETLINK answers: No such file or directory
Error talking to the kernel
* Bringing up interface enp0s31f6
*   config_enp0s31f6 not specified; defaulting to DHCP
*   dhcp ...
*      Running udhcpc ...
udhcpc: started, v1.29.0
udhcpc: sending discover
udhcpc: sending discover
udhcpc: sending discover
udhcpc: no lease, failing
*   start-stop-daemon: failed to start `/bin/busybox`
* ERROR: net.enp0s31f6 failed to start


Thoughts?


Update:
Note that if I leave resolv.conf and conf.d/net filled out to my normal values, the interface does get the values listed in conf.d/net and shows no errors.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41413
Location: 56N 3W

PostPosted: Sat Aug 25, 2018 7:14 pm    Post subject: Reply with quote

Wizumwalt,

What does dmesg say about enp0s31f6 ?

That looks like networking on USB. Do you have firmware missing?
It would be good to see all of dmesg on a pastebin after the interface has failed to start.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Wizumwalt
Guru
Guru


Joined: 20 Aug 2006
Posts: 452

PostPosted: Sat Aug 25, 2018 7:26 pm    Post subject: Reply with quote

When I zero out resolv.conf and net, then do a restart, the only new entry in dmesg is ...

Code:
[ 5123.21341242] e1000e: enp0s31f6 NIC Link is Down
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41413
Location: 56N 3W

PostPosted: Sat Aug 25, 2018 8:37 pm    Post subject: Reply with quote

Wizumwalt,

Link is Down means that there is no detected electrical connection to the other end of the link.
Do you have several interfaces and have the cable connected to the wrong one?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Wizumwalt
Guru
Guru


Joined: 20 Aug 2006
Posts: 452

PostPosted: Sat Aug 25, 2018 9:46 pm    Post subject: Reply with quote

Ugh, thanks. For some reason, I had to switch ports from what the systemrescuecd was working off of, and when it boots on it's own.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum