Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Virtualbox mouseclicks don't work in guest AND host
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
gorg86
Tux's lil' helper
Tux's lil' helper


Joined: 20 May 2011
Posts: 135

PostPosted: Fri Aug 24, 2018 7:22 am    Post subject: Virtualbox mouseclicks don't work in guest AND host Reply with quote

Hello,

This is a tough one you guys...
When I use Virtualbox sometimes mouse clicks don't get executed anymore, it doesn't work for the guest AND the host. When that happens I can still move the mouse around and still see the cursor, but when I move the mouse outside the VM window it still has the same sprite like the guest OS. I can still use my keyboard but it is trapped inside the VM. I have to shut down the guest with the keyboard only, after that the cursor sprite changes back and I can use it in the host like normal. A reboot doesn't work it has to be shut down. This happened with different linux, Windows XP and Windows 7 guests.

For testing purposes I installed different Windows and linux guests from scratch and I did not install the Virtualbox addons/drivers, it still happens. I tried changing chipset to ICH9 and pointing device to PS/2... no change, but I got the impression that it happens less often. De/activating mouse integration doesn't help either.
Apparently it is totally random, sometimes it happens after 5min sometimes after 1 hour maybe and sometimes not at all.
The problem started after I updated Virtualbox less than a year ago, I don't remember the exact version I think it started with v5.1.2 or maybe after that. At first this happened very rarely, but now I got this annoying bug way more often (I use the VM 3-4 days in a week).

I looked into the vbox logs, there were errors with loading/reading the kernel modules. I searched the interwebs found a solution (it was just some privilege thing). The errors are now gone but no changes in behaviour :(

I still do not know what exactly triggers it.

There was a guy in this forum who had a very similar problem, but he said his hardware was defective, after a repair everything worked fine for him. My hardware is OK though...

Installed Vbox packages:
app-emulation/virtualbox-5.2.18
app-emulation/virtualbox-additions-5.2.18
app-emulation/virtualbox-extpack-oracle-5.2.18.124319
app-emulation/virtualbox-modules-5.2.18

emerge --info:
https://pastebin.com/Hu9KCubD


Last edited by gorg86 on Mon Oct 08, 2018 3:42 am; edited 2 times in total
Back to top
View user's profile Send private message
theluckyone17
n00b
n00b


Joined: 03 Dec 2005
Posts: 52

PostPosted: Mon Aug 27, 2018 2:58 pm    Post subject: Reply with quote

For what it's worth, I've had this occur a few times in the past, but haven't been able to isolate a cause, rhyme or reason. Seems sporadic and random. I have been able to escape out of the host using the host key and open the Virtualbox Manager, and shut the guest (Win10) down from there. That restores the mouse behavior.
Back to top
View user's profile Send private message
gorg86
Tux's lil' helper
Tux's lil' helper


Joined: 20 May 2011
Posts: 135

PostPosted: Mon Aug 27, 2018 4:50 pm    Post subject: Reply with quote

Well at least I'm not alone. Do you still use Virtualbox? Is the problem still there?
Back to top
View user's profile Send private message
the_bard
n00b
n00b


Joined: 03 Dec 2002
Posts: 60
Location: Albany, NY

PostPosted: Tue Sep 04, 2018 2:14 pm    Post subject: Reply with quote

Still using Virtualbox, and the problem hasn't occurred in some time. Currently running version 5.2.14-r1 of virtualbox. If it occurs again, I'll report back.
Back to top
View user's profile Send private message
gorg86
Tux's lil' helper
Tux's lil' helper


Joined: 20 May 2011
Posts: 135

PostPosted: Mon Oct 01, 2018 1:33 pm    Post subject: Reply with quote

virtualbox-extpack-oracle was causing the problem

EDIT:
It happened again...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum