Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plymouth themes refuse to load for some reason
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 47

PostPosted: Thu Aug 23, 2018 5:39 pm    Post subject: Plymouth themes refuse to load for some reason Reply with quote

For some reason druing boot I'm only getting the default splash screen (3 dots and info on what's loading). I followed this guide https://wiki.gentoo.org/wiki/Plymouth

What I've done so far:

1. sudo su
2. emerge -q sys-boot/plymouth sys-boot/plymouth-openrc-plugin sys-kernel/genkernel-next
3. /etc/rc.conf
Code:
rc_interactive="NO"

4. /etc/genkernel.conf
Code:
PLYMOUTH="yes"
PLYMOUTH_THEME="darwin"

5. plymouth-set-default-theme darwin
6. genkernel --udev --install initramfs
Code:
* Gentoo Linux Genkernel; Version 68
* Running with options: --install --udev initramfs

* Using genkernel.conf from /etc/genkernel.conf
* Sourcing arch-specific config.sh from /usr/share/genkernel/arch/x86_64/config.sh ..
* Sourcing arch-specific modules_load from /usr/share/genkernel/arch/x86_64/modules_load ..

* Linux Kernel 4.14.61-gentoo for x86_64...
* .. with config file /usr/share/genkernel/arch/x86_64/kernel-config
* busybox: >> Using cache
* initramfs: >> Initializing...
*         >> Appending base_layout cpio data...
*         >> Appending udev cpio data...
Package systemd was not found in the pkg-config search path.
Perhaps you should add the directory containing `systemd.pc'
to the PKG_CONFIG_PATH environment variable
No package 'systemd' found
cp: cannot stat '/lib64/udev/rules.d/99-systemd.rules': No such file or directory
* cannot copy /lib64/udev/rules.d/99-systemd.rules from udev
cp: cannot stat '/lib64/udev/rules.d/71-seat.rules': No such file or directory
* cannot copy /lib64/udev/rules.d/71-seat.rules from udev
cp: cannot stat '/etc/modprobe.d/blacklist.conf': No such file or directory
* cannot copy /etc/modprobe.d/blacklist.conf from udev
cp: cannot stat '/network/99-default.link': No such file or directory
* cannot copy /network/99-default.link from udev
*         >> Appending auxilary cpio data...
*         >> Copying keymaps
*         >> Appending busybox cpio data...
*         >> Appending modules cpio data...
*         >> Appending blkid cpio data...
*         >> Skipping modprobed copy
*         >> Appending plymouth cpio data...
*   >> Installing plymouth [ using the darwin theme and plugin: "script" ]...
*         >> Appending drm cpio data...
*         >> Appending ld_so_conf cpio data...
* ldconfig: adding /sbin/ldconfig...
* ld.so.conf: adding /etc/ld.so.conf{.d/*,}...
cpio: lib64 not created: newer or same age version exists
cpio: lib64 not created: newer or same age version exists
cpio: lib64/ld-linux-x86-64.so.2 not created: newer or same age version exists
cpio: lib64/libblkid.so.1 not created: newer or same age version exists
cpio: lib64/libc.so.6 not created: newer or same age version exists
cpio: lib64/libuuid.so.1 not created: newer or same age version exists
cpio: lib64 not created: newer or same age version exists
cpio: lib64/ld-linux-x86-64.so.2 not created: newer or same age version exists
cpio: lib64/libc.so.6 not created: newer or same age version exists
cpio: lib64/libz.so.1 not created: newer or same age version exists
cpio: usr/lib64 not created: newer or same age version exists
*         >> Finalizing cpio...
*         >> Compressing cpio data (.gz)...

* WARNING... WARNING... WARNING...
* Additional kernel cmdline arguments that *may* be required to boot properly...
* With support for several ext* filesystems available, it may be needed to
* add "rootfstype=ext3" or "rootfstype=ext4" to the list of boot parameters.

* Do NOT report kernel bugs as genkernel bugs unless your bug
* is about the default genkernel configuration...
*
* Make sure you have the latest ~arch genkernel before reporting bugs.

7. /etc/default/grub
Code:
GRUB_TIMEOUT=0
GRUB_CMDLINE_LINUX_DEFAULT='net.ifnames=0 scsi_mod.use_blk_mq=1 splash quiet'
GRUB_GFXPAYLOAD_LINUX=keep


I tried a different theme (solar) as a test, and results were the same.

Can someone please help me with this? I believe I'm doing everything right, yet only the default theme works. :?

-- edit --
I've also disabled Bootup Logo in the kernel. I'm not sure what else to do in the kernel settings, because I'm using a very old GPU (Radeon x550). I'm guessing this is the reason it doesn't work.

-- edit --
I'm using gentoo-sources-4.14.61 ...
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 47

PostPosted: Fri Aug 24, 2018 11:41 pm    Post subject: Reply with quote

Okay, so I messed around some more, and looks like I didn't enable KMS for my radeon GPU (I guess), but the problem is that I can't really find it in gentoo-sources-4.14.61. I can't find 'Enable modesetting on radeon by default', and it's not under Device Drivers ---> Staging drivers ---> . :(
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3691
Location: Dallas area

PostPosted: Sat Aug 25, 2018 12:09 am    Post subject: Reply with quote

Device drivers -> Graphics support -> ATI Radeon also select DRM above it
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 47

PostPosted: Sat Aug 25, 2018 9:18 am    Post subject: Reply with quote

Wait, I've enabled that already, but only as a module. Now this makes sense and it's kinda dumb of me not noticing this. Because it's not built in and loaded later on, the splash doens't appear correctly as a result. The reason why I enabled it as a module is because otherwise my XFCE4 desktop environment wouldn't load (black screen no matter what). I figured out that enabling ATI Radeon as a module fixes this problem. Hmm, I'll try again I suppose, but looks like I won't be able to use a splash screen after all. :?
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3691
Location: Dallas area

PostPosted: Sat Aug 25, 2018 10:18 am    Post subject: Reply with quote

I use a splash screen, and the nouveau driver is a module. (I have radeon as a module too, but I only use it for pass through)

under device drivers -> graphics support -> console display driver support
I have vga text console, with framebuffer console support clicked on

under graphics -> Frame Buffer Devices,
I have enable video mode handling helpers clicked on.

under graphics -> Direct Rendering Manager,
I have Enable legacy fbdev support clicked on.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 47

PostPosted: Sat Aug 25, 2018 5:07 pm    Post subject: Reply with quote

Anon-E-moose wrote:
under device drivers -> graphics support -> console display driver support
I have vga text console, with framebuffer console support clicked on

Yeah, I had that enabled earlier.

Anon-E-moose wrote:
under graphics -> Frame Buffer Devices,
I have enable video mode handling helpers clicked on.

After installing xorg-server I had a warning message that the frame buffer should be disabled, so that's what I did. I tried enabling it just to see if plymouth would work correctly, but unfortunately it didn't work out. It just made the screen resolution very low...

Anon-E-moose wrote:
under graphics -> Direct Rendering Manager,
I have Enable legacy fbdev support clicked on.

Yeah, that was also enabled as well.

Basically, I have everything enabled like you have minus the frame buffer device (ATI Radeon under frame buffer settings).

I tried making ATI Radeon (under the graphics settings) built-in instead of as a module, but that didn't work out either. Plymouth would work the same way, and on top of that my desktop woudn't load. Oh well, looks like this is some kind of bug. I really don't think there's something wrong with my settings at this point. I should also point out that plymouth doesn't work during shutdown, although it says that plymouthd is being run.
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3691
Location: Dallas area

PostPosted: Sat Aug 25, 2018 5:18 pm    Post subject: Reply with quote

Radeon stuff is a work in progress, if it doesn't work now, it might in the near future.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 47

PostPosted: Sat Aug 25, 2018 5:40 pm    Post subject: Reply with quote

Oh, I see. Well, thank you very much for your time, man! :D
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3691
Location: Dallas area

PostPosted: Sat Aug 25, 2018 5:44 pm    Post subject: Reply with quote

https://wiki.debian.org/plymouth

there is a section

Code:
Configuration

Edit the file /etc/initramfs-tools/modules and add the modesetting for your graphics card:

For ATI:

# KMS
drm
radeon modeset=1

_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 47

PostPosted: Sat Aug 25, 2018 9:11 pm    Post subject: Reply with quote

I can't really find this initramfs-tool program on any of the available overlays.
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3691
Location: Dallas area

PostPosted: Sat Aug 25, 2018 9:21 pm    Post subject: Reply with quote

if you make an initramfs there should be a list of modules that go with it.

I'm not sure what it's called under gentoo as I don't use an initramfs.

It's a way of passing a parameter to the radeon module to tell it to set modesetting to 1 (I forget whether that turns it on or off).

if you don't use an initramfs then you would put it in a file under /etc/modprobe.d

Maybe someone that uses an initramfs can weigh in. Anyway, that's where there parameter would go.

Here's the link for gentoo initramfs stuff, might be somewhere in the links in it https://wiki.gentoo.org/wiki/Initramfs
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 47

PostPosted: Sat Aug 25, 2018 10:30 pm    Post subject: Reply with quote

So it's not set in the kernel at all now (4.14.xx)? I'll have to look into that then. I'll post later about my results.
I tried earlier to load my system without an initramfs, but I couldn't get it to work for some reason. The root file system wasn't being detected or something, I don't remember. Maybe I'll try that too, because I do like to optimize stuff as much as possible. :wink:
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3691
Location: Dallas area

PostPosted: Sat Aug 25, 2018 10:45 pm    Post subject: Reply with quote

If not using an initramfs then something like this

Code:
cat /etc/modprobe.d/options.conf
# radeon
options radeon modeset=1


Whether this will make a difference, I'm not sure.


Edit to add: this is if the radeon is set to be a module, if built-in, then I think you have to pass a command line parameter
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 47

PostPosted: Sun Aug 26, 2018 12:42 am    Post subject: Reply with quote

This is a bit confusing, because the wiki says I need to enable KMS, but settings like that don't seem to be available in linux 4.14.xx. :(
This would explain why there's no theme during boot with plymouth, which is a bummer.
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 47

PostPosted: Tue Aug 28, 2018 5:43 pm    Post subject: Reply with quote

Okay, so I messed around some more, because even if it's not going to work as intended, sometimes I still would like to learn more to understand how things work.

The reason I didn't have a splash screen is due to a bad kernel configuration, which I fixed. I went overboard with the optimization, and disabled options I shouldn't have with the CPU I'm using. Atm, I am messing around with old hardware to see what's the extent of Gentoo linux, and is it possible to use it comfortably with single-core CPUs. It's just something I want to see for myself.

Anyway, because of my bad config I couldn't even load the XFCE4 desktop. From what I learned it seems the Kernel Mode Setting is enabled by default with a chosen open source driver from what I can tell. I've lurked around the web, and there's a simple way to check this. CTRL+ALT+F1 , then CTRL+ALT+F7 , and if it switches back, then that means KMS works. Besides when I run statxfce4 the log says KMS is enabled. Anyway, that's one thing I couldn't figure out, because the wiki says KMS should be manually enabled in the kernel. The other problem I have is the framebuffer, and of course without it I only get a splash screen while initramfs is loading. When grub tries to load plymouth the screen just goes black, it flickers with a green color on top, then I can see the OpenRC log, and only then initramfs loads the splash screen properly. I believe something has to be enabled in the grub linux comand line (a module?), but I don't understand what should be done there, or rather what command should be added with my ATI Radeon driver. I tried enabling the radeon framebuffer again, but it doesn't work at all, and uvesafb (userland vesa framebuffer) is deprecated now, so that's useless too. I'm not even sure the framebuffer is needed, because the splash screen works fine, but only while initramfs is loading, and it also doesn't work when I shutdown he system.
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum