Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with intel integrated video and external TV.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1488
Location: San Jose, CA

PostPosted: Tue Aug 21, 2018 3:19 am    Post subject: Problem with intel integrated video and external TV. Reply with quote

I've got KDE plasma running on a table PC which is now a multimedia PC for my kids.

It is connected to an external monitor. X is configured to disable the tablet and enable the 1080p TV.

It works fine if I boot with the external monitor disconnected, I allow it to boot on the tablet display then after X initializes I plug in the external TV and it switches and works perfectly, but the system hard crashes if the external TV is connected during boot.

I'll come back and add the Xorg.log once I make the failure happen again...

Update: Here's a pastebin of dmesg just moments before the hang. I managed to switch to console and copy xorg.0.log and dmesg to the root path before the machine hung.

https://pastebin.com/raw/g5n2J90k

It looks like drm is having problems... I have to see what package that belongs to and see if an update to unstable is in order...
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Tue Aug 21, 2018 4:27 am    Post subject: Reply with quote

RayDude ...

I'm not really familiar with connecting TV's but I expect the framebuffer will expect to be informed which 'conn', and also 'res', and possibly other options ... see 'video' in: boot options.

HTH & best ... khay
Back to top
View user's profile Send private message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1488
Location: San Jose, CA

PostPosted: Tue Aug 21, 2018 4:36 am    Post subject: Reply with quote

This looks like the same problem and there's no solution yet...

https://bugs.freedesktop.org/show_bug.cgi?id=105811
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1488
Location: San Jose, CA

PostPosted: Sat Sep 22, 2018 11:02 pm    Post subject: Reply with quote

If you find this thread, as of today you still have to disconnect the external monitor, boot and then plug it it to prevent the hang.
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum