Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Upgrade]->Blocked Packages [résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Sun Aug 19, 2018 12:18 pm    Post subject: [Upgrade]->Blocked Packages [résolu] Reply with quote

Bonjour,

Je me suis mis à la gentoo il y a deux mois, aujourd'hui je veux faire une mise à jour en lançant la commande :
Code:
# emerge --update --newuse --deep @world


Et là ce devient compliqué, j'ai des paquets bloqués :
le résultat de la commande est en abrégé :
Code:

[...]
[blocks B      ] sys-fs/eudev ("sys-fs/eudev" is blocking sys-apps/gentoo-systemd-integration-7, sys-apps/systemd-238-r7)
[blocks B      ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/eudev-3.2.5)
[blocks B      ] sys-apps/sysvinit ("sys-apps/sysvinit" is blocking sys-apps/systemd-238-r7)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/eudev-3.2.5)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.



Code:
 (sys-fs/eudev-3.2.5:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/eudev-2.1.1 required by (virtual/udev-217:0/0::gentoo, installed)
    >=sys-fs/eudev-1.3:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-fs/eudev-1.3:0/0[abi_x86_64(-)]) required by (virtual/libudev-232:0/1::gentoo, installed)

  (sys-apps/sysvinit-2.88-r9:0/0::gentoo, installed) pulled in by
    >=sys-apps/sysvinit-2.86-r6[selinux?] (>=sys-apps/sysvinit-2.86-r6) required by (sys-apps/openrc-0.34.11:0/0::gentoo, installed)

  (sys-apps/systemd-238-r7:0/2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-7:0/0::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (virtual/tmpfiles-0:0/0::gentoo, installed)
    sys-apps/systemd[pam] required by (sys-auth/pambase-20150213-r1:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-38 required by (virtual/logger-0:0/0::gentoo, installed)
    sys-apps/systemd:0= required by (sys-apps/dbus-1.10.24:0/0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

Malgré la lecture du manuel cité et des forums, je ne vois pas comment me sortir de ce truc , une idée ?
Merci,


Last edited by sitro on Wed Aug 29, 2018 12:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3066
Location: Paris

PostPosted: Sun Aug 19, 2018 4:17 pm    Post subject: Reply with quote

Bonjour à toi.
L'idée serait de regarder la documentation Gentoo spécifique à Systemd, car elle doit fatalement expliquer comment passer de sys-apps/sysvinit à sys-apps/systemd. A vue de nez, tu es allé un peu vite à ce niveau là.
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Sun Aug 19, 2018 4:26 pm    Post subject: Reply with quote

Bonjour,

Merci de la réponse, mais je ne vois pas ce que systemd vient faire la dedans car en process init c'est openrc, si je ne me trompe pas, j'ai laissé le système par défaut lors de l'install


Mais il y effectivement ceci qui vient en contradiction avec mon système :

Code:
(sys-apps/systemd-238-r7:0/2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-7:0/0::gentoo, ebuild scheduled for merge)
    sys-apps/systemd required by (virtual/tmpfiles-0:0/0::gentoo, installed)
    sys-apps/systemd[pam] required by (sys-auth/pambase-20150213-r1:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-38 required by (virtual/logger-0:0/0::gentoo, installed)
    sys-apps/systemd:0= required by (sys-apps/dbus-1.10.24:0/0::gentoo, ebuild scheduled for merge)
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 724
Location: S.O. France

PostPosted: Sun Aug 19, 2018 5:11 pm    Post subject: Reply with quote

Peux-tu poster ton emerge --info?
Back to top
View user's profile Send private message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Sun Aug 19, 2018 5:19 pm    Post subject: Reply with quote

gentooHP /usr/src/linux # wgetpaste -s bpaste -c 'emerge --info'


Your paste can be seen here: http://bpaste.net/show/038d7b9ee96a
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 724
Location: S.O. France

PostPosted: Sun Aug 19, 2018 5:42 pm    Post subject: Reply with quote

Poste la totalité de ton emerge --update --newuse --deep @world
T"aurais pas aussi des packages.use?
Back to top
View user's profile Send private message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Sun Aug 19, 2018 6:08 pm    Post subject: Reply with quote

Voilà,

gentooHP /usr/src/linux # emerge --update --newuse --deep @world
[...]

gentooHP /usr/src/linux # wgetpaste -s bpaste /tmp/emerge.txt


Your paste can be seen here: http://bpaste.net/show/c7370343f1b0
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 724
Location: S.O. France

PostPosted: Sun Aug 19, 2018 6:13 pm    Post subject: Reply with quote

Code:
[ebuild   R    ] sys-apps/dbus-1.10.24  USE="systemd*"
[ebuild   R    ] sys-auth/pambase-20150213-r1  USE="consolekit* systemd*"


T'as pas des entrées dans ton package.use?
Back to top
View user's profile Send private message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Sun Aug 19, 2018 7:47 pm    Post subject: Reply with quote

oui dans : /etc/portage/package.use/zz-autounmask

Code:
# required by sys-apps/systemd-238-r7::gentoo
# required by gnome-base/gnome-settings-daemon-3.24.4::gentoo
# required by gnome-extra/gnome-tweak-tool-3.24.1::gentoo
# required by gnome-base/gnome-extra-apps-3.24.2::gentoo
# required by gnome-base/gnome-3.24.2::gentoo[extras]
# required by gnome-base/gnome (argument)
>=sys-apps/dbus-1.10.24 systemd

# required by gnome-base/gdm-3.24.3::gentoo
# required by gnome-base/gnome-shell-3.24.3::gentoo
# required by gnome-extra/gnome-tweak-tool-3.24.1::gentoo
# required by gnome-base/gnome-extra-apps-3.24.2::gentoo
# required by gnome-base/gnome-3.24.2::gentoo[extras]
# required by gnome-base/gnome (argument)
>=sys-auth/pambase-20150213-r1 systemd


Ca ne me dit pas ce que je dois faire car c'est la config initiale de l'installation
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 724
Location: S.O. France

PostPosted: Sun Aug 19, 2018 7:55 pm    Post subject: Reply with quote

T"es parti de quel support d'install?
T'as changé de profil entre temps?

Je suppose que, vu ton profil, tu utilise plasma?
Vu ton package.use, c'est comme ci tu avais installé gnome.

Poste ton /var/lib/portage/world et l'intégralité de ton package.use juste pour vérifier.

La solution serait de supprimer ces entrées de ton package.use mais si tu as des paquets gnome ca va bloquer.
Back to top
View user's profile Send private message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Sun Aug 19, 2018 8:19 pm    Post subject: Reply with quote

J'utilise Mate, possible qu'il y ait des trucs de gnome, me souviens plus tout ce que j'ai bidouillé

le world et package.use -> Your paste can be seen here: http://bpaste.net/show/f8358a07d5f1
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 724
Location: S.O. France

PostPosted: Sun Aug 19, 2018 8:39 pm    Post subject: Reply with quote

Ca ressemble grandement a une install de gnome... J'ai jamais installé mate mais ca m'etonnerais qu'il ait besoin des dépendances de gnome.

1 Bascule ton profil sur default/linux/amd64/17.0/desktop (eselect profile list puis eselect profile set X)
2 Lance emerge --depclean puis revdep-rebuild.
3 Déplace ton zz.autounmask ailleurs que dans package.use tu pourra l'y remettre au cas ou
4 Relance un emerge -uDNvp @world et poste le résultat.
Back to top
View user's profile Send private message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Sun Aug 19, 2018 10:27 pm    Post subject: Reply with quote

ok merci
Il se fait tard
je verrai demain

en attendant voici le typescript

wgetpaste -s bpaste typescript
Your paste can be seen here: http://bpaste.net/show/4b4ecb8a80f9
Back to top
View user's profile Send private message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Mon Aug 20, 2018 3:53 pm    Post subject: Reply with quote

Bonjour,

Petit retour sur mes paquets bloqués

J'ai suivi les conseils
J'ai toutefois choisi le profil "gnome"
puis le emerge -depclean me donnait des trucs bizarres sur des paquets
cela m'a obligé à supprimer ou installer des paquets à la main

Puis le revdep-rebuild : me donne :

Code:
 # revdep-rebuild
 * This is the new python coded version
 * Please report any bugs found using it.
 * The original revdep-rebuild script is installed as revdep-rebuild.sh
 * Please file bugs at: https://bugs.gentoo.org/
 * Checking dynamic linking consistency

Your system is consistent


J'ai pensé que c'était cool d'avoir un système consistant
Mais quand j'ai lancé la commande :
Code:
 emerge -uDNvp @world


Je me suis retrouvé au point de départ avec des paquets bloqués :

# wgetpaste -s bpaste /tmp/emerge.txt
Your paste can be seen here: http://bpaste.net/show/610aea4b0395
Back to top
View user's profile Send private message
guitou
Guru
Guru


Joined: 02 Oct 2003
Posts: 372
Location: France

PostPosted: Mon Aug 20, 2018 4:46 pm    Post subject: Reply with quote

Bonjour.

Tu as plusieurs problemes ici, le premier etant un mix apparent entre systemd et eudev. Je suppose que tu pars d'un systeme openRC (et le profil gnome introduit la dependance a systemd). Si tu veux garder openRC, il te faut donc commencer par choisir un profil plus en adequation avec tes besoins, sinon faut te soucier de la migration de ton systeme vers systemd.
Pour le reste, si tu optes pour systemd, il faudra desinstaller eudev et si tu gardes openRC, il y'a une cette discussion dediee gnome without systemd pour gnome, ou tu as encore la possiblite d'opter pour un autre gestionnaire de bureau.
Te restera ensuite a voir pour le conflit bluetooth/blueman (je soupçonne qu'il suffit ici de faire un "emerge --deselect blueman") et celui des notification-daemon pour lequel je ne sais trop que dire.

++
Gi)
Back to top
View user's profile Send private message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Tue Aug 21, 2018 10:26 am    Post subject: Blocked Packages [résolu] Reply with quote

Bonjour,

Je commence à y voir plus clair dans le système.
Je n'avais pas compris que Gnome était dépendant de Systemd. La solution citée pour avoir Gnome et Openrc me semble pour l'instant un peu complexe et nécessite quelques lectures avant de s'y lancer. et je n'ai pas envie de basculer sur Systemd en lieu de Openrc.

Finalement pour faire rapide (ça a quand même pris la nuit à turbiner), j'ai donc opté pour un profil desktop/plasma avec openrc
j'ai enlevé temporairement Mate, supprimé un par un les paquets en conflits, mis à jour le système ,enfin ajouté plasma-meta.
Je me retrouve avec un système clean mais un environnement de bureau qui ne me plaît pas (kde-plasma).

Je vais revoir pour la possibilité de réinstaller Mate ultérieurement.

Merci pour vos aides.
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 724
Location: S.O. France

PostPosted: Wed Aug 22, 2018 4:48 pm    Post subject: Reply with quote

Oui mais non.

Ce n'est pas parce que tu choisis le profil plasma que tu dois installer plasma.
Il faudrait que tu revois le fonctionnement des USE et des profils.

Un profil introduit des USE générales et sur certains paquets.
Regarde la partie USE de ton emerge --info.
Change de profil par ex le default/linux/amd64/17.0/ et compare les USE.

Mate doit s'installer sans problème sur n'importe quel profil.
Par contre la version stable de gentoo est très ancienne.
Back to top
View user's profile Send private message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Wed Aug 29, 2018 8:16 am    Post subject: make: *** Aucune règle pour fabriquer la cible « menuconfig  Reply with quote

Re,

Nouveau problème qui suit

Je suppose à la suite de emerge --depclean, je ne peux plus compiler le noyau
J'ai ce message : make: *** Aucune règle pour fabriquer la cible « menuconfig 

Voici ce que j'ai tenté sans succès :
Code:

gentooHP /usr/src/linux # make menuconfig
make: *** Aucune règle pour fabriquer la cible « menuconfig ». Arrêt.
gentooHP /usr/src/linux # eselect kernel list
Available kernel symlink targets:
  [1]   linux-4.14.63-gentoo-r1
gentooHP /usr/src/linux # uname -a
Linux gentooHP 4.9.95-gentoo #7 SMP Mon Aug 20 16:38:46 CEST 2018 x86_64 Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz GenuineIntel GNU/Linux
gentooHP /usr/src/linux # eselect kernel show
Current kernel symlink:
  /usr/src/linux-4.9.95-gentoo
!!! Warning: Symlink target doesn't appear to be valid!
gentooHP /usr/src/linux # eselect kernel set 1
gentooHP /usr/src/linux # eselect kernel show
Current kernel symlink:
  /usr/src/linux-4.14.63-gentoo-r1
gentooHP /usr/src/linux # uname -a
Linux gentooHP 4.9.95-gentoo #7 SMP Mon Aug 20 16:38:46 CEST 2018 x86_64 Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz GenuineIntel GNU/Linux
gentooHP /usr/src/linux # make menuconfig
make: *** Aucune règle pour fabriquer la cible « menuconfig ». Arrêt.
gentooHP /usr/src/linux #


Je ne vois pas comment me sortir de ce guêpier, une idée ?
Back to top
View user's profile Send private message
sitro
n00b
n00b


Joined: 19 Aug 2018
Posts: 19

PostPosted: Wed Aug 29, 2018 8:30 am    Post subject: Reply with quote

Je poursuis mes investigations sur la compilation du noyau
et je viens de faire ceci :

Code:
gentooHP /usr/src # ls -al
total 16
drwxr-xr-x  4 root root 4096 29 août  10:07 .
drwxr-xr-x 13 root root 4096 23 juin  13:03 ..
-rw-r--r--  1 root root    0 14 juin  23:54 .keep
lrwxrwxrwx  1 root root   23 29 août  10:07 linux -> linux-4.14.63-gentoo-r1
drwxr-xr-x 25 root root 4096 29 août  10:26 linux-4.14.63-gentoo-r1
drwxr-xr-x 22 root root 4096 21 août  08:42 linux-4.9.95-gentoo
gentooHP /usr/src #

gentooHP /usr/src/linux # cp linux-4.9.95-gentoo/.config linux-4.14.63-gentoo-r1/


Le make menuconfig refonctionne
Mais est-ce correct de copier un .config d'une source vers une autre ? n'y a -t-il pas ajout/suppression d'option du .config entre sources ?
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3066
Location: Paris

PostPosted: Wed Aug 29, 2018 10:19 am    Post subject: Reply with quote

Bonjour Sitro,
Ces questions sont fondamentales et légitimes... et figurent dans la documentation bien évidemment ;)

Et comme je suis dans une phase de modératite aiguë, peux-tu STP mettre ton titre en conformité?

Pour ton problème précédent de make menuconfig, tu as du tout simplement désinstaller le noyau en question et tu n'avais donc pas de sources à compiler. Et si tu as de nouveaux problèmes, n'hésite pas à ouvrir des threads individuels.
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum